Jump to content

Search the Community

Showing results for tags 'Logs'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 17 results

  1. Since I installed Wireguard on my raspberry pi4, where I have emby server runnin, I got the logs flooded with: 2021-09-15 00:01:03.504 Error App: Error sending socket message from 10.6.0.1:33412 to 239.255.255.250:1900 *** Error Report *** Version: 4.6.4.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_armhf.deb Operating system: Linux version 5.10.60-v7l+ (dom@buildbot) (arm-linux-gnueabihf-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #144 Framework: .NET Core 3.1.13 OS/Process: arm/arm Runtime: opt/emby-server/system/System.Private.CoreLib.dll Processor count: 4 Data path: /var/lib/emby Application path: /opt/emby-server/system System.Net.Sockets.SocketException: System.Net.Sockets.SocketException (0xFFFFFFFF): Bad value for ai_flags at Rssdp.SsdpCommunicationsServer.SendFromSocket(Tuple`3 socketTuple, Memory`1 messageData, IPEndPoint destination, CancellationToken cancellationToken) Source: System.Private.CoreLib TargetSite: Void Throw() 2021-09-15 00:01:03.712 Error App: Error sending socket message from 10.6.0.1:33412 to 239.255.255.250:1900 *** Error Report *** Version: 4.6.4.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_armhf.deb Emby seems to be working fine so maybe it is not a real problem but I would like to hear if any suggestion on how to avoid this. Thanks
  2. Paul898

    Installation Location

    Hey, I am NEW to Emby. Is there a way to to have the server install on a specific drive? I have a small C drive where windows is located and would like to have Emby and all the data and logs for it located on my D drive that is a lot larger. How can i set it up on a drive Different drive? From what i see most logs and files can be moved but not the program. please help
  3. This is a follow on to the Transport Stream Conversions Fail thread earlier in this forum. I'm rapidly coming to the conclusion that attempting to use the convert function on the Shield version of Emby is downright dangerous. Having converted a file and placed the converted file alongside the original, I opened the info circle on that program and scrolled down to the Media Info section which displays file format details. I then made the fatal mistake of clicking on the "Split Versions Apart" link just under the Media Info label. This has disabled playing any video in any of the Emby libraries through the web interface or on the TV to which the Shield is connected. Each attempt to play anything spawns about a dozen ffmpeg instances (all in about 1 second!). Restarting the server has no effect on the problem! Attempting to play anything on the web interface of course fails by bringing up the (useless) dreaded green Got It! button which does nothing but attempt to replay the program and thus spawn another dozen ffmpeg instances. Log file attached along with the list of log files generated by a play attempt. Unless someone has a suggestion I suspect the only way forward is de-install the Emby server and reconfigure a new instance. Since the media library is on a network drive and the Emby and Plex library formats are similar, I torn between doing that and just switching to the Plex server. (Thankfully I only did a month-to-month subscription to Emby Premiere until I was confident everything was working... which it obviously isn't). In any event, file conversion on the Shield version of the Emby server appears far too dangerous to use. embyserver.txt LogList.txt
  4. livtyler

    Thumbnail Generator doesnt work.

    Hi all having an issue with emby generating episode images, and I can see this error related to it. Thanks for the help. 2020-04-22 22:04:56.454 Error ChapterImagesTask: Error creating thumbnails for smb://10.2.x.xx/Multimedia/tv/Avenue 5/Season 1/Avenue 5 - S01E01 - I Was Flying WEBDL-1080p.mkv *** Error Report *** Version: 4.5.0.6 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb Operating system: Unix 4.15.0.96 64-Bit OS: True 64-Bit Process: True User Interactive: True Runtime: file:///opt/emby-server/system/System.Private.CoreLib.dll System.Environment.Version: 3.1.2 Processor count: 10 Program data path: /var/lib/emby Application directory: /opt/emby-server/system System.NotSupportedException: System.NotSupportedException: Stream does not support writing. at System.IO.StreamHelpers.ValidateCopyToArgs(Stream source, Stream destination, Int32 bufferSize) at System.IO.Stream.CopyTo(Stream destination, Int32 bufferSize) at Emby.Server.Implementations.IO.ManagedFileSystem.CopyFileUsingStreams(String source, String target, Boolean overwrite) at Emby.Server.Implementations.IO.ManagedFileSystem.CopyFile(String source, String target, Boolean overwrite) at MediaBrowser.Providers.MediaInfo.ThumbnailGenerator.CreateThumbnailSet(Video item, LibraryOptions libraryOptions, Int32 width, CancellationToken cancellationToken) at MediaBrowser.Providers.MediaInfo.ThumbnailGenerator.CreateThumbnailSets(Video item, LibraryOptions libraryOptions, CancellationToken cancellationToken) at MediaBrowser.Providers.MediaInfo.ThumbnailGenerator.RefreshThumbnailImages(Video item, LibraryOptions libraryOptions, IDirectoryService directoryService, List`1 chapters, Boolean extractImages, Boolean saveChapters, CancellationToken cancellationToken) Source: System.Private.CoreLib TargetSite: Void ValidateCopyToArgs(System.IO.Stream, System.IO.Stream, Int32) I dont think its a permission issue, and I cant think what else it could be, ive started pulling my hair out.
  5. Recently the logs started filling up with a error that looks related to playback progress. Has anyone seen this? Log attached. embyserver.txt
  6. It seems that the ffmpeg-transcode-* log files are not being rotated by the "Rotate Log File" scheduled task. No errors reported in the console logs. Other log files in the same directory are deleted as expected. 1.8GB of transcode logs built up before I manually cleared. Debug logging is not enabled; should these logs even be generating? Is there an option to turn those off? Thanks!
  7. Not sure if normal or not but i noticed my main disk (SSD) usage was at 100% came to find tham emby logs accounted for 119GB of my 250GB disk. I think it might be some form of run-away log issue? by running sudo du -hsx /var/lib/emby-server/logs/* | sort -rh | head -n 35 you can see the 35 biggest log files. here are my top 5: 116G /var/lib/emby-server/logs/server-63639475200.txt 2.9G /var/lib/emby-server/logs/server-63639388800.txt 45M /var/lib/emby-server/logs/server-63639302400.txt 35M /var/lib/emby-server/logs/server-63639216000.txt 936K /var/lib/emby-server/logs/server-63639189005.txt I've removed the files from my server now, but just incase anyone else had the issue.
  8. Hello, In this thread: http://mediabrowser.tv/community/index.php?/topic/12014-large-library-causing-issues/page-1 it is mentioned the server logfiles are available on the internet without any form of authentication. @@ebr responds to this with: I have not changed anything in my site configuration, I've done a standard installation so the installer configured the webserver for me. I am able to open my logs folder over the internet without any authentication, so it seems to me Media Browser does this out of the box. To test it, use this link, but include your own hostname (or IP address) and logfilename. http://[HOSTNAME]:8096/mediabrowser/System/Logs/ http://[HOSTNAME]:8096/mediabrowser/System/Logs/log?name=[VALIDLOGFILENAME] Cheers, Danee
  9. ruands

    Server Logging Issue

    First off, I love Emby as a media server. I just have one small issue with it though. I recently started having issues with my C drive filling up randomly. My first thought was just Windows updates. So I ran WinDirStat to find the culprit and found that the log folder under C:\Users\<user>\AppData\Roaming\Emby-Server\logs was 36GB. All log files were small except for one server-xxxx file. This seemed to start happening after Emby-server had an update. As a software engineer myself, I understand the importance of log files, but that seems a bit excessive. I unfortunately have no screenshot of this file, although I wish I had taken one. Can we have a setting for only logging errors instead of logging HttpServer responses as well?
  10. Since 3.1 (I think), whenever I restart emby-server using the command /etc/init.d/emby-server restart or service emby-server restart (or with start instead of restart) it starts spewing out log information on what appears to be stdout. Has anyone else had this issue? Also, it doesn't seem that triggering a restart from the management page works - it kills emby-server, but I have to manually start it (which is why I noticed this problem in the first place).
  11. Hi All, Does anyone know what is happening and/or why? I am getting an unhanded exception log on a daily basis at 5am. I guess a scheduled task is running into problem, but I cant tell what is it. From the log the main think that sticks out is a sqllite locking issue. The only thing weird I have noticed on my server is that a bunch of TV shows are not available. Its possibly off topic so I have posted about this issue separately as I dont want to pollute this thread. here is the log: htpc@ubuntutv:/var/lib/emby-server/logs$ cat unhandled_39663c63-c883-4c5b-977a-aec5c4622834.txt One or more errors occurred. System.AggregateException at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) <0x7f25de0a12e0 + 0x005a9> in <filename unknown>:0 at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, Int32 millisecondsTimeout) <0x7f25de0a1280 + 0x00028> in <filename unknown>:0 at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks) <0x7f25de0a11f0 + 0x00016> in <filename unknown>:0 at MediaBrowser.Server.Mono.MainClass.RunApplication (MediaBrowser.Server.Implementations.ServerApplicationPaths appPaths, ILogManager logManager, MediaBrowser.Server.Startup.Common.StartupOptions options) <0x4037d120 + 0x00398> in <filename unknown>:0 at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) <0x40325ff0 + 0x001c7> in <filename unknown>:0 InnerException: System.Data.SQLite.SQLiteException database is locked database is locked at System.Data.SQLite.SQLite3.Prepare (System.Data.SQLite.SQLiteConnection cnn, System.String strSql, System.Data.SQLite.SQLiteStatement previous, UInt32 timeoutMS, System.String& strRemain) <0x404a37e0 + 0x00cbb> in <filename unknown>:0 at System.Data.SQLite.SQLiteCommand.BuildNextCommand () <0x404a3350 + 0x00214> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f25de0018a0 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f25ddfff880 + 0x000a7> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f25ddfff800 + 0x0006b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f25ddfff7b0 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () <0x7f25ddfffce0 + 0x00012> in <filename unknown>:0 at MediaBrowser.Server.Implementations.Persistence.SqliteExtensions+<ConnectToDb>c__async0.MoveNext () <0x4047add0 + 0x005ea> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f25de0018a0 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f25ddfff880 + 0x000a7> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f25ddfff800 + 0x0006b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f25ddfff7b0 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f25ddfffee0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Server.Implementations.Persistence.SqliteItemRepository+<CreateConnection>c__async0.MoveNext () <0x404eba90 + 0x00231> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f25de0018a0 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f25ddfff880 + 0x000a7> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f25ddfff800 + 0x0006b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f25ddfff7b0 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f25ddfffee0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Server.Implementations.Persistence.SqliteItemRepository+<Initialize>c__async1.MoveNext () <0x404e9000 + 0x001b8> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f25de0018a0 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f25ddfff880 + 0x000a7> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f25ddfff800 + 0x0006b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f25ddfff7b0 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () <0x7f25ddfffce0 + 0x00012> in <filename unknown>:0 at MediaBrowser.Server.Startup.Common.ApplicationHost+<RegisterResources>c__async2.MoveNext () <0x40469000 + 0x0809c> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f25de0018a0 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f25ddfff880 + 0x000a7> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f25ddfff800 + 0x0006b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f25ddfff7b0 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () <0x7f25ddfffce0 + 0x00012> in <filename unknown>:0 at MediaBrowser.Common.Implementations.BaseApplicationHost`1+<Init>c__async0[TApplicationPathsType].MoveNext () <0x4041a4f0 + 0x008df> in <filename unknown>:0 htpc@ubuntutv:/var/lib/emby-server/logs$
  12. Hi there. I am running emby server on my mac. Using kodi as a client (I cannot play files via the emby Web app at all). Episodes get updated as having been watched correctly, however the progress is not being stored. I get no option to resume playback. The file simply resets watch status to "unwatched" (I assume so because the plot gets hidden to prevent spoilers again.) and the episode starts again from the beginning. Where should I begin to diagnose this? Stats: Mac mini: OS X 10.7.2 Emby Server version 3.0.5724.4 Kodi version: 15.2RC1 Git:2015-08-28-59716ca DB Version(in logs and dashboard): 1.1.39 Play method: "direct stream" Kodi does report its current status and play duration to the dashboard. The nfo file for that episode in particular does not appear to contain any watched indicator nor progress information. If I watch the file to near completion, then hit stop - kodi treats it as watched however if I then edit the nfo there isn't even a watched status tag in the xml. There are so many logs to go through which I will gladly do of you can tell me what I should be looking for.
  13. I was just checking on my hosted vanity domain and while poking around cPanel I thought that Emby could use some of the same log viewing and downloading functionality. Instead of digging around the file system, a user experiencing an issue can go to the admin panel to view and download logs. This would help less technical users as well as power users that manage servers remotely. I would like to request a feature under "Manage Server" to view and download logs. I recommend putting it under Users or Metadata to keep it near the top. It should have the ability to select and display a log file formatted (spacing/line feeds) in a scrolling window. It would be nice to separate transcoding logs from server logs as well as provide the ability to sort by date and size.
  14. Hi At the moment, we have the progress bars for the scanning of the libraries. Could we have an additional little log window, that tells us what it's doing in a simple form? So it could look like this: I'd love to know what it's actually doing...
  15. schmitty

    Logs path

    Hello, Is there somewhere I can change the location of the logs directory? so I can have them stored on my Emby share, with the cache, dashboard-ui, downloads, metadata and transcoding-temp directories,
  16. saitoh183

    MBS - Log size option

    Would it be possible to add a configurable option to limit the maximum size a log can be. This would be to insure that we can always open the log via the webclient (which currently isnt the case). When we need to debug or something causes the log to grow really quickly, The webclient will fail to open it because of its size and all you get when you try is Then your forced to navigate to the logs location and try to open it (because if its to big , its usuless). Yes i know MBS creates a new file at 12:00am and yes it also creates a new log when you restart it, but that is not a solution when your MBS is used by alot of people and you cant always just restart.
  17. http://pastebin.com/api Of course have some way to automatically sanitize logs... i.e. remove ip address, etc...
×
×
  • Create New...