Jump to content

Search the Community

Showing results for tags 'HLS'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 9 results

  1. Hi Guy's, To be clear this is only with the webapp and presuming this is due to HLS caching problem since there is some proof in the console. Seen allot of threads in this forum about pausing video maybe this might solve a few more of them. So playback stops randomly (faster with higher bitrate content, which makes sense) and error's out in the chrome console with the errors in the attached screenshot. The only thing that helps is restarting the video, unpausing is not an option since HLS already errored out. Also checked my transcoding settings etc. But even without transcoding this happens. And with transcoding I can trick the webplayer with lower bitrate content to keep playing. Oh and I noticed that "H264 encoding CRF" had noticeable impact, I always had it on 18 but going higher (now on 30) helps with this issue. (Or its a placebo effect since I can't measure when the buffer runs out) Now I've done some digging towards the solution, and I know this is close to blasphemy but here is the link , since it contains a possible solution to the problem.
  2. Sorry if this is addressed somewhere else in advance. I was testing if I can play a mkv file with hevc x1, flac x2, ass x1, and ttf subset x5 (media info as below) I want to ensure the video on my server can be directly played while showing ass effect with fonts properly on android, ios and PC platforms without encoding (hard-sub) PC: web is not okay for ass effect, but the PC client I am using (not standard emby theater) is able to show correctly (directly play) Android: app is not smooth enough (Exoplayer I assumed?), switched to VLC player, became smooth and ass display is correct (directly play) IOS(both on iPad and iphone): container is not compatiable and HLS format is needed, HEVC is directly played, while flac needs to be transcoded to mp3 (while the same flac is directly played with AVC + Flac in mkv container), fonts of ass is not used and turned to be the default font. (not directly play) I would like to know: 1. What is the compatiable container for IOS app? HLS format appeared even if the audio is aac in mkv container or flac in mp4 container with HEVC as video stream. Any way to get around this? 2. I think the emby app can support ass effect with fonts, but it turned out not the case in IOS. Is there any method to show embed fonts for ass subtitle on IOS platform? ___________________________________________________________________________________________________________ It shows HVC1 in MPC-HC player Video: HVC1 1920x1080 23.976fps [V: hevc rext L4.0, yuv444p10le, 1920x1080 [default]] Audio: FLAC (framed) 48000Hz stereo 2304kbps [A: flac, 48000 Hz, stereo, s24 [default]] Audio: FLAC (framed) 48000Hz stereo 2304kbps [A: コメンタリー (flac, 48000 Hz, stereo, s24)] Subtitle: Advanced SubStation Alpha [S: 繁體 [cht] (ass) [default]] Subtitle: UTF-8 [S: No subtitles] ___________________________________________________________________________________________________________ General Unique ID : 156709209093414132247110442661145388684 (0x75E51888AB9ECBEF1F908B7C139AA68C) Complete name : \\...xxxxx...S01.E02.[AI-Raws].mkv Format : Matroska Format version : Version 4 File size : 1.16 GiB Duration : 23 min 41 s Overall bit rate mode : Variable Overall bit rate : 7 020 kb/s Movie name : S01.E02.[AI-Raws] Writing application : Lavf58.76.100 Writing library : Lavf58.76.100 ErrorDetectionType : Per level 1 Attachments : 仓耳今楷01 W05.146F4902.ttf / 方正粗圆_GBK.1C4025C1.ttf / 方正新楷体_GBK.3819E60D.ttf / 方正仿宋_GBK.E9AA63B2.TTF / 仓耳今楷01-27533 W03.1C19A3A6.ttf Video ID : 2 Format : HEVC Format/Info : High Efficiency Video Coding Format profile : Format Range@L4@High Codec ID : V_MPEGH/ISO/HEVC Duration : 23 min 41 s Bit rate : 4 242 kb/s Width : 1 920 pixels Height : 1 080 pixels Display aspect ratio : 16:9 Frame rate mode : Constant Frame rate : 23.976 (24000/1001) FPS Chroma subsampling : 4:4:4 Bit depth : 10 bits Bits/(Pixel*Frame) : 0.085 Stream size : 719 MiB (60%) Writing library : x265 2.9+8-27d8424c799d:[Windows][MSVC 1900][64 bit] 10bit Encoding settings : cpuid=1111039 / frame-threads=4 / numa-pools=16 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / input-csp=3 / input-res=1920x1080 / interlace=0 / total-frames=0 / level-idc=0 / high-tier=1 / uhd-bd=0 / ref=4 / no-allow-non-conformance / no-repeat-headers / annexb / no-aud / no-hrd / info / hash=0 / no-temporal-layers / open-gop / min-keyint=23 / keyint=250 / gop-lookahead=0 / bframes=4 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=25 / lookahead-slices=4 / scenecut=40 / radl=0 / no-intra-refresh / ctu=64 / min-cu-size=8 / rect / no-amp / max-tu-size=32 / tu-inter-depth=1 / tu-intra-depth=1 / limit-tu=0 / rdoq-level=2 / dynamic-rd=0.00 / no-ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / strong-intra-smoothing / max-merge=3 / limit-refs=3 / limit-modes / me=3 / subme=3 / merange=57 / temporal-mvp / weightp / no-weightb / no-analyze-src-pics / deblock=0:0 / sao / no-sao-non-deblock / rd=4 / no-early-skip / rskip / no-fast-intra / no-tskip-fast / no-cu-lossless / no-b-intra / no-splitrd-skip / rdpenalty=0 / psy-rd=2.00 / psy-rdoq=1.00 / no-rd-refine / no-lossless / cbqpoffs=6 / crqpoffs=6 / rc=crf / crf=14.5 / qcomp=0.60 / qpstep=4 / stats-write=0 / stats-read=0 / vbv-maxrate=25600 / vbv-bufsize=10240 / vbv-init=0.9 / crf-max=0.0 / crf-min=0.0 / ipratio=1.40 / pbratio=1.30 / aq-mode=1 / aq-strength=1.00 / cutree / zone-count=0 / no-strict-cbr / qg-size=32 / no-rc-grain / qpmax=31 / qpmin=0 / no-const-vbv / sar=0 / overscan=0 / videoformat=5 / range=0 / colorprim=1 / transfer=2 / colormatrix=2 / chromaloc=0 / display-window=0 / max-cll=0,0 / min-luma=0 / max-luma=1023 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / no-opt-cu-delta-qp / no-aq-motion / no-hdr / no-hdr-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=5 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-mv-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei Default : Yes Forced : No Color range : Limited Color primaries : BT.709 Audio #1 ID : 3 Format : FLAC Format/Info : Free Lossless Audio Codec Codec ID : A_FLAC Duration : 23 min 41 s Bit rate mode : Variable Bit rate : 1 474 kb/s Channel(s) : 2 channels Channel layout : L R Sampling rate : 48.0 kHz Frame rate : 11.719 FPS (4096 SPF) Bit depth : 24 bits Compression mode : Lossless Stream size : 250 MiB (21%) Default : Yes Forced : No Audio #2 ID : 4 Format : FLAC Format/Info : Free Lossless Audio Codec Codec ID : A_FLAC Duration : 23 min 41 s Bit rate mode : Variable Bit rate : 1 296 kb/s Channel(s) : 2 channels Channel layout : L R Sampling rate : 48.0 kHz Frame rate : 11.719 FPS (4096 SPF) Bit depth : 24 bits Compression mode : Lossless Stream size : 220 MiB (18%) Title : コメンタリー Default : No Forced : No Text ID : 1 Format : ASS Codec ID : S_TEXT/ASS Codec ID/Info : Advanced Sub Station Alpha Duration : 23 min 40 s Compression mode : Lossless Title : 繁體 Language : cht Default : Yes Forced : No Menu 00:00:00.000 : :第 01 章 00:00:23.023 : :第 02 章 00:01:53.030 : :第 03 章 00:11:17.051 : :第 04 章 00:17:50.027 : :第 05 章 00:19:20.076 : :第 06 章 00:23:35.039 : :第 07 章 ___________________________________________________________________________________________________________
  3. Hello, im trying to watch live tv via the emby-next-gen addon (6.2.15). Unfortunately this fails. When I select a channel on kodi (19.4), i get a spinning wheel, followed by the error message: One or more items failed to play. Check the log for more information about this message. when i try and play the same channel on my android phone with the emby app it plays fine. I even installed the kodi app on my phone to see if the behaviour would be different but I get the same error. the same error happens when I install the emby-next-gen addon from the emby beta repository. I have included the debug kodi log and the debug emby server log. i start the stream at 22:49. sorry i did not find the option in emby-next-gen addon to enable debug logging embyserver-63790325406.txt kodi.log
  4. There is a great Plugin on Plex for the NFL Gamepass live streams and game rewind features for the NFL GamePass Subscribers. I love this plugin for Plex but would love to tie it in to my Emby setup so I can only use one of them! Please let me know what this would take and if it's doable! Here's a link to the GitHub page for this plugin! https://github.com/41john/NFL.bundle Thanks a lot!
  5. Before a video stops playing, I get the "Loading, please wait" message on the screen, similar to what others have reported. When I checked the server log, there is an entry waiting for the next .ts file, but it doesn't exist, nor is it listed in the m3u8 playlist file: 2015-03-18 11:27:04.8893 Info - App: waiting for C:\Users\Media\AppData\Roaming\MediaBrowser-Server\transcoding-temp\c1f49a88b916337905bab9c2a49fedc2833.tsHere are a few lines before that message: 015-03-18 11:27:03.2292 Debug - HttpServer: HTTP GET http://192.168.1.140:8096/mediabrowser/Videos/cf3d75f18b5b35930747c52a1e746a25/hlsdynamic/main/832.ts?mediaSourceId=cf3d75f18b5b35930747c52a1e746a25&maxWidth=1920&maxHeight=1080&videoCodec=h264&profile=high&level=41&deviceId=1MH361020127&ClientTime=1426677997&MaxVideoBitDepth=8&MaxRefFrames=8&AudioCodec=aac&MaxAudioChannels=2&AudioStreamIndex=1&AudioBitrate=128000&VideoBitrate=30000000 Ip: 192.168.1.11:56786. Headers: Host=192.168.1.140:8096,User-Agent=Roku/DVP-6.1 (076.01E05516A) 2015-03-18 11:27:03.3593 Debug - HttpServer: HTTP POST http://192.168.1.140:8096/mediabrowser/Sessions/Playing/Progress?itemId=cf3d75f18b5b35930747c52a1e746a25&PositionTicks=24210000000&isPaused=false&canSeek=true&PlayMethod=Transcode&QueueableMediaTypes=Video&MediaSourceId=cf3d75f18b5b35930747c52a1e746a25&AudioStreamIndex=1 Ip: 192.168.1.11:56773. Headers: User-Agent=Roku/DVP-6.1 (076.01E05516A),Host=192.168.1.140:8096,Accept=*/*,Accept-Encoding=deflate, gzip,Authorization=MediaBrowser Client="Roku", Device="Now TV", DeviceId="1MH361020127", Version="1.87", UserId="fe8e98c1df54d9b502474bab46ee8982",X-MediaBrowser-Token=fe17adc1b0f54bbab72ad6f22eaf7368,Content-Length=0,Content-Type=application/x-www-form-urlencoded 2015-03-18 11:27:03.3593 Debug - HttpServer: HTTP Response 204 to 192.168.1.11. Response time: 2.0001 ms. Url: http://192.168.1.140:8096/mediabrowser/Sessions/Playing/Progress?itemId=cf3d75f18b5b35930747c52a1e746a25&PositionTicks=24210000000&isPaused=false&canSeek=true&PlayMethod=Transcode&QueueableMediaTypes=Video&MediaSourceId=cf3d75f18b5b35930747c52a1e746a25&AudioStreamIndex=1 2015-03-18 11:27:04.3533 Debug - HttpServer: HTTP POST http://192.168.1.140:8096/mediabrowser/Sessions/Playing/Progress?itemId=cf3d75f18b5b35930747c52a1e746a25&PositionTicks=24220000000&isPaused=false&canSeek=true&PlayMethod=Transcode&QueueableMediaTypes=Video&MediaSourceId=cf3d75f18b5b35930747c52a1e746a25&AudioStreamIndex=1 Ip: 192.168.1.11:56773. Headers: User-Agent=Roku/DVP-6.1 (076.01E05516A),Host=192.168.1.140:8096,Accept=*/*,Accept-Encoding=deflate, gzip,Authorization=MediaBrowser Client="Roku", Device="Now TV", DeviceId="1MH361020127", Version="1.87", UserId="fe8e98c1df54d9b502474bab46ee8982",X-MediaBrowser-Token=fe17adc1b0f54bbab72ad6f22eaf7368,Content-Length=0,Content-Type=application/x-www-form-urlencoded 2015-03-18 11:27:04.3553 Debug - HttpServer: HTTP Response 204 to 192.168.1.11. Response time: 2.0001 ms. Url: http://192.168.1.140:8096/mediabrowser/Sessions/Playing/Progress?itemId=cf3d75f18b5b35930747c52a1e746a25&PositionTicks=24220000000&isPaused=false&canSeek=true&PlayMethod=Transcode&QueueableMediaTypes=Video&MediaSourceId=cf3d75f18b5b35930747c52a1e746a25&AudioStreamIndex=1 2015-03-18 11:27:04.8663 Debug - HttpServer: HTTP Response 200 to 192.168.1.11. Response time: 1637.0936 ms. Url: http://192.168.1.140:8096/mediabrowser/Videos/cf3d75f18b5b35930747c52a1e746a25/hlsdynamic/main/832.ts?mediaSourceId=cf3d75f18b5b35930747c52a1e746a25&maxWidth=1920&maxHeight=1080&videoCodec=h264&profile=high&level=41&deviceId=1MH361020127&ClientTime=1426677997&MaxVideoBitDepth=8&MaxRefFrames=8&AudioCodec=aac&MaxAudioChannels=2&AudioStreamIndex=1&AudioBitrate=128000&VideoBitrate=30000000 2015-03-18 11:27:04.8893 Debug - HttpServer: HTTP GET http://192.168.1.140:8096/mediabrowser/Videos/cf3d75f18b5b35930747c52a1e746a25/hlsdynamic/main/833.ts?mediaSourceId=cf3d75f18b5b35930747c52a1e746a25&maxWidth=1920&maxHeight=1080&videoCodec=h264&profile=high&level=41&deviceId=1MH361020127&ClientTime=1426677997&MaxVideoBitDepth=8&MaxRefFrames=8&AudioCodec=aac&MaxAudioChannels=2&AudioStreamIndex=1&AudioBitrate=128000&VideoBitrate=30000000 Ip: 192.168.1.11:56786. Headers: Host=192.168.1.140:8096,User-Agent=Roku/DVP-6.1 (076.01E05516A) 2015-03-18 11:27:04.8893 Info - App: waiting for C:\Users\Media\AppData\Roaming\MediaBrowser-Server\transcoding-temp\c1f49a88b916337905bab9c2a49fedc2833.ts c1f49a88b916337905bab9c2a49fedc2.m3u8 c1f49a88b916337905bab9c2a49fedc2831.ts #EXTINF:9.384000, c1f49a88b916337905bab9c2a49fedc2832.ts #EXT-X-ENDLISTNot sure if this is related to the cut-off of playback that the Android TV testers are seeing, but it's a very similar problem. Server log here. Transcode log here. The m3u8 file and the .ts files listed in it are in this ZIP file for reference - it is ~50Mb in size though. .
  6. I'm writing a channel plugin which fetches links to HLS streams from external source. What is the right way to tell MBS that this an HLS stream when creating ChannelMediaInfo object? My goal is to avoid transcoding HLS streams when playing on devices which support HLS. I have tried this: new ChannelMediaInfo{ Path = "http://example.com/hls_streams/test.m3u8", Container = "mpegts", AudioCodec = "aac", VideoCodec = "h264", Protocol = MediaProtocol.Http, SupportsDirectPlay = true } but the stream is still transcoded when trying to play on Android (which supports HLS). I have written similar channel plugin for the Plex and it plays without transcoding on Android, but in Plex I can specify protocol=hls explicitly from plugin.
  7. Cerothen

    IIS Reverse Proxy HLS

    I have been using the reverse proxy setup for a while now using IIS with ARR and its been working pretty well. I have however been having a heck of a time using the chromecast with this particular setup. The issue that I have is whenever I do anything (browse around the web client or try to play a video to it) there is a popup indicating that the URI scheme is not valid. In my internet travels it appears that this could be relating to the host header that is sent to the mediabrowser client from IIS when it writes the HLS list for the client (chromecast) however I am not certain. I have tried to do a few things that I saw in hopes it would solve the issue including: Turn on preserve host in IIS: http://stackoverflow.com/questions/14841986/iis-aar-url-rewrite-for-reverse-proxy-how-to-send-http-host I have tried using ARR helper: http://forums.iis.net/t/1214989.aspx?ARR+Helper+for+IIS8+ And tried setting a server variable: http://tiku.io/questions/2950025/does-iis-with-arr-support-fully-transparent-reverse-proxy This is the rewrite rules that are applied: <rule name="Redirect to HTTPS" enabled="true" stopProcessing="true"> <match url="(.*)" /> <conditions logicalGrouping="MatchAll" trackAllCaptures="false"> <add input="{HTTPS}" pattern="^OFF$" /> </conditions> <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="SeeOther" /> </rule> <rule name="RewriteRemoteAddr"> <match url="(.*)" /> <conditions> <add input="{HTTP_X_FORWARDED_FOR}" pattern="([_0-9a-zA-Z]+)" /> </conditions> <serverVariables> <set name="{REMOTE_ADDR}" value="{HTTP_X_FORWARDED_FOR}" /> </serverVariables> <action type="None" /> </rule> <rule name="Mediabrowser 1" enabled="true" stopProcessing="true"> <match url="mediabrowser(.*)" /> <conditions logicalGrouping="MatchAll" trackAllCaptures="false" /> <action type="Rewrite" url="http://localhost:8096/{R:0}" /> </rule> The typical error in mediabrowser: 2015-02-13 13:14:49.0142 Error - HttpServer: Error processing request for /mediabrowser/System/Endpoint *** Error Report *** Version: 3.0.5518.3 Command line: C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe -service Operating system: Microsoft Windows NT 6.2.9200.0 Processor count: 8 64-Bit OS: True 64-Bit Process: False Program data path: C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server Application Path: C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe Invalid URI: The URI scheme is not valid. ServiceStack.HttpError No Stack Trace Available 2015-02-13 13:14:49.0142 Error - DtoUtils: ServiceBase<TRequest>::Service Exception *** Error Report *** Version: 3.0.5518.3 Command line: C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe -service Operating system: Microsoft Windows NT 6.2.9200.0 Processor count: 8 64-Bit OS: True 64-Bit Process: False Program data path: C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server Application Path: C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe Invalid URI: The URI scheme is not valid. System.UriFormatException at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind) at System.Uri..ctor(String uriString) at MediaBrowser.Common.Implementations.Networking.BaseNetworkManager.IsInLocalNetworkInternal(String endpoint, Boolean resolveHost) at MediaBrowser.ServerApplication.Networking.NetworkManager.MediaBrowser.Common.Net.INetworkManager.IsInLocalNetwork(String ) at MediaBrowser.Api.System.SystemService.Get(GetEndpointInfo request) at lambda_method(Closure , Object , Object ) at ServiceStack.Host.ServiceRunner`1.Execute(IRequest request, Object instance, TRequest requestDto) I am trying to stick with IIS since I am using the remote desktop gateway feature and Apache doesn't support it. Any advise that experienced users can bestow unto me would be much appreciated. Thanks!
  8. I'm running into an issue with HLS support and LiveTV. Using the Android client (2.0.85) on my Nexus 5 (Kitty Kat 4.4.4) I have HLS support turned off due to a nasty stuttering issue. When I attempt to view LiveTV it hangs the Android app -- I press the "View Now" button. I see the white circle (which isn't spinning) and that's it. It hangs the client app pretty hard. If I turn HLS Support back on, it exhibits the stuttering issue after viewing for a short period of time (8 to 10 minutes). Can ServerWMC and LiveTV plugin work without HLS support? I sure would be nice if Google would fix their HLS so it doesn't have the stuttering issue -- apparently affects Android 4.4.3 and 4.4.4, and I've even heard rumors Android L continues to be broken). Some details: Mediabrowser Server 3.0.5395.0 Mediabrowser ServerWMC plugin 1.0.0.43 ServerWMC 1.0.0.42 build 1167 Android Mediabrowser App (2.0.85) Nexus 5, running Kitty Kat 4.4.4 Thank You for all the awesome work you guys have been doing.
  9. I have been playing around with the app now for a little while and was testing for bugs. One that I noticed was that when I have HLS enabled in the settings, I can play a video from the beginning. However, if I use the slider to skip ahead a long ways, it causes the playback to hang and the app becomes unresponsive. What makes this even more interesting is that the server will not playback to the webclient after the Android app crashes. I attached the logs for both the client and the server. client-dc68ac52-9811-4223-b9af-d2b8f1c71598.txt server-6354811679967.txt
×
×
  • Create New...