Jump to content

Search the Community

Showing results for tags 'FFMpeg'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Model: Pixel 3a - Google/google ---> Official ROM Android 11 Hardware: sargo/sargo/sargo/sargo CANNOT LINK EXECUTABLE "/data/user/0/com.emby.embyserver/files/ffmpeg/ffmpeg": cannot locate symbol "__trunctfdf2" referenced by "/data/user/0/com.emby.embyserver/files/ffmpeg/ffmpeg"... i cant watch videos With Emby server for android App version 4.7.0.9 beta and 4.6.4.0 LOG.zipLOG.zip
  2. ShotToTheDome

    Emby post-processing dvr script for linux

    I thought I'd post my emby post-processing dvr script. Tested and working on Debian Linux 8.9 Files processed end up being named *originalvideoname*.ts.mkv so i can search by that and make sure recordings have no issues. After I look at them, I manually rename to just .mkv. I do not have automatically convert recordings checked or the two preserve boxes checked under live tv --> settings. Script flow: see if lockfile exists. if so wait 60 sec create lockfile commerical scan and commerical cutting ccextractor to pull out closed captions and convert to srt file Encode to h264 using ffmpeg
  3. Hello, I have an odd one and I do not think it is emby directly. Read to the end.... I'm encoding some movies into HEVC using Hardware Acceleration. I decided to have two audio tracks (1. Original Audio Passthru, 2. AAC Track @ 960K). When I view the data in emby the second AAC audio track is wrong. It is being reported as 320K. So I figured maybe its the file itself. Here is the audio mediaInfo on the file. Perhaps it is the FFmpeg commands I am using for the audio. This is the main list of commands I have come up with for encoding HEVC with two audio tracks. M
  4. CaffNoir

    Nothing want to start

    Hi ! So this night with no reason, my emby server decided to not transcode movies and all of stuff on it. Here is my log file : https://paste2.org/9cFkEk0p
  5. David9Points

    Subtitles not downloading on MacOS

    Hello, Although scheduled to run each night. The process to download any new subtitles is set to run, and does. However, it doesn't download all the subtitles, in fact it fails with the following message: ffmpeg subtitle extraction failed for file:"/Users/David/emby-server/cache/temp/23f0ce6d-0784-4cf4-afe8-dc84a7fd885f.txt" to /Users/David/emby-server/cache/subtitles I have noticed a number of the TV Show's I have on my NAS (That is connected to Emby) doesn't have subtitles. Does anyone have any ideas how I can fix this? Thanks
  6. Hey everyone. I would like to ask about Intel Quicksync with ffmpeg, I tried to encode 10bit h264 by ffmpeg but it seems that Intel Quicksync doesn't support h264 10bit unlike hevc, so anyone have idea and if I'm mistaken plz inform me.
  7. oisecnet

    Optimizing scanning Library

    Hey guys, Been using emby on Linux for quite some time now. However after a new install on a clean machine, while importing my existing files. I encountered some performance issues. After looking at it it seems the library scanning process only will utilize 1 core at a time. The ffmpeg process that is forked for the chapter images is explicitly started with -threads 1. Is there any option to increase that ? Or is it limited that way due to locking issues ? On current systems it would speed up these processes quite a lot if multiple threads where forked. Even if ffmpeg was only f
  8. First of all I love all the work that has been done for this great product and I’ve been using Emby for 2 months without a hitch. However, yesterday I noticed Emby server was only sending stereo audio to my chromecast where surround sound with a range of different transcoded codecs always worked before. I could not find an easy fix, I had the feeling it was ffmpeg related but no errors occurred and software I believe was not updated. However, the Emby logs said it was sending out a stereo signal. I reinstalled Emby Server and everything works except when Emby is casting, the chromecast fr
  9. well the title explains HOW ITS MEANT TO BE SEEN HOW ITS SEEN THROUGH A BROWSER LOG FILEffmpeg-transcode-2e5de3da-59ec-4e6e-87fe-0c9abef5ea0c_1.txt in the "Processing Plan", in the "SubtitleBurnIn" part it says "false" for burning subtitles but i have this option disabled
  10. lesensei

    Unable to stream some movies

    Hello, I've been happily using Emby (with Premiere) on a XPenology NAS for a few years now, and recently seem to have hit a bug. When I try to play some movies of my collection, I hit the "Aucun flux compatible n'est actuellement disponible." (please pardon my french setup, this would be "No available stream" or something like that in english). I looked at the attached logs, tried to launch the "actual command" and sure enough, got the same error before ffmpeg quits: Stream specifier ':3' in filtergraph description [0:3]scale@f1=width=720:height=-2:force_original_aspect_ratio=decreas
  11. marky9074

    FLAC 7.1 to LG WebOS?

    Not sure if this is the right place for this, however having re-ripped all my media using FLAC given the lack of license with Synology (and others) for DTS, I am wondering why Emby is not handling the native 7.1 streams on 'newer' blu-rays and 4K UHD and outputting them as 5.1 to clients. Maybe this is an LG specific thing, as a quick test playing on Android phone and through the browser on my desktop (2ch) seems OK? All I get through my LG 65" OLED (2018) is a blank screen and no sound, and on the LG 32" LCD a high pitched buzz/whistle. Going back to Plex (which I am trying to get away fr
  12. Problem: transcoding a movie with 6-channel audio on a 2-channel (stereo) it TV causes the playback to loop, play a bit, then loop, then play a bit, then loop. This only starts to happen after an hour or so of the movie's playtime. If I fast forward a movie to an hour and ten minutes, the looping will happen. If I fast forward to the ten minute mark, or play ten minutes from the start, the looping will not happen. It only happens when I'm far into the movie. i've seen it happen with multiple movies after the hour (or so) mark. Server Platform: Raspberry PI 4 Server Version: Emby 4.3,
  13. I've seen that some files are being remuxed (changed from mp4 to ts, no changes in video or audio codec) whitout apparent reason. Can somebody give me a clue why this file is being converted from mp4 to ts copying both the video and the audio? The device where is being seen is able to do DirectPlay but insted it is DirectStreaming. Thanks, can provide more info if needed. ffmpeg-directstream-f118d222-127c-45bf-b8f8-f4943b9f68be_1.txt
  14. I have a .STRM file and have disabled transcoding for the user. In the dashboard the content shows up as direct played but it is evident this is not happening because there is massive stutter. I looked in the log files and Emby is still using FFmpeg to transcode it even though it should be direct play. I am using Emby Web Client on Chrome.
  15. Don't know whether this is the right place for this sorry. When FFmpeg transcodes the m3u stream on the fly for viewing where is the code that handles this? I cannot seem to find it anywhere in the source code on GitHub.
  16. I have a .m3u8 file that looks something like this: #EXTM3U #EXT-X-VERSION:3 #EXT-X-STREAM-INF:BANDWIDTH=614000,AVERAGE-BANDWIDTH=564000,RESOLUTION=480x270,CODECS="avc1.77.30,mp4a.40.2" https://example.com/270/prog_index.m3u8 #EXT-X-STREAM-INF:BANDWIDTH=1118000,AVERAGE-BANDWIDTH=1028000,RESOLUTION=640x360,CODECS="avc1.77.30,mp4a.40.2" https://example.com/360/prog_index.m3u8 This is a valid streaming file and the servers are responding. The file works in VLC and using ffmpeg command line. However when trying to play the file in Emby it fails. Here is my log (where [EXAMPLE_FILE] is emby's
  17. Emby Web 4.3.0.26 windwos 7 Core i5 750 RAM 8gb After watching a video on a Samsung TV-set, when I press the 'back' button, the ffmpeg process freezes up. When I open the next video, another ffmpeg process appears: because of that my server slows down and the video starts to slow down due to CPU overload. However, there is no such problem when I watch the video via web browser, the process disappears.
  18. alberto.bracci

    emby -ffmpeg issue

    Hello everyone, first post here so if anything should be edited just tell me. Anyway, I am running emby on a Manjaro linux machine, everything has been working out of the box until now. I am watching an episode of a series I already watched tons of episodes on emby without any problem, and suddenly the media reproduction stops towards the end. If I reload the episode it will keep stopping around the same time. Other episodes seem to be fine for now. I attach the log embyserver.txt, it seems to be an error with starting ffmpeg, but I don't really see the reason as everything has been w
  19. dougaddams

    FFMPEG Advanced parameters

    Hey Guys! Is there anyway to add extra parameters to the FFMPEG CLI? I think it would be a good idea if possible to add an arguments box to the advanced trans-coding page so people may enter any extra parameters they wished to add to FFMPEG for streams. Just a thought if there is not a way to do it at the moment. I can't seem to see any way to add extra arguments myself without attempting to decompile and dig. Is this do able? does anyone know?
  20. In MCEBuddy, one can choose to use any number of available Processor Cores to leave overhead for other processes. This allows me to convert ts to HEVC and run Emby at the same time. This works great until after MCEBuddy converts and Emby kicks in Thumbnail Extraction which uses ffmpeg and pegs the processor to 100% or just below leaving no room for other things like LiveTV or even transcoding on the fly for a client. Is there a way to limit ffmpeg to maybe 1 core? I know it will take longer but that's not a big concern anyhow. TIA
  21. It seems that the ffmpeg-transcode-* log files are not being rotated by the "Rotate Log File" scheduled task. No errors reported in the console logs. Other log files in the same directory are deleted as expected. 1.8GB of transcode logs built up before I manually cleared. Debug logging is not enabled; should these logs even be generating? Is there an option to turn those off? Thanks!
  22. With the recent move by FreeNAS to 11.2, and the corresponding move from warden to iocage, I had been putting off my FreeNAS upgrade as all my plugins were still working. I finally made the jump to 11.2rc2, and had to rebuild my plugins that use the iocage backend. The install via plugin of Emby 3.5.3.0 worked without issue using the new UI. After adding the video libraries and re-scanning, everything seemed normal. Playback worked on ios clients without incident, but other clients had playback issues with ffmpeg errors in the logs. After searching several threads I found a solution. Here is a
  23. Hello, I recently bought premiere and suddenly Emby is running ffmpeg in the background at nearly 100% CPU, nearly constantly, even with no one accessing the server. For now, I disabled Download & Convert, and things returned to normal. I guess I have a few questions: 1) What exactly does "Download & Convert" do? What's it for? 2) Why was it running in the background? 3) Was it converting and replacing my library to be stream friendly? My whole library? That would take forever, are the old files deleted as they are converted to save space? 4) I have a GTX 950 -
  24. lills

    Option to override ffmpeg command

    Hi, I cannot get Emby (Windows or Synology versions) to transcode mkvs (h265) to mp4 (h264) my Humax set top box connected to my TV. I believe my dlna profile is configured correctly as the Humax box see's the emby server and attempts to start transcoding the mkv to mp4. It tries for about 15 seconds and I can see that transcoded file building in the transcoding-temp folder. But I get the error 'unsupported format'. After looking at the ffmpeg log I could see it was trying to run this command: /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -f matroska -i file:"/volume1/TV Series
  25. Ok.. I have been able to compile and install a custom ffmpeg with OMX (hardware encoding enabled) https://emby.media/community/index.php?/topic/36227-h264-omx-instead-of-x264/page-2 But when enabled in the Emby server.. it silently fails.. HOWEVER... When I copy/paste the command (for example): ffmpeg -i file:"/media/usb0/TV Shows/SpongeBob SquarePants (1999-2015) [480p] [720p] [HEVC] [x265]/Season 01/[pseudo] S01E02 Reef Blower [480p] [h.265].mkv" -map_metadata -1 -map_chapters -1 -threads 0 -map 0:0 -map 0:1 -map -0:s -codec:v:0 h264_omx -b:v 2211644 -maxrate 2211644 -bufs
×
×
  • Create New...