Jump to content

Search the Community

Showing results for tags 'DirectPlay'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 12 results

  1. elpoolet

    Browser DirectPlay Codecs

    Hi Everybody I looked for it a bit, but unfortunately I wasn't able to find it. I'm looking for the list of codecs and file formats that each browser can read by DirectPlay and ones causing DirectStream. I need these because I use Emby at home and I only play my stuff on my TV that support almost everything but not my computer (when I'm in my bed) that plays via browser (Chrome). Is there someting there that I missed ? The best solution would be a compatibility matrix like that Video Codec Sound Codec Playing x264 MP3 DirectPlay x264 AAC DirectPlay x264 DTS DirectStream x265 all Transcode Cause, untill now, when I download someting, I re-encode Audio with AAC, and video to x264 to ensure DirectPlay will occur, but is there a better Audio Codec ? No matter the bandwith here, cause all plays occur via LAN or WiFi... Many thanks for your answers
  2. Preface All of the media I'm testing have previously worked flawlessly in the current environment. Meaning my network topography/speed has not changed. I cannot say for sure when this problem began as I rarely need to use a browser to access my Emby personally, however I had a user report issues a few weeks ago. I gave it very little thought until I had reason to use a browser recently and I ran into problems. Problem Recently (within the last few weeks), Emby playback within my web-browser has begun giving me the following error: Testing I have tested with various browser on various machines with results as such Ubuntu - Chrome: FAIL Windows - Chrome: FAIL Ubuntu - Firefox: FAIL Windows - Firefox: FAIL Windows - Edge: SUCCESS I have deduced that this happens for all Matroska contained media as far as I can tell. Container WebM w/ VP9/Opus codecs works correctly. I'd have to really go fishing for other types of media to test as my libraries are 99.99% Matroska or WebM. Logs NOTE: Firefox actually attempted transcoding, though still resulted in the same error. I zipped the result transcode logs for each occurrence, though I know they will not be helpful for debugging this. 20180926-Emby.Server.DEBUG-Ubuntu.Chrome.v69.0.3497.81-1.log 20180926-Emby.Server.DEBUG.Windows.Chrome.v68.0.3440.100-1.log 20180926-Emby.Server.DEBUG-Ubuntu.Firefox.v57.0.1-1.log 20180926-Emby.Server.DEBUG-Ubuntu.Firefox.v57.0.1.zip 20180926-Emby.Server.DEBUG.Windows.Firefox.v62.0.2-1.log 20180926-Emby.Server.DEBUG.Windows.Firefox.v62.0.2.zip 20180926-Emby.Server.DEBUG.Windows.Edge.log UPDATE -- 20180927 -- Official Embyserver Docker Container results -- 20180927-Emby.Server.DEBUG-Ubuntu.Chrome.v69.0.3497.81-3-1.log UPDATE It appears I may have opened a duplicate post from someone else with a similar problem (though to be fair, when I searched I did not find it as their topic is very misleading) https://emby.media/community/index.php?/topic/63309-docker/?p=627055 Also at a glance at their log, their ffmpeg doesn't even start, whereas this is not my issue.
  3. Ahim13

    Ass direct play

    Hi, so today I updated the emby app on my LG tv and now it always wants to transcode the media, whereas before the update it was direct play even with ass subtitles. Thai feature was of the things I chose Emby. Please help resolve this issue, or does anyone know how to rollback to previous emby version on lg tv? Thanks
  4. I've seen that some files are being remuxed (changed from mp4 to ts, no changes in video or audio codec) whitout apparent reason. Can somebody give me a clue why this file is being converted from mp4 to ts copying both the video and the audio? The device where is being seen is able to do DirectPlay but insted it is DirectStreaming. Thanks, can provide more info if needed. ffmpeg-directstream-f118d222-127c-45bf-b8f8-f4943b9f68be_1.txt
  5. Skyobliwind

    Tips for Codecs and Fileformats

    Hi, after some testing on different devices and with different media I noticed that almost all files transcode which reduces quality and sometimes makes playback shutter. My main Playback devices are Firefox on Windows, The Emby app for Tizen(Samsung) and the Android app. My Films and Series are all in mkv container. Most are DVD Rips in Mpeg2 Codec, some are Bluray Rips in Mpeg4 codec and I think also a few in HEVC. Even Musicvideos in H.264 seem to transcode. All transcode to H.264(AVC) if played from Firefox on Windows, Firefox on Android and emby app on Android. So is H.264(AVC) the codec to go for? It makes no difference if I disable or enable subtitles. Is there any guide or something which are the preferrable formats/codecs for which Playback device? (Video and Audio) (The goal obviously is to get as many files to directplay as possible (sorted from important to less important 1.quality, 2.speed, 3.storagespace) In the future there may be other devices like fire-TV stick, IOS Devices, maybe Xbox or Emby Theater added. At the moment there Are mostly DVD Rips and FHD Bluray Rips, but I'd also like to add 4k Bluray Rips in the future (i alread read this makes some trouble in other topics). @ @@maegibbons @@arrbee99 @@JaScoMa @@pir8radio @@AdrianW
  6. nelsong

    Direct Play - Cannot Fast Forward

    Hello, I've been using FreeNAS on windows for a couple of years now and a few days ago a bit the bullet and built a NAS with FreeNAS. I went the plugin route for emby and everything has been working fine, that is until I tried to fast forward with my Kodi using the Companion. The image just went to black and stopped playing altogether. Now here's the kicker, I'm not having problems when transcoding the videos, it only happens if I have play a video and the bitrate is over 10Mbps. To bypass this issue, I've had to make it so that the playback forces a transcode using 1080p 10mbps on the local network. Since it doesn't happen when transcoding, I just have it to auto when playing from the internet, I'm already forcing a max of 8Mbps from outside connections. Any idea on why this would be happening?
  7. I've found an unusual issue. I typically name my H.264 files as .M4V. Using that extension, with a stock multi-track movie (2 chan HE-AAC as the first track and AC3 5.1 as the second), it will default to the stereo track, and only Direct Stream the 5.1 track. If I rename the file to a .MP4 extension, it does DirectPlay without issue and auto-selects the 5.1 track without issue. The info indicates it is doing Direct Stream with M4V due to the container. I've used M4V on many many servers, with this audio setup and none had an issue with the container/codec setup. I'm not sure if this is by design, or a bug. The only other issue is a movie filename with periods in it like "The Man From U.N.C.L.E (2016)". I end up with "The Man From WTF". Worth a laugh to be sure, but not expected. Can I force it to leave my filenames alone and not rename them? I really dislike when a server does this without asking. So far so good otherwsie! Great server. Thanks!
  8. Im having some issues with playing back my media collection. Let me start by telling you what equipment I have: Emby & my media are on a Synology DS418play (Hardware acceleration: VA API enabled, DLNA not enabled in Emby). My playback client is a Samsung 7 series tv with the emby app. All of my media is .mkv in x265 Most of my media is 1080p, while some like in this example is 2160p (or 4K) Glitches dont just occur in 2160p files. For example, I get artifacts playing back The Simpsons (1080p x265 mkv) The glitches range from a few seconds of video freeze while audio is still playing to some artifacts throughout the videos. The attached log is from when playback is started on Daredevil S03E07 which is a 4K file to when I click exit to close the app. During this playback I have video freeze while audio played for a few seconds. I made a note that the time when it happened was around 19:11pm. As far as I know, the TV should be directly playing the file as it supports the codecs and the server should not be transcoding. The emby app and server are on the latest version. PS / I switched over from Plex (which could playback the file fine) because it kept sending info "home" and not letting the server sleep. / Emby is a great app and once this is hopefully resolved I will be getting Emby Premiere log.txt
  9. Hello guys, After running Plex for a long time, I decided to switch to an opensource alternative, given all the new anti-privacy measures taken by Plex. I'm having a problem however: I did a fresh install of Emby 3.2.34.0 in a LXC container running Ubuntu 16.04, the server is not powerful enough to transcode high quality stuff, but this is not necessary. However, even when I do a DirectPlay, the CPU is utilised at 100% in the FFMPEG process, even though transcoding is disabled for the user requesting the stream, the stream play just fine, but it is strange to see this process running when no transcoding is present. Plex used only a few % of the CPU when Direct Playing or remuxing. Very strange. This problem looks similar to a problem people had a few weeks ago when using Emby with live recordings. Is there someone who can help me? Kind regards, Ronnie FFMPEG LOG.txt
  10. Dears, 1stly, my wishes to all for a shiny 2017!!! I would like to express my appreciation for the valuable efforts & support within this Emby "Technosystem"! Now that Subtitles and Resume functionalities are fully working on Samsung Smart TVs via DLNA, I would appreciate considering support for Direct Play of LiveTV content to DLNA smart TVs. In my case, the Live TV content is an M3U list of HTTP-based mpeg-ts streams (.TS), which is currently direct-played to DLNA TV through XUPNPD DLNA media server. Having the same level of functionality through Emby Media server will be a great addition. More specifically, no probing of streams is necessary and no attributes (size, audio channels, duration,...) are needed in describing those streams when browsing the M3U list through the DLNA TV. Below is the DLNA Browse response from XUPNPD to TV: <res size="0" protocolInfo="http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_NA_ISO;DLNA.ORG_OP=00;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"> http://url:4044/proxy/0_1_2_23.mpeg_ts</res> Based on the above, keeping the original URL for the individual live streams (assuming mpeg-ts) should be fine for Samsung Smart TV DLNA. What I have noticed so far is that any attempt to stream a transcoded live tv channel from Emby to Smart TV (via DLNA) is failing due to the significant delay (over 15 seconds) resulting from probing/transcoding. Thank you for your support, Wayve
  11. grizlyadams

    Question about direct play

    Hi, If i'm on the same LAN and have access to the same folders that Emby has, why do my files not direct play when I watch them via the browser Also, how do i check that Emby for WMC is playing direct play? Emby server is running in a docker on unRaid. thanks Griz
  12. I have multiple video files that used to direct play or direct stream just fine and now it is attempting to transcode these videos and seems to not even be able to start the transcoding. Emby log Points to a stream.mkv that isn't being created. Regardless I don't want transcoding. I don't understand why these videos that were once flagged as supported for direct play are now saying unsupported. This issue seems to coincide with a recent server update. I have attached my server log, ffmpeg-directstream log, and the media info for one of the video files no longer playing. Any help in getting this sorted out would be great. server-63613652966.txt ffmpeg-directstream-2f2038d1-56e3-4dc6-a807-44d62464b0f8.txt Mission - Impossible - mediainfo.txt
×
×
  • Create New...