Jump to content

Search the Community

Showing results for tags 'Cache'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 31 results

  1. nosachov

    Thumbnails and cache OpenSUSE

    Hi Everyone. Problem: I got a trial emby on an OpenSUSE server. All looks good except the thumbnails usage. Every time I enter some folder thumbnail images are downloading again and it causes a 100% or high CPU usage. Already looked for a solution on the forum but can't find it. VM Hardware: 4 CPU Cores. 2 GB RAM. External mounted NAS with photos and videos of high resolution (~1TB). Also I use Nginx. Config: server { listen 80; server_name media.domain.com; root /var/www/html; return 301 https://$server_name$request_uri; } server { listen 443 ssl http2; server_name media.domain.com; root /var/www/html/emby; ssl_certificate /etc/nginx/ssl.crt/some.crt; ssl_certificate_key /etc/nginx/ssl.crt/some.key; location / { try_files $uri $uri/ @backend; } location @backend { proxy_pass http://127.0.0.1:8096; # Allow WebSocket connections via HTTP 201 proxy_http_version 1.1; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_set_header X-Forwarded-Host $host; proxy_set_header X-Forwarded-Server $host; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Real-IP $remote_addr; proxy_redirect off; } } No errors in nginx log. /var/lib/emby/logs/embyserver.txt: 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 8000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 300000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 600000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 900000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 1200000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 1500000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 1800000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 2100000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 2400000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 2700000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 3000000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 3300000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 3600000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 3900000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 4200000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 4500000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 4800000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 5100000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 5400000ms. 2020-09-08 02:00:03.484 Error ChapterImagesTask: Error during chapter image extraction for 2013-12-20 17.00 Annual Company Meeting, December 20, 2013, at 5700000ms. 37M /media/cache/ 3.0G /media/metadata/ Please kindly help me. And let me know if you need any information additionally. Thank you in advance. KN
  2. Hello! It would be very nice if I could make Emby cache the Subtitles from MKV files when added! Also - As a bonus, maybe some way to activate it for already added media - Sometimes it takes a little while, so it would be nice if I could do it manually a litle while before I would like to see the Movie. Is there any possibility this could be added? Or would it be hard to make? Best Regards Jonatan
  3. Starting yesterday, my Emby Classic running on Windows 8 Media Center was missing some movie cover images. When attempting to open the movie missing the covers, Emby Classic hung. Had to close Media Center to gain control of the computer again. Later I found out that the Emby server (running on different hardware) was crashing each time I did this. I would have to force quit the Emby Server and restart it. Emby seems to work fine from every other app and the website. I am able to repeat the issue any time by using Emby Classic for WMC for anything so it has become worthless. I am able to use Emby Theater from the same PC without issue. I do not have an option to test Emby Classic from another PC as I do not have another Media Center PC. I have uninstalled Emby Classic and removed the programdata folder associated with it however the same issue exist after new install. I have even tried to use the Emby Classic beta but the same issue exists. I have removed the Emby Server Cache folder to make it recompile all new cache, same issue still. I am thankful that Emby theater works great but I REALLY like using Classic more as it seems to have better eye candy and smoother transitions. Is anyone else having similar issues lately? Is there a way to completely remove Emby Classic and start completely over? Any direction is appreciated. Thanks Randy
  4. Loki93

    How to clear metadata cache

    Hello everybody and happy holidays, I'm looking for a way to manually clear the metadata cache. I want that because the tvdb scrapper gets outdated (wrong) episode information (episode title, description, airdate, etc.) from cache based on the correct filenames. As it seems the scrapper refers to the S00E00 part of the filename and ignores the following episode title (e.g. "S03E14 - Zwei linke Hände.mp4"). The result is, that "S03E14 - Zwei linke Hände.mp4" is displayed as "Glaube versetzt Berge" which is S03E20. I recently changed some information (episode numbers) in the tvdb database and verified that the API repsonses the new values. In particular, I changed the episode numbers: from 14 to 20: https://thetvdb.com/series/291180/episodes/6106291 from 15 to 14: https://thetvdb.com/series/291180/episodes/6179164 from 16 to 15: https://thetvdb.com/series/291180/episodes/6179166 from 17 to 16: https://thetvdb.com/series/291180/episodes/6179167 from 18 to 17: https://thetvdb.com/series/291180/episodes/6179168 from 19 to 18: https://thetvdb.com/series/291180/episodes/6218765 from 20 to 19: https://thetvdb.com/series/291180/episodes/6218772 I found a folder at /var/lib/emby/cache with several subfolders like "tmdb-movies" or "tvdb". Is it save to delete those folders without running into problems with? Cheers Lok1
  5. jeffshead

    Emby for Kodi settings do nothing

    On my Nvidia Shield... Since updating Kodi to 18.5 and Emby for Kodi to 4.1.16, none of the EFK add-on settings do anything. For example, nothing happens when I click on the "Repair Library" option. Also, when starting Kodi, I no longer get the little pop-up that says, "Welcome user". Everything worked just before the updates. Another ongoing problem (the reason why I wanted to repair the libraries) is that artwork goes missing for a lot of the TV episodes so I periodically have to repair the databases. Its been doing this since the last couple of releases. How do I troubleshoot/fix this? UPDATE: I solved the issue. I use a scheduled task to run the Emby Server updater script and I run Emby Server as a service. Apparently, Emby Server automatically updated just hours before I manually updated Kodi and Emby for Kodi on the Shield box. The Emby Server update did not get fully installed because it needed to install an updated version of the Microsoft Visual C++ redistributable package. This cannot be done until you logon to the Windows server. Simply stopping the Windows Emby Server Service and starting the Emby Server EXE auto started the update of the Microsoft Visual C++ redistributable package. Once it finished updating, Emby Server could once again fully start.
  6. Hello, I have a problem with web interfaces, both in firefox and chrome on windows. In particular when I open emby from browser it often shows an older cached session, meaning that the next episodes to play and the one to be resumed are older. If I clean the cache, things get back to normal. Still, it happens all the time and I cannot keep clearing the cache every time, is there a way to prevent this from happening? Thanks, Alberto
  7. riothamus

    Safe to dump the cache (periodically)?

    Hi all. I have had the same Emby server running for well over a year now. I've noticed that sometimes when I click on a letter in any of my media libraries (which are all from different directories) sometimes the images wil not show, or the server will hang trying to filter down to my selection. Every once in a while, when I watch the log during these instances, I do not see any error messages show up. Instead, the server daemon will restart itself. Since I have had this running for quite a long time, and I have made additions, removals, and moving some media around, I wonder if perhaps my cache just might have some old/corrupt data in there. So I was wondering if it was ok to clean out that directory, and if so how often should/could it be done. I understand that new searches might take a while as it gets repopulated, but I only have my family using it so I'm not overly concerned with performance impact on this. Is this something that can be safely done on a monthly or a semi-annual basis? Thanks all!
  8. Hey guys, I was just trying out Emby to see if it fits my needs, one of the things that attracted me was the Live TV and being able to run IPTV on it. I run the emby docker in Unraid, so my experiences are in that. I got a warning my cache drive where app data is stored was gettin full so I was a bit shocked ( I normally use about 40gb out of 256gb) and I then realized Emby's /EmbyServer/cache/temp was taking up 140GB. Since the directory was owned by deamon:deamon I was not able to delete the temp files through network, so I had to SSH to do that. After testing I realized that the /temp folder started getting full again after adding a Live TV EPG XML file. I added the m3u file and nothing happened, but when I added the EPG via XML it started populating again, to the tune of 18GB on this EPG Refresh, I assume it was due to multiple refreshes without purging that it previously filled up so much in the past couple of hours. Not sure why it does that or how to prevent it either. Also if the folders could be owned by nobody:users like all other apps instead of deamon:deamon, it would also be easier to clean them off via network share, though obviously I would prefer it never blow up to that size honestly. Is there a way to prevent that? Anything I can provide to help diagnose or debug?
  9. Just trying to verify something here. It is my understanding that Live TV, while being recorded, is recorded to the Transcoding Cache Folder and is later moved to the Recorded TV Library folder. This would imply that I could create a Ramdisk and identify it as the location for the transcoding cache, which has the potential to provide 2 benefits. First, and most important to me, it would reduce the write activity on my expensive m.2 NVME drive, which has a finite number of writes. Second, DDR4 RAM is quicker than even Gen3 X4 NVME storage, so I may perceive a performance improvement as well. I have adequate unused RAM so I don't see creating any new system bottlenecks. Now for my questions: 1. Am I correct about the way the LiveTV recording cache works? 2. If so, is the recording file only moved to the recording folder at the end of the recording process or is it written to that folder at some interval during the recording process? 3. Am I missing anything in my reasoning? Thanks
  10. hofstra

    qnap 453be increase Emby performance

    hello forum, im running emby premiere version 3.5.3.0 on qnap 453be 8gb ram 2 3tb hdd in raid 1, hardware transcoding enabled ( va api). internet speed 175 down 15 up emby runs great for local clients, remote cilients can take up to 10 seconds before the stream starts then works great. iptv and dvr don't load as smootly , 10 seconds minimum before stream starts sometimes longer but then streams perfectly. what would be the best performance upgrade, i currently can only afford to do one of the following: -buy another hdd and change from raid 1 to raid 5 - buy 250-500gb ssd and add as a cache -buy 250-500gb sdd and install emby on the ssd
  11. I've specified a specific directory for cache, metadata, transcoding etc. The server is not using the cache directory specified for storage. I'm using Emby Docker version 3.5.3.0 on Unraid. I've specified it to use path /mnt/Emby/transcode/cache Looking at that path there's around 350M of data in it. So Emby is writing to it. But the majority of my cache is in the default location /cache/ as this folder is around 600M. How do i move all the cache from /cache into the specified cache. I don't know why there is any cache there as i moved the cache location when i first setup the sever.
  12. admin.nxpoint@gmail.com

    [Feature Request] Playback Setting

    Hi, I would like to propose a some new features, at least for the web interface. 1. Ability to setup the keyboard shortcuts. - not all can use the default shortcuts, there might be other system shortcuts that get in the way. - a method to setup your own could really make a great difference 2. Setup and define the local cache size [if there is any local cache for browser play] - it will incredible to be able to setup the local cache size for playback
  13. How do I delete the Emby Theater cache so it will rebuild from scratch its cache of metadata images? I searched and couldn't find the answer. ET is not showing some images -- some posters are missing. They show in the server web view, so I think it's a Theater problem. I want to just purge its cache and start over rather than trying to find and fix individual movies / shows. Short of uninstalling ET, I don't know how to purge its cache.
  14. KillyKillKill

    Refresh all metadata? or clear cache?

    Sorry if this is a repost, but I haven't been able to find an answer anywhere.... All I need is a simple explanation of how to refresh my entire database in one go (if possible), and whether this can be achieved by a simple restart, an option in the menu, or by deleting a cache folder? Clean install? Or other method? Obviously I'm new to all this... My problem arises from originally having MB set up wrong, and now that it's configured the right way, I'm still left with some oddly incorrect metadata and am trying to find a way to simply refresh (rewrite) it all. For example, all of my "sort name" metadata in my television folder is missing key episode information: 'Adventure Time - S01E20 - Freak City.mp4' is labeled under sort name '001-Freak City' (missing episode info) but a quick manual refresh gets it correctly to '001-0020 - Freak City' I save it and all is good. Except, I really don't want to do this for EVERY SINGLE EPISODE, because that would be mad. Any help would be beyond awesome.
  15. Hello I've just noticed that movies I am adding to my library are not downloading any metadata. I have the option checked to store the metadata with the media file itself but that option has actually not worked for a while (but metadata was still downloading). Recently my c: drive was completely full and I suspect that may have played a role in preventing any meta from downloading but I have cleared some space and now even if I scan for new files or manually refresh metadata nothing happens. I also chose another location for the cache but that did not seem to resolve it. I'm actually not sure where the metadata is stored on the computer. I would like to move it all to another drive to free up more space. I am not sure which files in AppData\Roaming would need to be moved though. I am running Emby server Version 3.2.26.0 on Windows 7 Pro x64. C:drive is a 240GB SSD that has less than a GB of free space currently. I am assuming that the caches and metadata are taking up all the space because no media is stored on this drive. Any thoughts on a fix for this? Thanks
  16. My server console for some reason has stopped reading the image cache when it loads in the browser, this occurs on the physical machine or if I connect remote via a web browser; IE, Edge, or Chrome, all behave the same. Oddly enough only sets/collections displays, movies, TV, etc do not, regardless of setting them to poster, banner, etc.. The metadata is there as they have displayed in the resent past. I can go to the cache folder on the server (it's default location) and I see the images and a properties of the folder revel there are indeed enough files to correspond with the amount of media on the server. My question is: 1) Is there a DB cache that the app reads from or is it reading directly form the CACHE folder in User/App Data/Roaming ? 2) In either case can a refresh be forced to load in the web page w/o actually pulling new metadata from the internet? Thanks for your help...
  17. I'm sure there are a few users out there using Emby and unRAID and wanted to see what others are doing. At this time, I'm running Emby and unRAID on separate boxes. The hardware I have for unRAID works good as a storage server, low cpu use, lots of drives, my Emby server (Windows), is more powerful, but less drive expansion at this time. At this time, I'm not interested in building up a new unRAID box and installing Emby via Docker. The problem I'm seeing is inconsistent playback, library management that I'm most likely contributing the unRAID spinning down the disks when not being used. I have a HDHomerun and plan on setting up the DVR portion of Emby shortly. So I'm just looking for some tips from those of you with both Emby and unRAID on separate boxes, are you keeping your disks spinning all the time, are there some plugins I should be looking at to help the media, do I need to move my meta data somewhere else? Thanks, Josh
  18. I cannot get used to how slow artwork loads and how it doesn't load in the background it has to wait for me to browse the media. Is this normal functionality for emby? It recently asked me to rebuild my library and it's a pain to have to recache all the episode thumbs. they take about 10 seconds to load into kodi on my openelec inter i5 nuc. Prior to emby this was nearly instant, I'm I doing something wrong? TIA!
  19. Crossfire0mega

    ANSWERED keep getting kicked back to login screen

    Hello, I have a newly installed EMBY server running on Ubuntu 14.04.3 x86 server. I have gone through the install process and I was just trying to setup the media locations which are local directories and whenever I try to enter the location in it kicks me back out to the login screen. I have only one account setup and I created the local folders for my media with the same account as for emby. I also tried to change the server cache files path from the default under advanced settings and the same thing happened, kicked right back out to the login page. I don't know what's causing this, any help would be great. Thanks. p.s. I also have samba installed and have made my media folders into shared network folders open to guest and tried the network paths in the media locations settings and it still kicked me back to the login screen then too.
  20. So i did a clean format/reinstall of my laptop. so put Emby on with a fresh install... but then copied over everything from the backed-up \Emby-Server\data folders, including all the images, etc... But i deleted the library.db & refreshinfo.db so the library would rebuild... Does the server use the images that are already downloaded, or does it just download everything a fresh and overwrite whatever's already there?
  21. Tanamur

    Cache file cleanup failed

    Hi there all, I have my emby server set up on my local server but have the ImagesbyName and Emby folders set up on networked drives. The cache is local. I keep getting the message "Cache file cleanup failed" The request could not be performed because of an I/O device error Emby Server Version 3.0.5621.4 is running on a Windows7 64 bit machine. Nothing special but this has just started happening. The C:\Users\Tanamur\AppData\Roaming\MediaBrowser-Server\cache tells me there is a problem. Any suggestions or should I just delete the cache folder and rbuild? Thanks in advance
  22. I have been trying to find a reliable, private, photo sharing application so I can move away from Dropbox or OneDrive. I have too many family photos to send them there but the interface is pretty decent and fast. I was giddie when I found that MB supports photos, too! I am new so I didn't catch this at first. So my problem right now is I have a lot of photos and browsing is very slow. Thumbnails are taking forever to show up and then downloading a photo to view takes ages. Is there already an option to pre-cache the thumbnails or is that done each time someone loads an album? Or, is it done only one time when the first time the photo thumbnail is requested? Is there an option to set the default image size once the thumbnail is clicked? For instance, I set the default image size, in MP or file size (2MP, 300KB) and have that cached, too. I have a lot of 35MP photos. Normally I use IrfanView (http://www.irfanview.com/ - as if you didn't know about it already) to batch resize when I send them in email or upload to cloud services but I am trying to get away from that so the originals can be downloaded and printed without artifacts. Is the thumbnail caching and default image size caching considered the same feature or should it be different posts? Thank you for your help
  23. gillmacca

    Cache location question

    I run my media on a readynas nv+, and due to the server software not currently being compatible for this server, I am running the server on my laptop. I currently have my cache in the default location, but was wondering if I would see any performance improvement by moving the cache to the readynas
  24. skynet600

    ANSWERED Is there a way to clear iOS cache?

    I have image inconsistancies between my iOS devices and the web client in that in the web client I can see images but for some titles in iOS those those titles have no image. Please see the below post for details. http://mediabrowser.tv/community/index.php?/topic/13113-imagescoverart-for-new-media-not-loading-on-homepage/?p=155213
  25. DaN

    Cache Clearing

    Sometime when the Server gets updated; I see Clearing Cache task gets executes. Is there a way to execute that task manually? regards, DaN
×
×
  • Create New...