Jump to content

Search the Community

Showing results for tags 'subtitles'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Until sometime recently, Emby on TvOS respected the system-wide subtitle settings when playing videos with "soft" .srt subtitles. I'm not sure when it changed, so I don't know if it's the result of an app update or the 4.0 server update, but now subtitles look totally different. I checked the system settings (in Settings > General > Accessibility > Subtitles and Captioning > Style) and they have not changed. I'm using the default setting: small white text in Helvetica over a transparent black background. Other video apps still display subtitles correctly. Emby is now showing subtitles in a huge font using white text with a black outline, with the letters just slightly too close together. It's very distracting and pretty much ruins the experience. Nice handling of the subtitles was the main reason I switched to Emby, so this regression is baffling. Is this a known bug? Or is there a way to tell Emby to respect the system subtitle settings like it used to? Thanks!
  2. Today I found that video files containing embedded closed captions, such as DVB recordings or iTunes downloads, will show that subtitles are present but none of my clients are able to display them and the server is not able to transcode them to a usable format. This example is from the iTunes Store. In the local and remote webapps some corrupted text is shown: The Android client behaves like the webapps. The Kodi plugin and Samsung Orsay client both display nothing at all but detect the correct language. The Emby's log shows ffmpeg bombing out: Stream #0:0(eng): Subtitle: subrip (srt), 1280x720 (default) Metadata: creation_time : 2016-12-07T11:23:24.000000Z encoder : Lavc57.64.100 srt Stream mapping: Stream #0:2 -> #0:0 (eia_608 (cc_dec) -> subrip (srt)) Press [q] to stop, [?] for help [Closed caption Decoder @ 0xa9ca000] Data Ignored since exceeding screen width Last message repeated 2029 times size= 1kB time=00:19:50.89 bitrate= 0.0kbits/s speed=1.52e+04x video:0kB audio:0kB subtitle:1kB other streams:0kB global headers:0kB muxing overhead: 52.568306% The root cause is a known deficiency in ffmpeg which can identify the caption stream correctly but cannot extract it, refer to https://trac.ffmpeg.org/ticket/4616 which also has a sample video attached. I would be curious to know if iOS devices are able to DirectPlay this type of content with working captions. WORKAROUND To extract usable subtitles from a video simply run the file through CCExtractor (http://ccextractor.sourceforge.net), generally you will not need to specify any special options as the defaults will produce an external SubRip (.srt) file as output. To get rid of the unusable caption stream (or replace it with the SubRip subtitles) simply remux the file to Matroska using mkvtoolnix or avimux.
  3. Hello all, I would like to reencode tv recordings that I recorded using tvheadend into hevc in mkv container. They are in mpegts format, with h264 video, aac audio and dvb_subtitle subtitles. I also would like to keep subtitles, as most of my recordings are in multilangage version with translation in subtitles. Currently, encoding works perfectly as expected and hardware accelerated for both decoding and encoding for video, but subtitles are removed during convert process, as shown in this example: ffmpeg-transcode-a3340299-f30b-418a-a8cd-ffae1c897874_1.txt Would it be possible to encode these subtitles, or at least copy them, during the conversion process? Thanks for your help. Nicolas
  4. stevedallas

    Subtitles - cannot get them

    I am a newby but I've searched these forums. I know I am making a newby mistake and would like help. I have created a user login in open subtitles and have provided my login name and password in emby. I have (I think) checked all of the correct boxes in each library's settings, but still no subtitles. There are no subtitle files in each recording's folder. I'm attaching a screen grab from my latest recording attempt. Please help! Thanks, Steve
  5. Whenever the 'cover' aspect ratio is selected, the subtitles move along with the video frame as if hardcoded onto the video, but these subtitles aren't hardcoded, they are from a separate srt file. I've tested it on multiple video files too. This behaviour happens around 80% of the time (tested on same file). Sometimes it is fixed by force-restarting the app, but mostly it's not. The emby server version is 4.6.4.0. The app version is 3.2.12. Also, the subtitle drop shadow doesn't match the preview in settings (except uniform) and the background doesn't work.
  6. Okay this is somewhat of two problems together but the initial problem, I've found a viable work around so I don't really care about it as much. First, I use VLC as an external player on my AndroidTV with Emby because the playback on HEVC formatted movies is very inconsistent. I don't know if it's on my end or what (it very well could be) but enabling VLC as an external player makes every video play with the same smoothness. (That's the first "issue". Second, in using the above workaround VLC, regardless of formatting, unless the subtitles are embedded within the video file itself, they are .sub formatted external file or a .srt file labeled properly as "forced", VLC will not see it nor will the subtitles play. In addition, what I believe is happening is Emby is transcoding with the forced subtitles into VLC because although forced allow them to play, it's at the sacrifice of functions like rewind, fast forward and/or any manner of skipping via VLC. With any other video all said features operate correctly. I would love not to have to use VLC and be completely within the app but if not the VLC as the player is perfectly fine and doesn't make that much of difference but with watching movies with alot of subtitles, it does throw off the experience significantly. Thanks for any help you can provide. Emby 4.7.0.17 embyserver.txt
  7. KojoZero

    Too many subtitles causes video to lag

    When playing a video on my iPhone with lots of and/or heavily stylized subtitles, the video + subtitles would lag for a while (but audio still plays). This occurs even when I download the episode. The video runs perfectly fine through VLC (via UPnP) or when I disable the subtitles in Emby. Is there any way to fix this? I've attached an example video + server logs (no ffmpeg) embyserver.txt 04:48:35.777 Extra Info: IPhone SE 2nd Gen iOS 14.6 Emby App 2.0.8 Emby Server 4.6.4.0 slow_subtitles.mp4
  8. Hello everyone, I'm a new emby user since a week or two. But there is a problem that keeps occuring. When a streamed a video to my chromecast it showed subtitles, but this was only the first day. Now when I try to stream the same movie (or other) it doesn't show any subtitles. When I pauze the video on mobile when it shows a subtitle and than stream it, it will show that sentence for a split second and nothing after. Context: - I run my emby server on a synology - I use opensubtitles as automatic source - self added subtitles are having the correct naming (showed at the ? in emby) - I have searched the forum but didn't come across some solution Thanks for helping.
  9. Hi, I’d love that audio and subtitles choice would be saved per show, according to what you select on the last episode you watched. The main audio/subtitles parameters is a good point but there are many cases it is not enough and you need to adjust audio and subtitles at the beginning of every episodes. For example i like to watch Casa de Pale in Spanish with french subtitles, The Big Bang Theory in English with french subtitles, French TV shows in french without subtitles, ....
  10. Hi, I had this same problem after updating PS4 to Software ver. 4.5 and now is back again after update to software ver 6.71. (The old thred: https://emby.media/community/index.php?/topic/46562-ps4-no-subtitles/) After updating everything works great but no subtitles (external srt) are displayed. I have tried to turn them on and off with no luck. I have tried many movies that used to work fine. I have: PS4-568 Software ver. 6.71 Emby server Version 3.5.3.0 Ubuntu linux 16.04.2 Thank you Emby Team!!! 8-)
  11. nishwahareesh

    Some Emby Android bugs

    first ones the video themes. It seems that it plays the actual video instead of playing it in the background example:- Screen_Recording_20210412-033132_Emby.mp4 next ones the subtitles. For some reason, when you initially start a video, the subtitles tend to look very oddly generated but a quick restart of the app fixes it examples initially starting a video (the opening/intro subtitles gets jumbled up too) after a quick restart of the app This ones again with the subtitles. Sometimes, the complex styled subtitles tend to glitch out and never show up (the dialogues do show up after this specific opening) example Screen Recording 20210412-035313 Emby-1.mp4 sample video https://mega.nz/file/wkAwBJSQ#9XZtCTDzdnsxnC0baqmBHfMnn7jVV3ya7wBvNsYyQJY (skip by 10 seconds) I ran all the videos listed above in galaxy s10
  12. Hello! How should I configure server or something other for remembering selected audio/subtitles track? What do I mean: In user 'Playback' settings I checked 'Remember audio track selection' In user 'Subtitles' settings I checked 'Remember subtitles track selection' (preferred subtitles language = English; subtitles mode = 'No subtitles' (I experimented with all available subtitles modes, but nothing helps)) I go to a movie then select audio I need, subtitles I need, then go to home screen and go back to this movie again. And my chooses did not saved (all states look like as I did nothing) At playback time (I start movie playing and select while playback) change these settings does not saved also. Besides, I detect another playback problem: if I trying to change subtitles while movie playing - subtitles does not changed, also if I set it to 'None'. And if I choose subtitles before start playing then Emby for reasons I don't know select 1-st track only (I select 2-nd track but playing 1-st). Is it my wrong or server error?
  13. KurtisEagles

    Disable automatic subtitles

    Trying to download forced subs so I can enjoy the foreign language parts of The Mummy (1999). I can search subtitles no problem, but encounter an error trying to download them. Check the plugin settings, disable VPN, check my login info on opensubtitles.org only to find that I hit my maximum download limit. Puzzled, I click my opensubs account to find it downloaded subtitles for my entire tv library. Not newly added content, but a subtitle file for every episode of King of the Hill and every other tv show in my library. In easy to understand language, how do I turn this off? I don't want my IP banner from opensubs and I'd rather just have manual downloading for subtitles. How long do I have to wait for my limit to reset so I can watch my movie?
  14. The following errors appear in the console when I try to play a file with internal subtitles: wasm streaming compile failed: TypeError: WebAssembly: Expected Response or Promise resolving to Response falling back to ArrayBuffer instantiation Log files attached Confirmed that the subtitles play correctly using VLC, cannot search for open subtitles as the episode only aired today so there are none available ffmpeg-directstream-d5e51cfa-85f1-4376-aaea-efe3b8426d92_1.txt ffmpeg-directstream-12870b2e-7b56-4e50-9a9d-522394d4643c_1.txt ffmpeg-directstream-4915ef66-7a8e-45a9-b9e0-8c10f93d9aac_1.txt embyserver.txt
  15. gsites

    Coverart Subtitles

    hello How do I make a movie appearance if it's captioned? What is the name of the image to put in the specific folder? Can anyone help explaining how to do it? or say where you have some tutorial? I searched but did not find. thank you
  16. Recently, emby android client V1.6.79g does not show subtitles. I have 2 different servers running latest server releases and have Emby TV on 2 different Android boxes. I have always added .srt files to the folders that contain movies/tv episodes on both servers as I have hearing issues and need the subtitles. Previous to about 3 weeks ago, the subtitles displayed properly playing on both clients from both servers. The subtitle file shows in the "cc" drop down list but does not display. If I add a second subtitle file, then I can select one of the two subtitle files and it displays properly. Example: filename.srt and filename.en.srt and I am able to select one. If only one file, .srt or .en.srt, or .default.srt, then no subtitle is displayed even though it appears in the dropdown list for "cc". If I have at least 2 srt files then I can select either one. This problem occurs only on several versions of the Emby For Android TV app. I've gone back to a version 1.5.6 version and same problem. However other versions of Emby For Android are perfect, no problems with displaying subtitles. I'm running Emby servers on a Raspberry Pi 3 and Windows 10. Any suggestions as to the cause. I Have performed all new fresh installs on the servers and player boxes.
  17. Hi, How I can disable adding country code subtitle filename? So instead of MovieName.pl.srt Emby will download MovieName.srt file?
  18. Hello. Some time ago a new update for Emby Android App appeared on Play Store and there was mention (changelog) of a new internal player library being used (ExoPlayer?). From that version forward (tested all updates released after) I am unable to see subtitles on an external screen. I have Samsung Galaxy S10e with USB-C->HDMI cable and I am using it occasionally for watching movies on an external screen (TV/monitor) using Emby App. I am using this "method" for a few years, never had any issue, subtitles were shown on the external screen as expected. But currently, I see a movie on an external screen and subtitles on phones display, which is useless. When setting "use external player" in Emby App and using, for example, VLC, everything is fine with video and subtitles on external screen, but that is a rather ugly workaround with its own issues. I have downgraded to pre-ExoPlayer version of Emby App for now and everything is working well again, but I don't want to be stuck on the old version forever. Could this use-case be fixed, please? I can provide any further information or testing if necessary. Thanks
  19. Hello, i have a big problem with some movies on my library. this happen for some HEVC mkv videos. in most cases, I can see movies correctly, even if it also transcodes,yet without any problems. for other case, with the subtitile, the movie frequently shows the fanart picture, but from dashboard I can see my cpu has no pressure on transcoding and it has already transcoded for a few seconds more. But after few seconds, it suddenly turn to the fanart picture (just like the loading page) and then show that "No compatible streams are currently available". If I turn off the subtitle, the movies transcodes correctly without problem. One point to note is that when there are no subtitles, it can be transcoded without any problem even if transcoding is required. But when it has to transcode with subtitles, the problem occured. By the way, the problem only occured on the emby website which it must transcode on the server, while on windows client it can be played normally and show the subtitles correctly because it transcodes in native. for example, I recorded the screen to show this complicated situation. https://1drv.ms/v/s!AlY_WtrxBUtlgp9BlwI0cdCRPMe8dg?e=a6dZJp the file are all in .mkv+HEVC format and the ass subtitle. if i disable subtitle, the film transcodes and plays correctly. If there isn't enough infomation, please tell me what I should do to provide it for you. what is the cause of this problem? how can i solve? thank you very much!
  20. Hey dear friends, How is it possible to add a new subtitles site which will be available for Hebrew subs? The site is: https://wizdom.xyz/ hope you can help me with that! Thanks in advance! Idan
  21. Is there a way (programm, script etc.) to batch check and convert if neccessary the format of my subtitles to avoid transcoding? The thing is that for my 10k+ episodes I have external subtitles, all saved as .srt files BUT in some cases they are MicroDVD {2215}{2291}text or .mpl subtitles [171][210]text just with .srt extension so they cannot be played and are not displayed with i.e. Android TV app. How can I batch convert them without checking one after the other?
  22. Xalactic

    DVR/Live TV Subtitles?

    Got my Emby server connected to a HDHomeRun Connect Duo and it's happily recording all the things. However, subtitles are not available when playing back my DVR recordings. If I play the .ts files in VLC, it will detect and show the embedded subtitles. VLC actually picks up 4 different sets of subtitles, but only the first one does anything. I know I can configure OpenSubtitles and have it download the subtitles. Or, I could set MCEBuddy to extract them to a .srt file. Though both of these options seem unnecessary since the subtitles are embedded in the .ts files. Am I doing something wrong here, or has this functionality not been added yet? I found some previous posts asking about Live TV subtitles as well. Is there any status update on that? That's a feature I would really love to see. Thanks for the support and this great software.
  23. Hi there, a request for Emby Server. I have been using Download and Sync very much lately to minimize transcoding, the only thing I don't seem to find is an option to convert the movie/episode with multiple audio tracks and keeping their metadata so one can select the transcoded version and different languages within the transcoded version. This feature would be greatly appreciated.
  24. I'm requesting a feature addition to Emby Theater: a way to change the vertical positioning of subtitles in Emby Theater. I want to raise them up about one line height. I'm comparing native playback of subtitled movies as discs in PowerDVD to MKV in Emby Theater. Emby theater positions the subtitles significantly lower in the screen than the disc playback does, about one full line lower. This worsens the overall experience. For a letterboxed movie like "Amelie", the subtitles fall across the letterbox boundary in Emby while they're within the movie frame natively. And in all cases (also seen in a 1.85 movie like "Kiki's Delivery Service") the subtitles are too close to the bottom of the screen, farther from the natural viewing location, making it a bit harder to read and watch simultaneously. If subtitle height can't be made a user preference, based on my sampling of four or five foreign language films, subs should be about one line height higher to match native Blu-ray playback. The Emby Theater setting is too low, from my small sampling. Thanks
  25. This post is probably intended mainly for @Luke but I will appreciate comment/upvote or anything else that would benefit the discussion I'm the dev behind Bazarr and currently having discussion with the devs teams of major media servers/players (eg: Plex, Jellyfin) and I would like to bring Emby to the discussion table to get all the major teams to adopt a mutual standard regarding those subtitles. So, would it be possible in Emby to interpret correctly the language name for subtitles filename that would look like this? Film.en.hi.srt Film.en.cc.srt Film.en.sdh.srt They should be detected as English subtitles and it would be nice to see a custom tag to make the user aware of the hi/cc/sdh content. Thanks for joining the discussion. I hope will reach a consensus for that standard!
×
×
  • Create New...