Jump to content

Search the Community

Showing results for tags 'subtitles'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. I can usually figure out anything I need to know using the Wiki guide or reading the forum, but this has me stumped. The reports have started showing my newly added movies as having subtitles: None of the above listed have subtitles. But take Saw, when I try to ply it in the Theater app (nice app!) it shows a subtitle available foe ENG. When I select it, no subtitles play. I believe this started happening when I updated to Version 3.0.7200.0, which I'm still on. BtW, I'm not embedding any subtitles and Media Info doesn't show them. Log file attached. TIA for any assistance. server-63612000000.txt
  2. I have some .mkv files with subtitles (each .srt file has the same name as its corresponding .mkv file). So basically I am streaming those files to Kodi using the Emby kodi addon. My subtitles are Greek. The playback is smooth and the subs are there but they are gibberish, which means there is something wrong with the encoding. I have set the Subtitle encoding settings on Kodi for Greek-Windows or Greek-ISO but nothing happened. What can I do so the subtitle are shown normally? Edit: This is my .srt file, in case you wanna test it.
  3. Didn't have this issue before only after the roll-out of iOS 10. Videos on iOS used to have controls and overlay that wasn't the native iOS video playback. CC also used to work differently and would allow more support for various sub formats, now subtitles seems to only work for .srt with the native player. Is there a way to make the iOS Emby use the player pre-iOS 10? When stopping playback, I can see the subtitles laid on the video.
  4. Today I noticed that some episodes my wife was watching in ET were all transcoding instead of Direct Playing. It turned out that the only thing making them transcode was the fact that they had external ASS subtitles. I converted the subs to SRT and (after a rescan) the video now direct plays. Considering that the subs in both cases are being rendered by XySubFilter why is it transcoding? This displays in the log when ASS subs exist: isEligibleForDirectPlay: False, isEligibleForDirectStream: False But after changing them to SRT this displays: isEligibleForDirectPlay: True, isEligibleForDirectStream: True
  5. I've noticed that closed captions in recorded TV are no longer working in the Android App, Emby Server but do work in Emby Theater. Up until around 6 weeks ago these were working in every client perfectly. I run NPVR between my tuners and Emby and it has always displayed closed captions both in recorded TV and Live TV. As I haven't seen any other reports on this I'm assuming that it is only in my setup. I'm about to to do a clean install of Win 10, but thought i'd ask first. I need closed captions to work everywhere as my wife has hearing difficulties and needs subs and closed captions. Let me know what else I can provide to try and fix this.
  6. martinandres987

    Chromecast and subtitles

    Hello everyone, my English is not very good but we will try my luck asking if anyone knows if there is any way to change the size or at least the color of the subtitles when you send content from android to a chromecast or if there I post it on github for them to add in a next version if it is possible the solution of it ... From already thank you very much to anyone that I can answer this question ... Greetings.
  7. It would be great if it was possible to create custom profiles for Sync, with options like bitrate, output format, subtitle handling (keep them as they are, mux them into a container or hardsub selected one), audio streams (transcode all of them, not only default one). I am writing this, because syncing files with multiple audio/subtitle tracks could really use some improvement.
  8. Hi there Tl;dr: OpenSubtitleDownloader downloads the subtitles anyway, even though there are no permissions to write them to the filesystem. I found a potential misbehavior of the OpenSubtitleDownloader worker. The case is the following: - repeatedly got notifications about failed subtitle downloads - day after day the same, though there were not many new subtitles to download - thought I got an IP ban (my ISP barely changes IPs because of VDSL, no way to easily renew it but call the hotline...) - e-mailed the admin of opensubtitles.org, asking to lift the ban - turns out there is no ban, but instead I find that my account downloaded more than 22000 subtitles although there way less than 1000 unique titles on my server (hence very few subtitles actually needed) So I started digging a bit deeper and found the following: - First, there are many reports because of "Access to the path ... is denied. System.Unauthorized.AccessException". (There are exactly 200 of those log entries every day, which matches the daily limit by opensubtitles.org.) - After those messages, numberless other entries exist because of "OpenSubtitles rate limit reached, System.ApplicationException". I found the problem being wrong ownership/permission of the folders (my mistake / samba problem, should have known that sooner). My guess is that the OpenSubtitleDownloader downloads the subtitles anyway, even though there are no permissions to write them to the filesystem. This kind of behavior could be fixed, if the permissions were checked first and download initiated later on. It would sure lower the traffic for all parties. Also could help debugging for fellow users, as the download limit is not the actual problem. So, maybe this could be adjusted in the next release? --- Example log entries:
  9. Hi, From reading the forums I gather that Emby always downloads the first subtitle it finds for a certain show or movie. In my experience this means that the majority of subtitles Emby downloads are incorrect. This is especially true for tv shows and non English subtitles. I would to request a feature to only download subtitles if a certain keyword is found in the filename to filter out subtitles that don’t match the source. E.g. only download subtitles if DVD is present in the filename. This should increase accuracy to a near 100%, especially for tv shows, where accuracy is now around 0% for me.
  10. Hi, I'm trying the web client on an android and can't find a way to choose subtitles. Is there a way to a) choose subtitles from the ones that exist on the server download a new file from the player page on the browser for content for which there are no subtitles on the server ? Thanks, Gonçalo
  11. nintendo424

    Embedded Subtitles Not Displaying

    Hi, I've been trying to watch various shows I have with embedded subtitles through VLC and BubbleUPNP via DLNA. Subtitles and dual audio options are unavailable through both options. Any tips? Is it a bug? I can take screenshots as necessary.
  12. cvika

    Subtitles question

    Is there a way to use subtitle in .mkv file as default? All my movies have 2 subtitles - one external MovieName.srt and one internal with language code (srp) as default and not forced. When use HTTP instead of SMB always is active external subtitle that does not have all the letters (wrong code page). Manually I can switch to internal subtitle and all is OK. On DirectPath working OK, Kodi use external subtitle but code page is OK.
  13. moviemadnessman

    Report Question

    Just a quick question about the reports features ... I went to take a look at my reports for all the movies in my library, and have found that you can show all in one page (nice!). However, for some reason, it does not mark which movies have trailers, specials, or subtitles anymore, even though I know almost all of my movies contain either internal or external subtitles (and in many cases they have both), and some do contain the trailer(s) as well. I think I remember the reports used to show a check mark if these were present, but that seems to have changed, unless I'm overlooking something. Beta server Version 3.0.5897.0 Also, while on the subject of server reports ... physical file location would still be a great feature; unsure how to implement it or I would, so I can see what files are on which drives (useful if one fails or whatnot ) EDIT: I just noticed that if I export the report to Excel, it is marked which films have the subtitle/trailer/specials. However, because it is not marked when viewing in the web browser, sort features such as "which movies do not have subtitles" do not work. I'm unsure where the discrepancy would be, since at some point, Emby sees the missing data and puts it into an exported excel file correctly.
  14. vigilian

    subtitles not working

    Hi, Since the previous post speak about video layout etc I was thinking that it is another issue. The ass subtitles downloaded by the server from opensubtitles seems not playable. But I can select it in most of the recognized videos. SRT seem to work more or less, i'm not sure about all my vids but that at least seems okey ....I have last version of everything in emby server and theatre. So what should I produce as logs? maybe it's a server problem?
  15. Kavalera

    How to make bigger subtitles

    HI Emby Team, your app is really good but till now i cannot understand how peaple looks the movies because the subtitles are too small. I am talking nor for burn in subtitles. In other apps like Ple* there is an option to select small, big, bigger, large. Here there is no option or i cannot find it. Can you support me how to solve the issue. Thank you very much in advance.
  16. pushka7

    Subtitles

    Is it possible to download subtitles for movies via Emby? If yes, how do I do this?
  17. I have forced subtitles and have the playback settings set to forced. However, the subtitles do not show. Playback of the movie is always set to off. Is there an additional setting?
  18. mystic.bertie

    Subtitles will not load

    Hi guys, i dont usually use subtitles much but not long ago i managed to get Polish subtitles displaying fine when using the previous version of Emby, 100% of the time. With the new Emby it would only work for 2 out of 5 movies, after a bit of research, the movies that wont display the Polish subtitles actually have internal subtitles. See snapshot below. I have tried the different settings for subtitles 'always' 'default' 'smart' and it wont make a difference. The Polish subtitles are only shown when the movie has no internal subtitles. How can i fix this?
  19. Hi, All of a sudden Emby has stopped downloading subtitles. Could you have a look please? Spanner server-63591254836.txt
  20. I've seen some other topics regarding this matter, but nothing conclusive. I'd like to embed all external .srt files inside their respective .mkv media containers. Is that too demanding for the server? Does it use transcoding every time for the whole video? If Emby only does extract a temporary srt to stream to the client (without transcoding), it would be better, even if take 1 or 2 more seconds to load.
  21. Magliok Fireborne

    Subtitles Failing to Download

    Hello, I'm running Emby in a Docker image, on Unraid. So far very happy with the system, as I am considering moving from Plex to Emby. However, one of the features I do rely on from Plex, is the automatic downloading of Subtitles. I have it configured in Emby, double-verified user / pass was right, and I'm getting nothing but a ton of "Subtitles Failed To Download" My library scan is not complete yet, any help here on why they are failing. Hopefully things start working once the scan for my libraries are done. Maybe it can't tell what subtitle to grab if it hasn't identified the movies yet - what I'm thinking. Can anyone confirm?
  22. I just recently got a new Sony bravia smart TV with Android TV. Of course immediately downloaded the Emby app and connected to my server. Love the immediately accessibility of my full media library. Only problem I am noticing is that every movie I start playing always defaults to playing subtitles also. I can turn them off while the movie is playing but if I stop and restart or start another movie after the first one is done they are turned back on again. Pausing, or exiting to emby menu and then resuming doesn't appear to create the same error. Can't find a setting to change this. Am I missing something? I'm on server v3.0.5818.0 and apparently the most updated version of the emby app on android TV as of the posting of this post. I never had this problem using the same server source and streaming source when streaming to a Roku 3. Any help would be appreciated.
  23. Agyy

    Problem med åäö

    Hej, Jag har problem med åäö på textningen i Emby det som händer är att det blir ett tecken som ser ut som en diamant med ett frågetecken istället för åäö är det något jag kan göra för att det ska fungera eller är det något som måste korrigeras i emby?
  24. It seems that the movie title is being used when searching for subtitles inside Kodi (so when using Kodi's subtitle plugin) while using the Emby plugin. However, I find I get better subtitle matches when using the actual filename instead. A workaround is using local paths instead of the plugin redirect but this is not so easy for remote Emby servers (outside of the local network). I tried to use path substitutions by using a FTP server, and while this works Kodi doesn't always stream video's that well over FTP (resuming after a little pause sometimes causes Kodi to hang). Example of a working FTP path substitution: D:\Movies\ ftp://Username:Password@host.com:21/Movies/ However because FTP wasn't working that well with Kodi I changed to HTTPS by using Apache server and using password protected directory listings (this already is my preferred method of streaming over the internet, even before I found out about Emby). So I figured if path substitutions work with FTP they should work with HTTPS as well, so I entered: D:\Movies\ https://test:test@host.com:443/media/Movies/ However over https I think this doesn't work because of URI formatting (spaces need to be escaped to %20), the Kodi log shows this: 15:49:01 T:7272 ERROR: CCurlFile::Open failed with code 404 for https://USERNAME:PASSWORD@host.com/media/Movies/Ant-Man (2015)/Ant-Man.2015.1080p.BluRay.x264-SPARKS.mkv 15:49:01 T:7272 ERROR: XFILE::CFileCache::Open - failed to open source <https://USERNAME:PASSWORD@host.com/media/Movies/Ant-Man (2015)/Ant-Man.2015.1080p.BluRay.x264-SPARKS.mkv> 15:49:01 T:7272 ERROR: CDVDPlayer::OpenInputStream - error opening [https://test:test@host.com/media/Movies/Ant-Man (2015)/Ant-Man.2015.1080p.BluRay.x264-SPARKS.mkv] 15:49:01 T:7272 NOTICE: CDVDPlayer::OnExit() 15:49:01 T:1316 ERROR: Playlist Player: skipping unplayable item: 0, path [https://USERNAME:PASSWORD@host.com/media/Movies/Ant-Man (2015)/Ant-Man.2015.1080p.BluRay.x264-SPARKS.mkv] I believe this way I tried all the alternative setups in which I use Emby ánd have Kodi use the filename to search subtitles. However none of them are really an ideal situation. TL;DR Of course I tried all of this in the first place because I simply want Kodi to use the filename when searching for subtitles. In fact I would prefer to keep settings and setup as simple as possible by using the default plugin redirect so keep al Emby features and let Emby handle the remote streaming process over HTTP(S). So I would like to request this as a feature for Emby for Kodi: pass along the actual video filename to the Kodi subtitle searcher (instead of the movie / series name) to get better matching subtitles. Thanks for reading .
  25. SSJ4Gokou

    Smart subtitles

    I don't really know where to post, but using a dlna device is where I first noticed it. I went into my user preferences and changed the subtitles to smart since I watch some anime in Japanese and they hardcode the subtitles. Everything works. I was watching izombie and since changing the subtitles to smart I started seeing them when streaming to my Joey. After some research I realized as ling as there was a .srt file it will force subtitles to the video. Isn't smart supposed to only push to the video if the language doesn't match? So if it's in another language and the .srt file is is English it will then show subtitles? Not when the language is eng and the subtitle is eng it shows the subtitles anyways. Am I reading what smart subtitle mean?
×
×
  • Create New...