Jump to content

Search the Community

Showing results for tags 'subtitles'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi, How I can disable adding country code subtitle filename? So instead of MovieName.pl.srt Emby will download MovieName.srt file?
  2. Hello. Some time ago a new update for Emby Android App appeared on Play Store and there was mention (changelog) of a new internal player library being used (ExoPlayer?). From that version forward (tested all updates released after) I am unable to see subtitles on an external screen. I have Samsung Galaxy S10e with USB-C->HDMI cable and I am using it occasionally for watching movies on an external screen (TV/monitor) using Emby App. I am using this "method" for a few years, never had any issue, subtitles were shown on the external screen as expected. But currently, I see a movie on an external screen and subtitles on phones display, which is useless. When setting "use external player" in Emby App and using, for example, VLC, everything is fine with video and subtitles on external screen, but that is a rather ugly workaround with its own issues. I have downgraded to pre-ExoPlayer version of Emby App for now and everything is working well again, but I don't want to be stuck on the old version forever. Could this use-case be fixed, please? I can provide any further information or testing if necessary. Thanks
  3. Hello, i have a big problem with some movies on my library. this happen for some HEVC mkv videos. in most cases, I can see movies correctly, even if it also transcodes,yet without any problems. for other case, with the subtitile, the movie frequently shows the fanart picture, but from dashboard I can see my cpu has no pressure on transcoding and it has already transcoded for a few seconds more. But after few seconds, it suddenly turn to the fanart picture (just like the loading page) and then show that "No compatible streams are currently available". If I turn off the subtitle, the movies transcodes correctly without problem. One point to note is that when there are no subtitles, it can be transcoded without any problem even if transcoding is required. But when it has to transcode with subtitles, the problem occured. By the way, the problem only occured on the emby website which it must transcode on the server, while on windows client it can be played normally and show the subtitles correctly because it transcodes in native. for example, I recorded the screen to show this complicated situation. https://1drv.ms/v/s!AlY_WtrxBUtlgp9BlwI0cdCRPMe8dg?e=a6dZJp the file are all in .mkv+HEVC format and the ass subtitle. if i disable subtitle, the film transcodes and plays correctly. If there isn't enough infomation, please tell me what I should do to provide it for you. what is the cause of this problem? how can i solve? thank you very much!
  4. Hey dear friends, How is it possible to add a new subtitles site which will be available for Hebrew subs? The site is: https://wizdom.xyz/ hope you can help me with that! Thanks in advance! Idan
  5. Is there a way (programm, script etc.) to batch check and convert if neccessary the format of my subtitles to avoid transcoding? The thing is that for my 10k+ episodes I have external subtitles, all saved as .srt files BUT in some cases they are MicroDVD {2215}{2291}text or .mpl subtitles [171][210]text just with .srt extension so they cannot be played and are not displayed with i.e. Android TV app. How can I batch convert them without checking one after the other?
  6. Xalactic

    DVR/Live TV Subtitles?

    Got my Emby server connected to a HDHomeRun Connect Duo and it's happily recording all the things. However, subtitles are not available when playing back my DVR recordings. If I play the .ts files in VLC, it will detect and show the embedded subtitles. VLC actually picks up 4 different sets of subtitles, but only the first one does anything. I know I can configure OpenSubtitles and have it download the subtitles. Or, I could set MCEBuddy to extract them to a .srt file. Though both of these options seem unnecessary since the subtitles are embedded in the .ts files. Am I doing something wrong here, or has this functionality not been added yet? I found some previous posts asking about Live TV subtitles as well. Is there any status update on that? That's a feature I would really love to see. Thanks for the support and this great software.
  7. Hi there, a request for Emby Server. I have been using Download and Sync very much lately to minimize transcoding, the only thing I don't seem to find is an option to convert the movie/episode with multiple audio tracks and keeping their metadata so one can select the transcoded version and different languages within the transcoded version. This feature would be greatly appreciated.
  8. I'm requesting a feature addition to Emby Theater: a way to change the vertical positioning of subtitles in Emby Theater. I want to raise them up about one line height. I'm comparing native playback of subtitled movies as discs in PowerDVD to MKV in Emby Theater. Emby theater positions the subtitles significantly lower in the screen than the disc playback does, about one full line lower. This worsens the overall experience. For a letterboxed movie like "Amelie", the subtitles fall across the letterbox boundary in Emby while they're within the movie frame natively. And in all cases (also seen in a 1.85 movie like "Kiki's Delivery Service") the subtitles are too close to the bottom of the screen, farther from the natural viewing location, making it a bit harder to read and watch simultaneously. If subtitle height can't be made a user preference, based on my sampling of four or five foreign language films, subs should be about one line height higher to match native Blu-ray playback. The Emby Theater setting is too low, from my small sampling. Thanks
  9. This post is probably intended mainly for @Luke but I will appreciate comment/upvote or anything else that would benefit the discussion I'm the dev behind Bazarr and currently having discussion with the devs teams of major media servers/players (eg: Plex, Jellyfin) and I would like to bring Emby to the discussion table to get all the major teams to adopt a mutual standard regarding those subtitles. So, would it be possible in Emby to interpret correctly the language name for subtitles filename that would look like this? Film.en.hi.srt Film.en.cc.srt Film.en.sdh.srt They should be detected as English subtitles and it would be nice to see a custom tag to make the user aware of the hi/cc/sdh content. Thanks for joining the discussion. I hope will reach a consensus for that standard!
  10. Hello, I have been having an issue with subtitles for certain films when streaming to an older Chromecast and am having a hard time pinning down the cause of this, so was wondering if anybody else is having this issue. While I have found various posts about this issue in the recent past, I have not found anything to explain and/or resolve the issue. Details: This occurs while streaming from Windows or Linux machine, so I do not think it is a problem that is related to the install or the OS. The subtitles do show when playing through a browser, on an Android phone, or streaming to a Roku streaming stick, so it seems to be a "Chromecast-only" issue. When streaming to the Chromecast, the subtitles will momentarily appear when the video is started, but disappear after about 0.5 seconds. This problem "seems" independent of file type/format (although I doubt this is the case). I am currently running Emby Server 4.4.3.0 (Win10/Linux Mint 19.3). I think have tried almost every combination of configuration adjustments over the past two weeks in order to resolve this, but so far have had no success. Any suggestions would be greatly appreciated. Cheers Update 1 (21.09.2020): I installed Jellyfin last night and it has no issues showing subtitles when streaming to the Chromecast, so this seems to be an Emby issue.
  11. From browser Bangla subtitle working fine, but in Emby android app it's not working. I think this is Bangla font issue from Emby Android app. How can i solve it? I added two screenshots from Browser and Emby Android so that anyone can understand the problem. Thanks in advance.
  12. Hi, first congratulations for all this work. Great! I have a problem, subtitles work fine in the Web version as you can see below: However, in the Android version do not work: Thank you very much in advance.
  13. So I dunno when it started, but its recent, subtitles are placed too low, pretty much at the very bottom of the screen in both Chrome and Firefox, in Emby Theater, on Chromecast and on my Smart TV this is not an issue. So I am not sure what happend on the browser version. Anyone experienced this? I cant seem to find anywhere to adjust subtitle positioning. I have attached a PNG file to show my issue.
  14. Feature Request Permit subtitle backgrounds for better visibility. It would be good to allow subtitle backgrounds with variable opacity so that the sub text can overlay any existing text. There might be issues where the subtitle is in the same color as the background that might cause viewing issues. I understand that you can change the text color, but this is inconvenient to change the subtitle color to avoid the issue. Let's say I'm watching a video with white hardsubs, and it conflicts with my external subs. Having sub backgrounds would permit a more enjoyable viewing experience and prevent the need to change the color. Example Netflix has a subtitle appearance that permits subtitle backgrounds.
  15. Hi guys, Season 1 local subs played ok, some out of sync. Was able to search more using the native downloader. All sub options ok. The other seasons are missing local subs. Strangely I can't locate a single one using the downloader. So I downloaded my own. I have restarted the server and scanned library as well as restarting the app. Subtitles obviously enabled in settings. But I have no options in the settings cog from player. There's no sub drop down like there usually is at the playing media screen. And the newly added subs aren't automatically playing. Images attached. Your help is appreciated.
  16. Is it possible to have more control over how the subtitle appears? Stuff like border size, drop shadow size, custom color, etc? Thanks.
  17. Following issue: Sometimes I need to try a few different subtitles until I find one where the timing is correct. In the emby webapp I always have to exit the movie to be able to download new subtitles (via "Edit subtitles"). So its actually alot of clicks if I need to try a few different ones. So I was wondering if there is any way to change the used subtitle while the movie keeps playing? I tried opening a second tab and editing the subtitles there (while the movie kept playing in the seond tab), but the newly downloaded subtitles don't seem to get used until I completely exit the movie and open it again. Is there any way to achieve what I'm trying to do?
  18. MBS 5264 How is the new download subtitles feature supposed to work? I was expecting it to download SRT subtitle files from opensubtitles.org and save them in the folder along with the video file, or perhaps in a subtitles subfolder. But I cannot seem to get subtitles to download. I checked Download Subtitles for Episodes, checked for English language, unchecked "Skip if the default audio track matches the download language", and tried both checked and unchecked for "Skip if the video already contains graphical subtitles". I entered my opensubtitles username and password and clicked "save" (now the password does not show, but I assume it got saved -- ideally MBS should show circles in that field to indicate a saved but blanked out password). Then I ran the "Scan Media Library" task. But it completed in about 20 seconds and did not do anything, despite there being hundreds or thousands of TV Episodes that need subtitles downloaded. Is it supposed to only download the subtitles file when I go to play a video? I used MBC to play a video (via MPC-HC) that I know opensubtitles has a file for, but nothing was downloaded and there were no subtitles visible. Do subtitles only work through the web interface? I tried playing an episode through the web interface and I did not see any subtitles.
  19. There needs to be a way on the XBox to move the location of the subtitles up and down. I use this with a projector and it sometimes has them off the bottom of the screen. Font/size and things would be nice, but at minimum some kind of +/- 0 for the location needs to be available. Simply locking it to the bottom of the video is not sufficient.
  20. EVDEADSHOT

    Subtitles out of sync

    Hi guys, Loving the work you’ve done. Is there any update on the discussion around the subtitle delay setting? My subs are fine, they play correctly in VLC locally. But when I cast to my tv, all subs play ahead of audio by 4 or 5 seconds. If anyone has any input that’d be appreciated too. But yeah keen to hear what’s happening with the prospect of subtitle delay settings. Thanks.
  21. I have recently started ripping my UHD Blu-rays for play back in Emby, and discovered issues with subtitle transcoding. In the past, my 1080p Blu-ray rips have been in HEVC, whatever the main audio track is, as well as only forced/foreign subtitle tracks if there are any. Normally I would extract the PGS (.sup file) and convert to VobSub using BDSup2Sub and that would work fine. This has been a habit that started back when Blu-ray subs weren't supported by the codecs on my old HTPC way back when, but handled DVD subs (VobSub) fine. The first 4K disc I have ripped that requires a forced subtitle track is Avengers: Infinity War for just one line of dialogue in the whole movie. I have tested playing this back using PGS, VobSub and also SRT. PGS and SRT seem to be OK and everything direct plays, however the VobSub version wants to transcode everything just to burn that single line of text onto the video. The HD audio also gets transcoded back to Dolby Digital. To test this further, I went back and tried some 1080p Blu-rays I had ripped previously with VobSub subtitle tracks and found that they too are being transcoded. My main benchmark for testing subtitle playback has been my rip of Avatar which used to play fine, but now the subtitles are being burnt in and the audio is also not coming through as DTS-HD as it should. VobSub maintains the font style and colour from the PGS subs on movies such as this that would be lost if I used SRT. My Emby server doesn't have the processor power for 4K transcoding, so it becomes unwatchable, but is fine with 1080p rips. So for future rips, I will be happy to use PGS as long as it continues to work properly. However, I would definitely prefer to avoid transcoding my older ones with VobSub subtitles so that the audio can be kept in the original HD format. I especially don't want to have to re-mux all of my older movies with different subtitles if it can be avoided either. Current setup consists of Emby app running on an Nvidia Shield connected via HDMI to a Pioneer receiver (supports HDMI 1.4 and HD audio formats) then to a 4K Sony TV.
  22. Bello, I've noticed in the latest beta update that subs that used to be the perfect size and "styling" now looks smaller and different in terms of font, and the text is so small that its basically unusable, I've tested this with several shows with ASS subtitles and have compared the beta and non beta apps and there definitely is a big difference, if required I can upload some example screenshots showing the difference in font.
  23. astynax777

    UTF-8 Chinese Subtitles

    Based on what I've read on this forum, UTF-8 encoded .srt subtitles should be supported by Emby Server. Is this correct? If so, perhaps there is a configuration issue I'm missing to make mine work? I'm not getting the expected results: In VLC the subtitles show as expected (same pc): and these are my settings in VLC to make them work: Any help would be appreciated.
  24. Tom1234

    Subtitles

    I have a file that displays Subtitles ONLY on the Emby Server/Player on my Windows 10 computer. The Subtitles will NOT show up when playing the video on VLC, Quicktime, an Emby client app, or using my Mackbook Pro as a server. Why will the Subtitles only display on the Emby Server/Player, and NOT on anything else?
  25. I am experiencing the issue whereby subtitles do not appear when the video plays on my iPad Pro. The same video plays with subtitles perfectly on my Samsung Galaxy S10+ as well as my Windows laptop. Here are the following information if required: 1. Currently a premium member with Emby (Hardware Transcoding option activated) 2. Emby on iPad running version 1.9.7 3. Same video file plays fine and subtitles all display perfectly on Android phone and windows laptop. 4. Huge buffering when played on iPad Pro (Please refer to below screenshot). I had to drop the Quality to 480p - 1 Mbps to allow for smooth playback. Doubt that this is a Internet issue as windows and phone are running on same network and plays file fine in 720p 5. File Info: Title: 1080p H264 Codec: H264 AVC: Yes Profile: High Level: 41 Resolution: 1920x960 Aspect Ratio: 2:1 Anamorphic: No Interlaced: No Framerate: 24 Bitrate: 8,984 kbps Bit Depth: 8 bit Pixel Formatyuv: 420p Reference Frames1 NAL4 Looking forward to your response. Thanks in advance.
×
×
  • Create New...