Jump to content

Search the Community

Showing results for tags 'subtitle'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hello all. I've recently found that all of my Google TV clients (new Chromecast) do not display subtitles. Movie subtitles will show up provided they are already there, but never TV shows. I can download show subs through the app, and even hash matched subs won't show up after being downloaded. If I play the same episode on my android phone, PC, or firestick however, the subtitles will show.
  2. After investigating my lack of subtitles, I found that my opensubtitles free account no longer existed. I registered a new one with the same email address and verified it. I can now login to the website and search for subtitles there. However, updating the login credentials in the plugin still fails to produce subtitles. My embyserver log shows an HTTP error 520. Is anyone else getting this? Looks like either they've blackballed the API used by Emby or the plugin needs an update. Operating system: Linux version 5.4.0-80-generic (buildd@lcy01-amd64-030) (gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)) #90-Ubuntu SMP Fri Jul 9 22:49:44 UTC 2021 Framework: .NET Core 3.1.13 OS/Process: x64/x64 Runtime: opt/emby-server/system/System.Private.CoreLib.dll Processor count: 8 Data path: /var/lib/emby Application path: /opt/emby-server/system MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: 520 at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod) at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod) at OpenSubtitles.OpenSubtitleDownloader.SendRequestAsync(ReadOnlyMemory`1 request, CancellationToken cancellationToken) at OpenSubtitles.OpenSubtitleDownloader.Login(CancellationToken cancellationToken) at OpenSubtitles.OpenSubtitleDownloader.Search(SubtitleSearchRequest request, CancellationToken cancellationToken) at MediaBrowser.Providers.Subtitles.SubtitleManager.<>c__DisplayClass17_0.<<SearchSubtitles>b__3>d.MoveNext() Source: Emby.Server.Implementations TargetSite: Void MoveNext()
  3. 在今年五月份的时候,搭建好了 sonarr raddarr emby ,总体来说很棒。但是困扰我的是字幕的获取问题。新一些的剧集就很难比较快的得到中文字幕。 In May of this year, Sonarr Raddarr Emby was built, and overall it was great.But what bothers me is the problem of getting subtitles.Newer episodes have a hard time getting Chinese subtitles quickly. 于是我开发了一款自动下载字幕的下载工具 So I developed a download tool that automatically downloads subtitles docker hub: https://hub.docker.com/repository/docker/allanpk716/chinesesubfinder github: https://github.com/allanpk716/ChineseSubFinder 有别于其他的中文字幕下载工具,本工具依赖于 IMDB ID 工作,并且需要进行基本的削刮后才能使用。也就是文件名需要规范。 Unlike other Chinese subtitle download tools, this tool relies on the IMDB ID to work and requires basic scraping to be used.That is, file names need to be standardized. 本来是考虑过做成 emby 的插件的,但是看到论坛中讨论说如果不是 open api 接口去拿数据的,就不太适合上架。所以就只能独立运行啦。 I was considering making it an Emby plugin, but I read the discussion in the forum that if you don't have the Open API interface to get data, it's not suitable to put it on the shelf.So it just runs on its own. 欢迎试用,工具的目的是简单粗暴的自动下载,设置够简单。 Welcome to try, the purpose of the tool is simple and crude automatic download, the setup is simple enough. 工具还在开发中,想提高自动化程度,以及搜索的速度。 Tools are still being developed to increase the level of automation and speed of search. 功能建议可以在这里提,或者 Github issues 更好。 Suggestions can be made here, or better yet, GitHub Issues. Github issue:https://github.com/allanpk716/ChineseSubFinder/issues
  4. Hi, I want to download a video from my server (for offline viewing) that has external subtitles (srt). From my web browser, I navigate to the video, go to "...More" > Download. Video file is downloaded just fine. However I cannot find anywhere how to download the srt subtitles from the server. Am I missing something here or is not really possible?
  5. and no i doubt its the subtitle itself since it appears perfectly sized in other players
  6. Hi! I like the auto subtitle download feature, but I do not want to use it for all shows/movies. I watch media in Hungarian language if possible, or with Hu subtitle if not. Many times the audio track is not marked as Hu, or the subtitle filename does not end with .hu, but it is still there. I understand it cannot be watched automatically if it is not marked properly, but it would be helpful if I could mark a TV show/movie to be excluded from auto subtitle search and download.
  7. Hi, can we have the fabulous shadows as option for subtitles in this magnific app, too? I prefer the yellow subtitle style and in the case of a bright or white background it's a little bit hard to read. The shadows would be generate are small dark frame around every single letter to improve the readability. So would it be possible to avoid a full background for the sub and get a better readability at the same time. Thx for consideration.
  8. David9Points

    Subtitles not downloading on MacOS

    Hello, Although scheduled to run each night. The process to download any new subtitles is set to run, and does. However, it doesn't download all the subtitles, in fact it fails with the following message: ffmpeg subtitle extraction failed for file:"/Users/David/emby-server/cache/temp/23f0ce6d-0784-4cf4-afe8-dc84a7fd885f.txt" to /Users/David/emby-server/cache/subtitles I have noticed a number of the TV Show's I have on my NAS (That is connected to Emby) doesn't have subtitles. Does anyone have any ideas how I can fix this? Thanks
  9. Sry, Maybe post wrong place, but I can't delete this by myself, I'll post this to emby server/general/windows From Emby web client From potplayer From VLC player you can see the subtitle in Emby web client is very very small. the setting to change the font size in Emby web client is not useful cause the font size is written in the ass file. this one's size is 60. If needed, I can provide this .ass file.
  10. norbo80

    Subtitle error

    Hi, i would like to run Emby for windows, I installed it and configured, but Emby don't download the subtitles. In log i can find an error: Method not found: 'MediaBrowser.Model.Globalization.CultureDto MediaBrowser.Model.Globalization.ILocalizationManager.FindLanguageInfo(System.String)' thank you for any help log.txt
  11. Quick question that might have a quick response. After setting up a new server, I noticed that whenever I run the "download subtitles" task it always takes over 2 hours. I thought it was normal at first since it was starting from scratch. But it's been a month and it's still taking just as long. When I opened up the log, I did notice a few errors, but I'm completely unfamiliar with it, so I do need some help deciphering it please. I believe the log includes the two times I ran it today. I'm pretty sure this question will come up, but I did sign into my Open Subtitles account (Free account, not VIP) on the dashboard. Here is a link to my log: https://filebin.net/fxsw3xneaqthg1wj/embyserver.txt?t=zt4ilqlz Definitely let me know if I can clarify anything! Thank you as always!
  12. I'm ready to wipe this program and re-install, but really don't want to set everything up again. A month ago the only issues I had with this program were TV show episodes not going to the next one at random intervals. This problem has been systematically getting worse.and started with movies. Until Thursday or Friday, it wasn't affecting TV shows at all. Movies started pausing or skipping if the embedded subtitles were used. Often they would finally work with repeated tries. Now, unless subtitles are off or srt files are used, movies won't play. In general, I don't mind srt subtitles but they do not line up with the movie timing. Like I said, this was going on with movies but you could finish a movie and go to a TV show and the TV show would play fine. Now nothing plays right. I don't know if the Emby program settings are screwed up (a big possibility) or if part of the program has become corrupted. This is happening across several user profiles and is happening with both the LG TV and if trying to play directly in the web interface. Issues apply to DVD and Bluray. I would say 4k, but I don't know if those issues are 4k issues or these issues. But starting and stopping, especially with subtitles was first noticed on 4k movies. Oh, have seen the error "Playback Error: No compatible streams are currently available. Please try again later or contact your system administrator for details." a couple of times tonight. As soon as I "try again" the file plays. Any help whatsoever is greatly appreciated. embyserver.txt ffmpeg-transcode-6b942f4c-719a-4889-b071-cab3dd2f31da_1.txt ffmpeg-transcode-07467def-4b2e-4f35-8183-1b03a6a928a5_1.txt ffmpeg-transcode-b237b0f5-cd3e-426a-9a8b-25bb6b9a6c2b_1.txt
  13. GoofyCDN

    Subtitle Location not changing

    I have set up my Emby server a while ago, but haven't really used it much. I have been running Plex for years, but am experimenting with switching to Emby. There are a number of things I like about each. With all that said I have one issue that i can't seem to get to work properly. I have a number of movies and shows that are missing subtitles. I like the fact with Emby I can go and to each individually if needed and click download to search OpenSubtitles. I have done this but every time I do the subtitles go into the metadata location at /var/lib/emby. I have the box checked to save subtitles in the media folder. Shouldn't that save the location to the same location as the media folder? Steps taken so far Removed all SRT files from /var/lib/emby/metadata/library.... Checked the library for the "save subtitles to media location" restarted server Ran library scan Refresh metadata - replace all metadata I have even deleted the library and added it back. I did name the new library the same as the old library. Any help would be appreciated Thanks
  14. hello everyone can somebody guide me how to add a custom font to make my emby use it for subtitles, I already have the font file and it's works like a charm in another media player but I really liked empy and I don't want to use any other platform. best regards
  15. hopykito

    Black screen on specific files

    Hi Guys ! TV : LG Smart TV (OLED55B8PLA) - Software : 05.10.50 Emby Server version: 4.4.0.40 Operating system: Unix 4.4.59.0 I have some strange crash when i play specific files only in my LG TV This files is : Anime with subtitle VOSTFR Stream is ok with Android phone and with computer But why i have only the problem with LG (i think the problem is subtitle) In my tv LG i have this scenario : Start 2s show and black screen and start again and black screen ... i have this message error (in french) : "Aucun flux compatible n'est actuellement disponible." Logs and video here : https://wetransfer.com/downloads/cd90dc46bd9b8e3e08af05f464c0ae5620200421091512/54fe3b Thanks guys ! ffmpeg-directstream-bd744a78-5645-4dd5-9bf6-cc9e3dbf38b5_1.txt ffmpeg-transcode-25f31677-e3af-4f3a-be52-5f7df0101cb0_1.txt ffmpeg-transcode-d7a10017-03f7-48d9-9909-3eb2cc9ef16a_1.txt
  16. ayoubmst7

    Change Subtitle Font

    hi, I Start using for while now and the subtitle font looks terrible on android mobile. a lot of letter don't shows up, if somebody knows how to change the subtitle. please let me know how. Ps: I am using emby on windows, and the problem i have with Arabic Subtitle Best Regards
  17. nRafinia

    New Plugin - Subscene subtitle

    Hi, I created the subtitle plugin for Subscene. Please install and let me know if there is a problem --> The problem with Subscene is resolved, Please download the latest version <-- Source Code: https://github.com/nRafinia/Emby.Subtitle.Subscene Binary: https://github.com/nRafinia/Emby.Subtitle.Subscene/releases/latest
  18. Phuein

    Tiny Subtitles With MKV

    Hey, Thanks for your guys hard work. Emby is always a pleasure to use. I've noticed that when playing files with embedded subs, like the MKV format, the default size is tiny. Unreadable basically. When I extract the subs into an .srt file ( ffmpeg -i "%~1" "%~n1.eng.srt" ) it works fine, loading the subs as expected. Any chance Emby could work with this better automatically? Thanks
  19. I have one library of movies and it works OK except some of the movies have subtitles that does not belong to them. Automatic subtitle is enabled for English language. It downloads the subtitles but for some movies the subtitle that shows on screen is not for this movie. Opensubtitle plugin is installed and in the settings I have entered my username and password for opensubtitle. (I even checked again and I can login to opensubtitles.org with my ID and password). What could be the cause of this subtitle mismatch? PS: I have checked and unchecked "Require Hash Match" but the end result is the same. I appreciate any help in troubleshooting this.
  20. I am on latest beta of Emby Android TV app running on Google certified Android 8.0 TV. I have connected my TV to Sony HT-RT3 soundbar (via HDMI ARC) that supports only AC3 and EAC3 (no DTS). So if I play a video with DTS audio, Emby app transcodes audio alone and use the same video stream. All good and fine. But of late I am starting to notice an issue. Consider the following the scenarios. 4K HDR Video Dolby Digital+ 5.1 Audio SRT subtitle Result = Direct Playback 4K HDR Video Dolby Digital+ 5.1 Audio PGSSUB subtitle Result = Direct Playback 4K HDR Video DTS 5.1 Audio SRT subtitle Result = Direct video + Transcoded audio But if 4K HDR Video DTS 5.1 Audio PGSSUB subtitle Result = Transcoded video + Transcoded audio Is this the expected behaviour? I am not sure why PGSSUB needs to be burned (resulting in video transcoding) if audio is an unsupported format. I mean the app displays PGSSUB just fine if the audio is supported. So what difference does it make to subtitle whether the audio format is supported or not?
  21. Vikh0

    smartv lg subtitle problem

    Hello good night friends of the forum, I am here because I am a new user of emby and I have a problem, before I used plex, but when I tried to watch subtitled movies, with the server mounted on my personal use pc, I transcoded and gave me buffering, for this motive stop using plex and try emby, and I liked it, much just that now I have a problem, which is that when I watch the movies I put the option to show subtitles and they do not appear or leave when they want, in the middle of the movie or at In the end, I have a powerful PC, for this type of work, and 100 mb of connection, mkv format and in 1080p quality use w10 pro, updated, I hope you can help me, try to play the same movies on my pc and if it shows subtitles and I have a smartv Lg Webos 43lj5500
  22. Hi thanks for your nice apps. android app have problem with Persian subtitle. this font is bad and some alphabets doesn't show correctly (like what you see in the attached photo) we have bad font in the web and TV too. but they can show all alphabets Please change this fonts, I suggest to use "B Koodak" font for Persian subtitles as default. it's most popular font for subtitles in the Persian.
  23. I'm just trying to figure out if I have something set incorrectly or is Emby really has different playback screens for TV shows vs movies. When you get to a TV show episode playback screen, it shows the audio and video details and then has a drop down list of the available subtitles. When you get to a movie playback screen, the same information is not shown. The movie does have the details embedded. Using Tiny Media Manager, I get this information: So, I'm wondering what I need to do or change with my Emby settings to get the movie playback screen to show the same information as the TV episodes. Just as an FYI, I have also added an external subtitle file (.srt) file for this movie. So I would hope that some kind of subtitle information would be shown. Any help would be appreciated. I am still setting items up and have only done about 15% of our movies. I want to make sure that I copy everything the way Emby likes it.
  24. I have been trying to figure out how to configure my Emby server/clients to do things the way I want them to. One thing I haven't been able to figure out is how to get Anime subtitles to play properly on all my devices. When I occasionally use Chrome or the Android client, which play my subtitles just fine, graphically and positioned on the screen appropriately. However my main method of playback is on my Roku TVs. Roku TVs by default appear to extract subtitles from my video files and display them using closed captioning. This is a much less visually appealing way of providing subtitles. It is especially problematic when the show I'm watching positions subtitles next to Japanese characters, which is totally lost when converting to Closed Captioning. I would like to find a best solution which allows me to have the visuals I am looking for. Right now, the only way I can find to make that happen is to begin playing a video, and then forcing playback correction twice (after using the beta, the text there says the 1st time forces remuxing and then the 2nd time forces transcoding, which at least explains why I have to do it twice) but that is not really an option I want to live with long term if I can avoid it. Ideally, there would be a way to allow the Roku client to support these subtitles (SSA in the show I tested as I am writing this, but other types as well) and display them graphically like VLC or Chrome or Android player or basically most other players out there. If this is not possible due to technical limitations, then I would rather have my videos transcoded than have to watch them with solid black closed caption boxes that are placed rigidly on the bottom of the screen. In this case, ideally I would be able to set only my Anime library to force transcoding, but not force my movies or US TV Shows. An alternate option would be to have it controlled by user, and I could create a 2nd ID for myself to watch Anime if I had to. Complicating my situation is the fact that sometimes when I select the episode I want to watch, I am presented with a pair of dropdown boxes to see what language the audio is and what subtitles are selected, while other times those boxes are not visible. I think it has something to do with selecting the video from the suggestions vs. from the Next Up section vs. selecting the title from Latest Anime and choosing the episode I want. When the dropdowns are not visible, the subtitles as captions will usually show up, but after selecting force playback correction twice, the subtitles have been turned off as transcoding is started. At this point, turning on the subtitles forces me to choose the correction option multiple additional times, each time possibly having to turn subtitles back on. Usually, once I get it to transcode with subtitles once it will continue to work with only two times selecting the correction option, and I can watch additional episodes in the same season for that viewing session with minimal additional issues. Honestly, I'm hoping that one of the devs or more knowledgeable users will point out some setting I haven't seen or some tweak in the server files that will allow me to do what I'm looking to do, or even link me to a thread where this has already been discussed and fixed which I wasn't able to find myself. Right now, I'm stuck forcing playback correction twice every 20 minutes of watching, and it is a real pain. Please let me know what I can do to assist with troubleshooting this issue if I can be of assistance. Thanks!
  25. Gulan

    Subtitle settings

    Hi, I use my video files(mkv) with srt subtitles. For a while it seemed so that you only had one size for the subtitle and the black background for subtitles were not removable. With the new version (1.0.19) under settings there came a "subtitle appearance" setting where you could set the font size, color and drop shadow. Oddly enough this does not seem to work with any of my MKV with srt subtitles. The subtitle stays with black background and one font size and white letters. Am I missing something? If you include something like drop shadow, i would expect also that the black background would dissappear because otherwise this would be a useless setting. But maybe it doesn't work with external srt subs? Thanks in advance for any advise. WEB OS (5.10.20)
×
×
  • Create New...