Jump to content

Search the Community

Showing results for tags 'subtitle'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Poptartica

    Subtitle backdrops?

    Hey all. I looked around but couldn't really find anything related to this specifically: When I play a file containing Subtitles in the web browser player, they always show with a black backdrop. Is there any way to remove this backdrop? I have had multiple people confirm that it happens when viewing through their browsers. If that's not supposed to happen, why might it happen and has anyone been able to fix this? The PC running the MediaBrowserServer is an Ubuntu 14.04.2 LTS system. For reference, here's a sample MediaInfo for a file which exhibits this behavior when played (quality setting: Direct) through the browser: General Format : Matroska Format version : Version 2 File size : 322 MiB Duration : 23mn 39s Overall bit rate : 1 899 Kbps Attachements : AppleGaramond.ttf / AppleGaramond-Light.ttf / arial.ttf / BISONPRR.TTF / CronosPro-Capt.otf / ElicitSSK-Bold.ttf / HATTEN.TTF / PIXEARG.TTF / TOARUmincho.ttf Video ID : 1 Format : AVC Format/Info : Advanced Video Codec Format profile : High@L4.1 Format settings, CABAC : Yes Format settings, ReFrames : 9 frames Codec ID : V_MPEG4/ISO/AVC Duration : 23mn 39s Width : 1 280 pixels Height : 720 pixels Display aspect ratio : 16:9 Frame rate mode : Constant Frame rate : 23.976 fps Color space : YUV Chroma subsampling : 4:2:0 Bit depth : 8 bits Scan type : Progressive Title : H.264 720p HDTV Writing library : x264 core 114 r1924+495 ccd7045 Encoding settings : cabac=1 / ref=9 / deblock=1:1:1 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / fade_compensate=0.80 / psy_rd=0.40:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=6 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / fgo=5 / bframes=10 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=18.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:0.60 Language : Japanese Default : No Forced : No Audio ID : 2 Format : AAC Format/Info : Advanced Audio Codec Format profile : LC Codec ID : A_AAC Duration : 23mn 39s Channel(s) : 2 channels Channel positions : Front: L R Sampling rate : 48.0 KHz Compression mode : Lossy Title : AAC 2.0 Language : Japanese Default : No Forced : No Text ID : 3 Format : ASS Codec ID : S_TEXT/ASS Codec ID/Info : Advanced Sub Station Alpha Compression mode : Lossless Title : Styled Subtitles Language : English Default : Yes Forced : No Menu 00:00:00.000 : en:Prologue 00:01:03.564 : en:Part A 00:10:32.966 : en:Opening 00:12:02.889 : en:Part B 00:22:09.870 : en:Ending Any help would be appreciated. Thanks!
  2. When I play a video from the start the subtitle is showing perfect but at resume no subtitle is showing. Even switching between subtitle doesn't help. I experienced this behavior with several versions of the server and webclients. With kind regards, Rienk Kuipers The Netherlands.
  3. Hi, Sorry to bring this topic again - I'm pulling my hairs out to find a workaround but without luck. I have a lot of videos with simplied or traditional chinese which are encoded in GB2312/BIG5 charsets. When mediabrowser server transcodes the videos, it assumes the encoding is CP-1252 which causes the subtitles not being displayed correctly. The problem only affect external srt subtitles, ass subtitles work fine, ssa subtitles don't work at all. I've tried several things without any luck: Change srt file name to include "chn" , "chs" or "cht" Convert srt file to UTF-8 encoding Convert srt file to CP-1252 (all chars become "?" after convertion) I understand it will take time to develop something to support asian subtitles, and it won't be the high priority now. As a workaround, can I, in anyway to enforce FFMpeg to use a certain charset when transcoding srt subtitles? Please see the following command I found in another thread, I assume it will work if the -sub_charenc is configured correctly. C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\ffmpeg\ffmpeg20131011\ffmpeg.exe -sub_charenc GB2312 -i "\\AUSTIN\media\TV Series\The Big Bang Theory\Season 1\The.Big.Bang.Theory.S01E02.720p.BluRay.x264-SiNNERS.chs.srt" "C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\cache\subtitles\1\1329e16a-7e00-b6cb-5f3f-00e0c93fbfc6.ass" Please share your suggestion, thank you in advance!
  4. Luke

    Subtitle Guide

    https://github.com/MediaBrowser/Wiki/wiki/Subtitles
  5. Below problem applies to both Windows 8.x metro App and Web Player. MBC and MBHT is fine since both uses external subtitle filter. Basically both unable to encode subtitles with Turkish chars. I couldn't find any setting for char. encoding in both 8.1 app and Web Player. Below is the line 00:05:49,800 --> 00:05:53,901 from attached srt. (Renamed to txt) Sample.Tr.txt
  6. I was really happy, when MediaBrowser Server gets support for automatic subtitle downloading. So I easily register on Subtitles web page, select my language (Czech) and hope for.. but nothing was happen I tried to find where the problem is, but there aren't so much configuration options and the only information, which I can get from MB is this: Error - SubtitleManager: Error downloading subtitles from Open Subtitles Anybody can help me?
  7. darwindeeds

    We are listening, subtitle support

    Thanks to all your support and feedback, just playing around with the subtitle support.
  8. zakraket

    external subtitles

    What settings do I need for using external subs? I have a few movies with internal (english) subs and I have downloaded dutch .srt subs, but I cannot get them to play (I cannot even select them manually via systray) I'm using the default installation for MTB with xy-VSfilter and LAV-splitter that comes with MBT. I manually installed xy-VS and LAV for MBC (before I installed MBT) and there it automatically selects the external dutch srt.
  9. I was just curious if there was a way to make subtitles within an mkv appear as the type they are? As in, I merged 21 & Over.mp4 and 21 & Over.eng.srt into an MKV, and it plays the files, but only recognizes that a subtitle is there, not that it is an english subtitle. Probably the biggest reason this matters right now, is for the Cover Art sub overlay. Just post question marks if everything I just said sounds like gibberish. Thanks.
  10. thoror

    subtitle extract

    I'm having some issues with playing embedded subtitles. Here is the relevant log: 2013-11-06 03:02:18.1323, Debug, MediaEncoder, C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\ffmpeg\ffmpeg20131011\ffmpeg.exe -i file:"\\AUSTIN\media\HD Movies\movie.mkv" -ss 3.962 -map 0:2 -an -vn -c:s ass "C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\cache\subtitles\3\3a13d2bf-09a8-c9f1-aa2c-179912d4e50a.ass" 2013-11-06 03:03:18.1323, Info, MediaEncoder, Killing ffmpeg subtitle extraction process 2013-11-06 03:03:18.1323, Info, MediaEncoder, Deleting extracted subtitle due to failure: 2013-11-06 03:03:18.1323, Error, MediaEncoder, ffmpeg subtitle extraction failed for file:"\\AUSTIN\media\HD Movies\movie.mkv" to C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\cache\subtitles\3\3a13d2bf-09a8-c9f1-aa2c-179912d4e50a.ass If I run the command separately, it runs fine with no problem, except it takes quite some time (about 2 minutes). But in the log it shows that the process is terminated after exactly 1 minute, which makes me believe the server is invoking some timeout that is set to 60 seconds. As it may take quite some time to fully extract embedded subtitles, would it be possible to increase the timeout duration? Thanks!!
  11. thoror

    subtitle mangagement

    I think it would be convenient if (external) subtitles could be managed through the web interface in the same way images are handled. Adding subtitles through drag and drop, and automatic renaming including the 3 char language would make my life much easy
  12. I have many korean subtitles, and they are usually encoded with cp949. When the subtitle is named with the .kor language specifier, the ffmpeg command uses the following: (with option -sub_charenc windows-1252) C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\ffmpeg\ffmpeg20131011\ffmpeg.exe -sub_charenc windows-1252 -i "\\AUSTIN\media\TV Series\The Big Bang Theory\Season 1\The.Big.Bang.Theory.S01E02.720p.BluRay.x264-SiNNERS.kor.srt" "C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\cache\subtitles\1\1329e16a-7e00-b6cb-5f3f-00e0c93fbfc6.ass" Thus, the resulting .ass file contains a bunch of gibirish: Dialogue: 0,0:00:06.67,0:00:07.95,Default,글쎄.. Dialogue: 0,0:00:07.95,0:00:12.04,Default,ì–¸ì œ 부풀어오를지 모르니까\N다들 하워드 잘 ë³´ê³ ìžˆì–´ Dialogue: 0,0:00:33.65,0:00:34.57,Default,ë‚´ê°€ 나갈게 Dialogue: 0,0:00:35.25,0:00:36.95,Default,혹시 나 부었어? 부어오른 ê±° 같아 Dialogue: 0,0:00:38.86,0:00:40.43,Default,- ë ˆë„ˆë“œ, 안녕하세요\N- 안녕하세요, 페니 Dialogue: 0,0:01:04.02,0:01:07.04,Default,편한대로 부르세요\N어차피 ì „ ìµœì €ìž„ê¸ˆ 받으니까요 This is true whether I encode the .srt file in CP949 or UTF-8. Futhermore, when using UTF-8, a bunch of errors can be seen in the sub-convert log: [subrip @ 003dbdc0] Unable to recode subtitle event "자, 여기 땅콩 뺀 <font color="#FFD700">팻 타이</font>" from windows-1252 to UTF-8 Error while decoding stream #0:0: Error number -42 occurred [subrip @ 003dbdc0] Unable to recode subtitle event "그런데 땅콩 기름 들어간 거 아니야?" from windows-1252 to UTF-8 Error while decoding stream #0:0: Error number -42 occurred [subrip @ 003dbdc0] Unable to recode subtitle event "벌 날아다니는 때는 아니니까 내 <font color="#FFD700">에피네프린을 쓰게 해 줄게</font>" from windows-1252 to UTF-8 Error while decoding stream #0:0: Error number -42 occurred Would it be possible to set the char_enc to the correct value for the specific language (I believe this issue should not be limited to Korean), or even support another tag such as .kor.utf8 which also gives information on the char encoding? As a work around, if I do not include the .kor language specifier, then the command is: C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\ffmpeg\ffmpeg20131011\ffmpeg.exe -ss 14.0657032 -i "\\AUSTIN\media\TV Series\The Big Bang Theory\Season 1\The.Big.Bang.Theory.S01E01.720p.BluRay.x264-SiNNERS.srt" -ss 1 "C:\Users\thoror\AppData\Roaming\MediaBrowser-Server\cache\subtitles\e\e9430590-01c3-b802-8909-f172b8fdb71b.ass" which does not contain the -sub_charenc windows-1252 option, and works flawlessly, if I have my .srt file pre-encoded in UTF-8.
  13. Love the ROC theme and it is getting better and better but still I would like to see some things implanted. Because I'm Dutch I always watch episodes with Dutch subtitles and now I always have to go in the episode detail page to see if that episode has subtitles available. For me and probably more people that aren't English it would be very handy to have a recently added with subtitle(s) page. In that page should be all episodes with internal or external subtitles available. I use external "name.srt" files for subtitles and they become visable in MBClassic after renaming to "name.nl.srt" * Let them appear only with the episode frame with all info like in the episode detail page. * In the recently added page only the episode name is visable so it would be nice to see the series clearlogo to know to what serie the episode belongs to. * Backdrops in recently added are not working yet so it would be nice to see the backdrops of the serie too. * Same thing for clearart in the recently added page which is not yet visable there.
×
×
  • Create New...