Jump to content

Search the Community

Showing results for tags 'server'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi, I have a problem with the QNAP Arm64 version (aarch64), my NAS is a TS-328, Versión 3.6.0.84 beta. Using the same folder with an emby server windows 10 the metadata is correct, but in the nas server there is an artist called "Artistes Divers" which includes many albums that do not have that artist. The albums that are included are those that the artist of the album "Various Artists" actually has. It seems somewhat random. I have tried to reinstall emby from scratch and have also created the library several times. In reality the artist "Artistes Divers" only has one album and "Various Artists" has 337 albums. I have tried in Emby server windows 10, Plex and Mediamonkey, this is all correct.
  2. Kimballslice1890

    Convert Media Failed

    After updating to the latest emby server, I have an alert saying convert media failed. Here is the content of that error: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Sync.SyncRepository.GetJobs(SyncJobQuery query) at Emby.Server.Sync.SyncJobProcessor.EnsureSyncJobItems(String targetId, CancellationToken cancellationToken) at Emby.Server.Sync.SyncJobProcessor.Sync(IProgress`1 progress, CancellationToken cancellationToken) at Emby.Server.Sync.SyncConvertScheduledTask.Execute(CancellationToken cancellationToken, IProgress`1 progress) at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options) is this an issue that will impact my experience or server?
  3. MrGrymReaper

    Portable Version Of 4.0.0

    Hi, Please will 4.0.0 or higher still have the portable version or has the setup tool gained the ability for the user to specify the location? As I utilise limited privilege accounts for running services to restrict damage possibilities. With the server (or setup) binding to an Admin privileges account. It means that hack attempt attacks attempts will have more damage possibilities. But with where I install Emby it is still able to do its job without needing complete access to the system. Thank you for time and attention in this matter. Kind Regards, MrGrymReaper
  4. Steverido

    Kodi - Emby Server Access Issues

    Gents, I have installed Kodi, Emby for Kodi and Embuary skin. I am getting a connection error 10061. Seems to be that Kodi is not connecting to the Emby server. I think that Emby server is crashing and it is okay when I first boot up and access the configuration page, but as soon as I start-up Kodi or even Emby Theater, it loses the connection. Running the latest Windows 10. Attached logs. Have not got to creating a Kodi log yet. I di enable debugging but it did not crete a log in roaming.
  5. Hi, In Settings there is a section named "Advanced" or "Hosting". This is the mine: And this is a section of my Dashboard: The server is running in local http port (8096), there is no option to enable https in local. Nor, in my opinion, does it make sense to activate https on local connections. My question is: does the "Local https port number" option make any sense? ----------------------------------------------------------------------------------------------------- And another question is about remote access. I have disabled this option, why the Dasboard shows "Remote (WAN) access" if it's inactive? This leads to confusion when remote access is not activated.
  6. babarsyal

    Options related

    Hello, I want to hide or disable some of the options from server for local users. we have more than 500 users and now we are running it as a test and for that i have some issues regarding main setting options. i I have attached above the screenshot with mark where i want to remove marked area or just settings option for local users. Second pic attached with marked area that any user can delete from his account. i will run only one account for all users and cannot allow one user one account. also if any user delete this file so it will be deleted from main directory or just from user's sync library? I just want to have full command over security to save my data from users.
  7. Steverido

    Post Installation Issues

    I have installed the latest Theater and I am getting a couple of strange things happening. Connect to the server once and then it seems to crash. I have to ctrl, alt del to shutdown the server and restart it. If I try to open up the server settings, I can one time and then I get can't connect to local host meassage. Windows 10. Latest. When I do open up Theater I have to manually connect to my server. When I go into settings to select a theme it has a statement this feature requires an active Emby Premiere subscription. I don't have a subscription because I already have a Lifetime Emby Premiere plan. Trying to play around with Theater as recommended by Luke because of issues with Emby for Windows Media Center. Added logs and screenshot. You will notice that the logs are picking up a Roberts DAB radio. It connects to my router. Not sure why it is showing in the logs or if there is any relevance to this issue! embyserver.txt embyserver-63681706321.txt theater-63681706950.txt
  8. This is not a huge deal, but I'm curious if there is any way to remove or exclude a particular movie from showing up in the Recent/Latest lists (including removing it from showing up in these lists via the API)? Thanks in advance for any advice!
  9. Hi I'm trying to use https for remote connections using Synology reverse proxy and letsencrypt certificate installed using DMS control panel. Here what I did so far: 1. Setup DDNS using synology.me service 2. Create a letsencrypt certificate for this domain using DMS control panel 3. Create a reverse proxy setting on port 8921 to redirect to localhost:8096 4. Setup the https://*:8921 service to use the "mydomain".synology.me certificate 5. Setup port forwarding on my router to forward port 8921 to my nas port 8921 6. Setup emby advance settings, I set the external domain, https port and the secure connection mode to "Handled by reverse proxy". Everthing is working greate except for 1 thing. If I use https://"mydomain".synology.me:8921, I get a secure connection to emby server with the message : Secure connection: verified by Let's Encrypt. However, if I use this url instead: https://"mypublicip":8921, I get to my emby server on a unsecure connection with this message: "mypublicip":8921 uses an invalid security certificate. The certificate is only valid for "mydomain".synology.me. I can add an exception in the browser and get to my emby server on an unsecure connection, which defeat the purposeto have a secure connection at the first place. Did I miss a setting somewhere, anything that could explain why I can get to my emby server on a unsecure connection through my public ip? Thank you
  10. ocsurf74

    Alexa can't reach Emby Server

    New user here and I'm trying to set up Alexa. I've set up Emby Connect and the Alexa skill and when I ask to open or play Emby it can't connect or find server. I'm running Windows and the latest updates have been done.
  11. Emby server 3.5.2.0 Server backup plugin 1.2.3.0 Ubuntu 18.04.1 LTS Client: Firefox Quantum 62.0 (64-bit) The story so far: Fresh install of Ubuntu 18.04 Download and install Emby server from https://github.com/MediaBrowser/Emby.Releases/releases/download/3.5.2.0/emby-server-deb_3.5.2.0_amd64.deb Enter my Premier subscriber key Install the backup plugin Restore my backups from backups.tar.gz from old system, into /home/emby/emby-backups Launch Emby, launch backup plugin. No luck. Just in case, make sure permissions are in place, even though no specific errors in logs: sudo chmod -R 755 /home/emby/ sudo chown -R emby:emby /home/emby/ Launch Emby, launch backup plugin Browse to any backup Result: backup screen hangs with loading indicator Log files: logs indicate that plugin is reaching endpoint ok, and browsing the JSON at http://localhost:8096/emby/MBBackup/Backups correctly displays restorable content of backup files (time, date, profile, users, etc). It seems like just the UI is hanging for some reason? Most recent log attached. Additional information: previous server was Emby 3.2.x on Ubuntu 16.04 LTS, same backup plugin version, and these same backups restored successfully there. Unfortunately the old server was destroyed and no longer exists, only the archived backups. embyserver.txt
  12. Hi, total scrub over here. I made my server on my old desktop that just died last week (ouch) and created my new server using the same emby connect account on my new desktop. When I go to stream from my apple TV that worked extremely well with my original server on the same internet connection, the apple TV asks me to select a server (the old one or the new one I made). Everytime I select the new one and enter the pin to connect, it gets stuck loading and never loads. Do I need to delete the old server to get this new one working? Because I don't have access to the old desktop that its on anymore. If not, is there anyway to delete it from my new computer? And is this even a problem or is there a problem with my new server? Please help! I need to stream my local library again!!! Update: When connecting through Apple TV, I tried connecting with the emby connect PIN and it gets stuck on loading and then I tried using the specific server address and port (which I made sure was open with my firewall) and it kicked me back to the page asking if it should connect with Emby Connect PIN or server address. This loops on repeat. Help!!2
  13. Library folders in my admin panel don't have images anymore since a while. So i've tried to add them manually, however when i click on "Edit Images", the loading icon appear (And never fade-out) but the popup for editing the images is never shown. The only library with an image is the "Auto generated library" called Collection créated by the plugin Auto Box Set. When i clic on "Edit Images" for this item the popup appear as expected. The only error i've managed to found is displayed in the browser console when i click an the menu item "Edit Images". Uncaught (in promise) Error: null itemId at ApiClient.getItem (apiclient.js?v=3.5.2.0:1) at imageeditor.js?v=3.5.2.0:1 at Object.execCb (alameda.js?v=3.5.2.0:1) at defineModule (alameda.js?v=3.5.2.0:1) at Object.depFinished (alameda.js?v=3.5.2.0:1) at alameda.js?v=3.5.2.0:1 Tested on Chrome 69 and firefox 62.
  14. I have just changed my ports for HTTP and HTTPS access on my server to the standard 80 / 443 as I don't run anything else on my home IP. However, when looking on the server dashboard, the In-Home (LAN) access has changed but the Remote (WAN) access has remained at the default 8096 (as I haven't set up a certificate yet). This ONLY effects the dashboard link as if you enter the emby server manually with the new port numbers it connects OK.
  15. Arch Linux emby server 3.5.3.0 filesystem ext4 The server detects when I delete a file but it doesn't detect if I move a file outside of library folder. I have to force a rescan to detect the changes.
  16. EsDeeEm

    Emby server on Pine64?

    I have backed the Pine64 Kickstarter and want to deploy it as an Emby server as soon as it arrives. I tried to do it on a Raspberry Pi, but the memory seems to be insufficient to run properly. So I ordered the heaviest Pine they had. It can run Ubuntu Snappy, so I would presume it will run Emby server on that platform. Did I guess right?
  17. This may be a "feature not a bug" situation as a result of me not understanding how you designed it to work... But it seems like the list of "Next Up" TV shows is actually a SUPER SET of "Continue Watching" (excluding the in progress movies)--- that is, it should contain all items that are in progress (Continue Watching) + episodes where I'm at the start of an episode (if the SHOW has been watched recently). You combine all those together into one list and take the most recent ~20 to include in the list. If this is more or less the desired outcome, then I believe I've found a bug. I generally only display the "Next Up" row on my Android TV because it always includes stuff that is in progress (ie Continue Watching just contains stuff I can find in "Up Next", so I don't display it). However, Up Next is occasionally missing items that I have to go and pull from the Continue Watching list. I'm happy to provide several examples but I first wanted to confirm this was actually a "bug" (per the design) before wasting any time filing a bug report. If this is not actually a bug, can you explain why it's necessary to have both the "Next Next TV" and the "Continue Watching" lists? (other than Continue Watching is both Movies + TV episodes).
  18. nicheplayer

    Upgrading OS on VPS -- which to choose?

    Upgrading from Debian Wheezy to something newer and am looking for advice/thoughts on which Linux distro would be best for running emby server, sabnzbd, etc. Just go for Ubuntu 18.04? Thanks.
  19. Hi, I'm having trouble to connect to my own server, and I did removed my self so I thought will be easier to reconnect if i added my self again, but not which is ridiculous ! this is what I see on my screen any advice would be nice.. This site can’t be reachedlocalhost refused to connect. Search Google for localhost 8096 web index ERR_CONNECTION_REFuse Connection Failure We're unable to connect to the selected server right now. Please ensure it is running and try again. Connection Failure We're unable to connect to the selected server right now. Please ensure it is running and try again.
  20. birne

    Exception /opt/emby-server/system

    Hi! I've got an Exception, but the file permissions are ok i think ^^ Can anyone help? Thank you very much! ls -l /var/lib/emby/ drwxr-xr-x 18 emby emby 4096 Okt 27 18:17 cache drwxr-xr-x 4 emby emby 4096 Okt 27 20:00 config drwxr-xr-x 7 emby emby 4096 Okt 28 06:16 data drwxr-xr-x 2 emby emby 4096 Sep 29 14:27 localization drwxr-xr-x 2 emby emby 4096 Okt 28 06:16 logs drwxr-xr-x 7 emby emby 4096 Sep 29 23:07 metadata drwxr-xr-x 3 emby emby 4096 Okt 27 19:23 plugins drwxr-xr-x 3 emby emby 4096 Sep 29 14:27 root drwxr-xr-x 2 emby emby 53248 Okt 1 18:44 transcoding-temp 2018-10-28 06:18:09.353 Info HttpClient: GET https://image.tmdb.org/t/p/original/tPAV8vSLIlEDHDPWg7jicNR2qsk.jpg 2018-10-28 06:18:09.386 Error ProviderManager: Error in metadata saver *** Error Report *** Version: 3.5.3.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb Operating system: Unix 4.9.0.8 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 8 Program data path: /var/lib/emby Application directory: /opt/emby-server/system System.IO.IOException: Read-only file system at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter) at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options) at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions) at MediaBrowser.XbmcMetadata.Savers.BaseNfoSaver.SaveToFile(Stream stream, String path) at MediaBrowser.XbmcMetadata.Savers.BaseNfoSaver.Save(BaseItem item, CancellationToken cancellationToken) at MediaBrowser.Providers.Manager.ProviderManager.SaveMetadata(BaseItem item, ItemUpdateType updateType, IEnumerable`1 savers) System.IO.IOException at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter) at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options) at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions) at MediaBrowser.XbmcMetadata.Savers.BaseNfoSaver.SaveToFile(Stream stream, String path) at MediaBrowser.XbmcMetadata.Savers.BaseNfoSaver.Save(BaseItem item, CancellationToken cancellationToken) at MediaBrowser.Providers.Manager.ProviderManager.SaveMetadata(BaseItem item, ItemUpdateType updateType, IEnumerable`1 savers) 2018-10-28 06:18:11.956 Info HttpServer: HTTP GET http://xx:8096/emby/Items/12a05dac156a069358d7db8473b08ea0/Images/Backdrop/0?Format=original&Tag=f01ce0531741e9341b049df55f645a2a. UserAgent: Kodi/17.6 (Linux; Android 5.1.1; AFTT Build/LVY48F) Android/5.1.1 Sys_CPU/armv7l App_Bitness/32 Version/17.6-Git:20171114-a9a7a20 2018-10-28 06:18:11.956 Info HttpResultFactory: Setting range response values for /var/lib/emby/metadata/library/12/12a05dac156a069358d7db8473b08ea0/backdrop.jpg. RangeRequest: bytes=0- Content-Length: 588905, Content-Range: bytes 0-588904/588905
  21. Arly (Sprinkles)

    Curious about Server Migration

    So, in the next few months, my wife and I have decided to purchase a new PC to base our media server out of, but I do have a few questions about server migration, backup, and a few other things. 1.) Will my Emby Premiere Key work on this new server, on a new machine, or do I have to purchase a new subscription? 2.) What does the backup plugin backup? Metadata? <--Working on doing everything manually through .nfo files and individual image files to make it easier for maintenance. 3.) How complex will this migration be? (i.e. Will I have to re-configure all User-based information such as Collections, log ins, profile pictures? Or will all of this be erased?) 4.) Where should I route this back up to? How much storage would it take up (on average, if anyone knows)? Just curious as to if a simple 16gb USB will be enough (probably.) Anyways, if anyone can answer these questions, this would be awesome! Thanks.
  22. Hello everyone. Having some issues with my Emby Server Version 3.2.16.0. I have a Roku that I push all of my media to and just recently the emby app hasn't been working. I've figured out that every time i can not play something i have to come upstairs because my Emby Server app has stopped running and I have to manually start the process again. I've attached the error log file with this that i got from http://localhost:8096/web/log.html - If anyone needs a ny more logs to have a look at please let me know. Emby Log.txt
  23. I've specified a specific directory for cache, metadata, transcoding etc. The server is not using the cache directory specified for storage. I'm using Emby Docker version 3.5.3.0 on Unraid. I've specified it to use path /mnt/Emby/transcode/cache Looking at that path there's around 350M of data in it. So Emby is writing to it. But the majority of my cache is in the default location /cache/ as this folder is around 600M. How do i move all the cache from /cache into the specified cache. I don't know why there is any cache there as i moved the cache location when i first setup the sever.
  24. Hi, On the Server you can currently see active devices on the dashboard, and consequently which users are watching what on what media. However, there's no way to abort these active devices to either conserve bandwidth, conserve server CPU, or simply to stop a renegade process. One use case that would be particularly helpful is when you're casting from the phone app to ChromeCast. If the phone gets interrupted, you lose control over the stream so that the TV stops showing whatever you were watching, and there's no way to stop it or regain control over it. Instead of having to stop and start the entire server, it would be nice to just click on that particular activity on the dashboard and press KILL (or perhaps a less dramatic word - cancel?) Food for thought? -Florux
  25. Hey all, I was wondering if server auto-discovery was discussed at any point? I couldn't find anything related on the forums so far. Two options that would IMO complement each other would be avahi and explicit SRV _emby._tcp entries (separate for http and https) in the local DNS. All the discovered (deduplicated) servers would show up as options when adding a server in Emby apps instead of having to type the URLs in. This shouldn't be too difficult to implement and I think it would improve the user experience a lot. Thanks!
×
×
  • Create New...