Jump to content

Search the Community

Showing results for tags 'metadata'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. -= canuck =-

    How to import sort metadata

    Hi folks, I'm trying out Emby for the first time today and it looks really good so far. I have only one thing I haven't been able to sort out which is how to get Emby to use the sort title metadata field. From a bit of searching it looks Emby is using ffprobe to get that information, is that still true? Environment: docker with emby/embyserver:4.4.2.0. I mounted a folder with a single file to /mnt/share2. I accessed the container to see if ffprobe would correctly see the metadata and it does: /mnt/share2 # ffprobe ./The.Circle.mp4 ffprobe version 4.3.0-emby_2020_02_24 Copyright (c) 2007-2019 the FFmpeg developers and softworkz for Emby LLC built with gcc 8.3.0 (crosstool-NG 1.24.0) Input #0, mov,mp4,m4a,3gp,3g2,mj2, from './The.Circle.mp4': Metadata: major_brand : isom minor_version : 512 compatible_brands: isomiso2avc1mp41 title : The Circle date : 2017 encoder : Lavf58.20.100 sort_name : TheCircle01 Duration: 01:49:47.14, start: 0.000000, bitrate: 2449 kb/s Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p, 1280x534 [SAR 1:1 DAR 640:267], 1997 kb/s, Level 31, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default) Metadata: handler_name : VideoHandler Stream #0:1(eng): Audio: ac3 (ac-3 / 0x332D6361), 48000 Hz, 5.1(side), fltp, 448 kb/s (default) Metadata: handler_name : SoundHandler Side data: audio service type: main Stream #0:2(eng): Data: bin_data (text / 0x74786574) Metadata: handler_name : SubtitleHandler I re-created the library with no metadata downloaders on and 'prefer embedded titles' just to see if that would help but no luck. For giggles I renamed the file to noname.mp4, re-created the library again and Emby did not use the metadata for the title either. What am I missing? Thank you
  2. loginletter@gmail.com

    How to backup server and restore

    I just install and use emby from last week. I install the server on win10 I used it mostly on PC and apple tv app. Suddenly, I found it cannot find the existing server on apple tv. I try to use it on firefox of PC. It shows "http://localhost:8096"cannot be connect. I restart the server from taskbar icon many times. It still cannot work, even restart the PC. I cannot find the emby server icon on start menu, even after couple times of PC restart. Eventually, I re-install the emby server, and found that all metadata of the past week work (over hundred hours) has been vanished. Since I has data bank for over 4 thousand movies, I work hard to find the in-recognize and mismatch movies data, and matched manually inside emby before. After re-install server and setup those media library, it can only recognize the picture, not the right name of the movie. I afraid that will happen again. I try emby also according to the server lost of other emby competitor, which has been used for many years. Can you teach me how can I backup the server and restore those manually matched movie data? to avoid another disaster happen again, even change PC? Thank you @@cayars
  3. Seems like this gets brought up a lot and there doesn't seem to be a step by step guide, so I'm asking again. I just set up Emby to handle music files only (any other setup tips would be welcome) and had it sort through the library, it's been a few days since then and it's still not displaying embedded artwork, so I don't know if I missed a setting somewhere or not. So to go through the motions, here's my step by step. I've manually combed through all of my music with MusicBrainz Picard and mp3tag. I have correct tags for everything, and most importantly, correct album cover art. On a different thread I read that there might be some confusion between id3v1 and id3v2.3, but looking in the extended tags in mp3tag, there's nothing with duplicates that should cause any confusion. I'm pretty sure I have Picard set to erase all the metadata and only rewrite it with new values, so v1 and v2.3 should be identical for everything, and was for the few albums I checked. Installed Emby, a crucial step. When setting up the music library, I turned off all metadata providers. The library settings, with the advanced options, only has real time monitoring enabled. Everything else is unticked, with "Automatically refresh metadata from the internet" set to Never. Library scan. No or incorrect artwork shown. For having the metadata and all providers disabled, it's still finding a few album covers, which are noticeably different from the embedded files, and mp3tag only shows the single image I've put in. Did I miss something? There's no obvious tick box in the library setup saying "Read embedded metadata"
  4. Hey all, it just recently started happening it seems. Lately it is failing to check for updates on the plugins. Also, the last two movies I've added it is unable to download metadata for them including artwork. Any idea what may be causing this? Nothing has changed on the PC that Emby is running on to my knowledge. Thanks!
  5. Manual edits to Movie Extras are initially accepted but are lost on the next Library Scan. Specifically, I manually edited the Overview, Locked, and saved it. The changes remained until the next Library scan where it was replaced with the Overview for the parent movie. I’m currently using version 4.4.0.40 of the server. I noticed a few versions ago that when I added a new Movie that had Extras to my collection that an NFO file was being added for the extras and the trailer. I actually prefer this but I don’t think it’s working correctly (or at least not how it did in the past where NFO files were not written). Wondering if anyone else is seeing this. I haven’t done a clean install in a long time so I’m not sure if this is a bug, data corruption issue, or just new default behavior.
  6. sunnyc90

    Question about firewall

    Ever since Update 4.4.1.0, I cannot identify any of my movies, search for plugins, or have the server automatically download Metadata. Server is having issues fetching plugin updates. I've tried to do some things myself such and reinstall Emby Server, remove OMDb and left TMDb. Searching in IMDB in Identify and get no results. Log file attached. Please Help.
  7. My issue or goal with this post is that i would like at the very least for the show titles to be in Norwegian and ideally also all the other metadata as thetvdb often only have metadata in the original language of the show. Situation: I have a separate library for tv-shows in my native language, The Preferred downloading language, Country and Preferred downloading language for pictures are all set to Norwegian. (under library settings). Yet all shows are displayed with an English title and English show description, And lack the show description. For the purposes of this post i'm referring to this show: https://thetvdb.com/series/the-great-norway-adventure The show title is in both Norwegian and English, The show and episode info are all in Norwegian only. I'm not sure about the pictures. The individual episodes only have descriptions in Norwegian (on the thetvdb) and these are missing on Emby. It apears i'm only getting metadata in english instead of the chosen language. I attempted to set the language for just this show and refresh all metadata (replacing existing) and yet there was no improvement. It does not appear to be an issue for my movie folder set to Norwegian, So i guess this is the tvdb api. Attached are logs for the next 6 minutes after i told Emby to refresh the metadata (replacing metadata). Edit: nvm i found this: https://forums.thetvdb.com/viewtopic.php?f=17&t=60423&p=174944&hilit=norwegian#p174944 I created this post as i found this issue to be on their fixed list, but i guess not. The issue is aparantly still with thetvdb api and is limited to the Norwegian Language.
  8. This maybe a bug or just the underlying behavior to get multi-versions to work in Emby. According the Emby Wiki you can name the movies files with the following naming convention Multiple versions of the same content can be stored in a single movie folder. /Movies /300 (2006) /300 (2006)/300 (2006) - 1080p.mkv /300 (2006)/300 (2006) - 1080p-trailer.mp4 /300 (2006)/300 (2006) - 4K.mkv /300 (2006)/300 (2006) - 720p.mp4 /300 (2006)/300 (2006) - extended edition.mp4 /300 (2006)/300 (2006) - directors cut.mp4 /300 (2006)/300 (2006) - 3D.hsbs.mp4 Each version must begin with the folder name, followed by " - ". If using the dash method anything following the dash will be what you see in the Emby client app. I have couple movies, Thor: Ragnarok, Pokemon Detective Picaku, King Arthur: Legend of the Sword and that do not group properly What discovered using MediaInfo tool was Movie Name in the Container had different names Blu-Ray Rip UHD Rip Blu-Ray UHD
  9. I've been trying all day to get Emby to download the metadata for a specific show from TheTVDB, but parts of it aren't coming through, especially the Specials. I've tried multiple times, wiping the nfo files, double checking the filenames, using the Identify tool, etc, none of it has helped. The show is Mai-Otome. I've tried other shows and they seem to be working fine. I dug through the log and found these two errors: 2020-04-15 21:25:01.811 Error App: Error in TheTVDB *** Error Report *** Version: 4.4.2.0 Command line: C:\Users\johndoe\AppData\Roaming\Emby-Server\system\EmbyServer.dll Operating system: Microsoft Windows NT 6.2.9200.0 64-Bit OS: True 64-Bit Process: True User Interactive: True Runtime: file:///C:/Users/johndoe/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll System.Environment.Version: 3.1.3 Processor count: 8 Program data path: C:\Users\johndoe\AppData\Roaming\Emby-Server\programdata Application directory: C:\Users\johndoe\AppData\Roaming\Emby-Server\system System.Xml.XmlException: System.Xml.XmlException: The '.' character, hexadecimal value 0x00, cannot be included in a name. Line 1, position 4097. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args) at System.Xml.XmlTextReaderImpl.ParseElementAsync_NoAttributes() at System.Xml.XmlTextReaderImpl.ParseElementContentAsync() at System.Xml.XmlTextReaderImpl.ReadAsync() at System.Xml.XmlTextReaderImpl.SkipAsync() at System.Xml.XmlSubtreeReader.SkipAsync() at Tvdb.TvdbSeriesProvider.GetFirstAiredDateFromEpisodeNode(XmlReader reader, CancellationToken cancellationToken) at Tvdb.TvdbSeriesProvider.FetchSeriesInfo(MetadataResult`1 result, String seriesXmlPath, CancellationToken cancellationToken) at Tvdb.TvdbSeriesProvider.FetchSeriesData(MetadataResult`1 result, String seriesDataPath, String metadataLanguage, Dictionary`2 seriesProviderIds, CancellationToken cancellationToken) at Tvdb.TvdbSeriesProvider.GetMetadata(SeriesInfo searchInfo, CancellationToken cancellationToken) at MediaBrowser.Providers.Manager.MetadataService`2.ExecuteRemoteProviders(MetadataResult`1 temp, String logName, TIdType id, IEnumerable`1 providers, CancellationToken cancellationToken) Source: System.Private.Xml TargetSite: Void Throw(System.Exception) ................... 2020-04-15 21:25:37.752 Error App: Error in TheTVDB *** Error Report *** Version: 4.4.2.0 Command line: C:\Users\johndoe\AppData\Roaming\Emby-Server\system\EmbyServer.dll Operating system: Microsoft Windows NT 6.2.9200.0 64-Bit OS: True 64-Bit Process: True User Interactive: True Runtime: file:///C:/Users/johndoe/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll System.Environment.Version: 3.1.3 Processor count: 8 Program data path: C:\Users\johndoe\AppData\Roaming\Emby-Server\programdata Application directory: C:\Users\johndoe\AppData\Roaming\Emby-Server\system System.Xml.XmlException: System.Xml.XmlException: The '.' character, hexadecimal value 0x00, cannot be included in a name. Line 1, position 4097. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args) at System.Xml.XmlTextReaderImpl.ParseElementAsync_NoAttributes() at System.Xml.XmlTextReaderImpl.ParseElementContentAsync() at System.Xml.XmlTextReaderImpl.ReadAsync() at System.Xml.XmlTextReaderImpl.SkipAsync() at System.Xml.XmlSubtreeReader.SkipAsync() at Tvdb.TvdbSeriesProvider.GetFirstAiredDateFromEpisodeNode(XmlReader reader, CancellationToken cancellationToken) at Tvdb.TvdbSeriesProvider.FetchSeriesInfo(MetadataResult`1 result, String seriesXmlPath, CancellationToken cancellationToken) at Tvdb.TvdbSeriesProvider.FetchSeriesData(MetadataResult`1 result, String seriesDataPath, String metadataLanguage, Dictionary`2 seriesProviderIds, CancellationToken cancellationToken) at Tvdb.TvdbSeriesProvider.GetMetadata(SeriesInfo searchInfo, CancellationToken cancellationToken) at MediaBrowser.Providers.Manager.MetadataService`2.ExecuteRemoteProviders(MetadataResult`1 temp, String logName, TIdType id, IEnumerable`1 providers, CancellationToken cancellationToken) Source: System.Private.Xml TargetSite: Void Throw(System.Exception) Attached is my full log. What I did was I just manually updated to v4.4.2 booted the server deleted the *.nfo files for my show and added an .ignore file scanned my library in order to wipe the show from my database deleted the .ignore file and scanned my library again Show appears in my library, but again chunks of the metadata are missing Any ideas? embyserver.zip
  10. Hi Could you please add add a db service like goodreads.com (they have and IPI) or something that could identify and download images and metadata for ebooks and audiobooks by name like movies and series? Thanks
  11. @@cayars In my main settings for Emby, under Library/Advanced, I have a metadata path set up that points to a spare SSD. I created a test 'movies' folder and placed a movie in there and checked the box for "...metadata saver to .nfo" and also checked the box to save artwork into this folder. First (maybe dumb) question is, when Emby scanned that test folder and saw the movie in there, why wasn't the artwork save into that folder? But now onto the main point of my post; with Plex, whenever I would hop to a new distro, I would follow the instructions for backing up all the necessary files and moving everything to a new Linux install. I would never back up my cache or metadata since it seemed to just take hours and hours vs. just letting my new Plex install rebuild everything from scratch. The problem with this approach however was that in my movie library, I would always have to manually fix metadata on dozens of movies due to mismatches. I think the metadata manager in Emby is 100x better than Plex. BUT, for movies like 'Wonder', Emby wants to identify it as 'Wonder Woman' and I'll need to manually intervene and fix it, which I'm totally fine with, BUT.... once I get all my movies fixed in Emby, how do I make sure those metadata corrections are backed up in case I ever have to load Emby on a new box? I was reading the guide for backing up the server and see that backing up metadata is not a feature of the 'Server Configuration Backup' plugin. Then I see this sentence in that guide: This will not backup library contents and metadata. To keep a permanent copy of metadata, we suggest enabling saving of local metadata to media folders. ....... and I think this is what I'm after, correct? Unfortunately, I don't see that exact wording anywhere. I found this thread: https://emby.media/community/index.php?/topic/73693-how-do-i-save-local-metadata-to-media-folders/ .... and it looks like 'save artwork into media folders' is the new equivalent to 'saving of local metadata to media folders', right? Which finally brings me to my last question............ in the admin dashboard, on the 'Nfo metadata' tab, I see "Save user watch data to nfo's for"..... and you can select a user. How can you tell Emby to record ALL users' watch data to an nfo file? Hope I articulated my question(s) correctly.
  12. Everything else is being matched fine, but with music it's a big hit and miss. Most of the artists in my library got identified, but only ~50% of them have pictures downloaded for them. I downloaded Last.fm hoping it could help and logged in in case it would be needed, but that didn't help at all. I set last.fm as the highest in library settings. For example "Alstroemeria Records" has 8 photos listed in last.fm-s page yet Emby found 0. Also how to I merge artists? Plex has a option for it (Select couple, then merge under options). Is there an alternative in emby, would help to clean up a lot of them. My folder structure is basic: A:\music\artist\album\song.mp3 https://imgur.com/a/SfQyeTa Thanks
  13. One of the supported TV file naming conventions is: 02 Episode Name.extFor a show that airs every weekday, the episode number often grows to three digits. For example: /Some Show/Season 2/123 Some Title.m4v Emby mis-identifies the file above as Some Show, Season 1 (even though it is in the Season 2 folder), Episode 23 (even though the filename has the number 123 in it). Is it really not possible to support this format for three digit episode numbers?
  14. I am not sure what has happened but Emby can't seem to pull any movie posted for Russian TV shows. It can only pull banners. Version 4.4.1.0 Sample: https://www.thetvdb.com/series/211771
  15. psaixx

    Don't update metadata

    My server stopped updating the metadata files. The task reports time out. embyserver.txt
  16. Just a couple of quick questions. 1....If I have 'Refresh metadata every 30 days' selected in library settings, does this replace all the metadata or just missing metadata? 2....If I have a series locked at series level, and then add a new episode, will metadata still be retrieved, and will the new episode be locked or unlocked?
  17. A feature i would find really useful would be to see additional metadata when looking through "on now" and "upcoming movies" for live TV. In particular the ability to click on the "on now / upcoming" movie poster & where the options are to watch / record / more... have additional data such as IMDB & rotten tomatoes ratings, movie runtime & a link to be able to watch the movie trailer prior to setting a recording. Would this ever be considered / possible?
  18. I've probably missed a setting here somewhere so I hope it's a simple fix. I spent a few hours last week refreshing metadata and updating images for the many titles i had that hadn't auto scraped....there were a lot. Only to come back on today to find they have all reverted back to thumbnails of the movie..... What have I done wrong please. Most movies scrape properly and stay correct and all will scrape the correct info if go through and manually re-scan them.
  19. In the never-ending fight against bad info, images etc. I've been editing IMDB and TmDB info in the Metadata Manager and saving each file which is known to have incorrect or missing info. However, I've been wondering (as of late) is this the right place to be doing these edits. Is there a simpler or more comprehensive way to have the fetcher/ scrapper pull in the correct info?
  20. English: Hello, I tell you about the problem I have. I'm trying to update metadata for the One Piece series (season 21) and I have the following settings in the series library: And what is happening is that tvdb has only the titles and not the synopsis, and most of the episodes on tvdb are blocked from being edited. In theory as tvdb does not have the synopsis, it should be taken from tmdb, but it is not. And I see that in the cache of tmdb-tv it creates a file "season-21-en.json", which has the data of the episodes, but emby apparently does not use them. I clarify that I am looking for metadata in the Spanish language, and I apologize for the translation into English of this topic. Attached the server log, to generate this log reset the server and when I start the only action I took was to replace the metada of the season in question. Do you know why this happens? Español: Hola, les comento el problema que tengo. Estoy intentando actualizar la metadata de la serie One Piece (temporada 21) y tengo la siguiente configuracion en la libreria de series: Y lo que esta pasando es que tvdb tiene solo los titulos y no la sinopsis, y la mayoria de capitulos en tvdb estan bloqueados para poder editarlos. En teoria como tvdb no tiene la sinopsis, deberia tomarla de tmdb, pero no lo esta haciendo. Y veo que en la cache de tmdb-tv crea un archivo "season-21-es.json", que tiene los datos de los episodios, pero emby no los usa al parecer. Aclaro que la metadata la busco en el idioma Español, y pido disculpas por la traduccion a Ingles de este topic. Adjunto el log del servidor, para generar este log resetie el servidor y cuando inicio la unica accion que realice fue reemplazar la metada de la temporada en cuestion. Saben porque ocurre esto? season-21-es.txt embyserver.txt
  21. arthurmv

    artist.nfo please

    I can't find artist.nfo in APPDATA folder, only cover images there, and nothing happens if I modify or set some dummy nfo's files in my artist folders. I gave me all rights to the whole drive (D:\) but nothing happens... I need to format computer and/or move my media library often, I'm looking for solution using metadata as files or embedded into them. I think emby could be the answer (I came from Plex). Can someone help me? please. log.txt
  22. Hello I have started adding home photos into my Emby library (videos home videos and photos), I am using Adobe bridge to add the IPTC metadata. I know Keywords get mapped to Tags I was wondering how Emby map other fields? I want to be able to mass tag photos and have Emby auto fill the following feilds: Studio People Genre I can't really find any guide around photos and metadata management for Emby and have been trying a few different fields but nothing but keyword seem to populate.
  23. thegrunge

    Backup And Restore Server

    Hi I'm doing a backup test on my mac. I used the server configuration backup extension (plugins) to do my restoration and I copied the metadata in the root folder where the metadata is located after the scan and that before scanning the libraries. The process is as long as if I hadn't transferred the metadata. I wonder if this is normal or if I should also use the NFO extension. In fact I am not sure what exactly this extension does apart from creating .nfo files next to each file. Thank you Edit: I think I used the metadata of another version of Emby that I had installed and which was not in .config but just before in my username folder. I believe that a simple way to restore on clean installation would be to copy and paste the emby-server folder as well as that of the application. @@dcol @@PenkethBoy @@Smaky
  24. C_J

    Artist Info & Artist Images

    1. Is there a way to load artists with pictures only but without artist info. The info provided by musicbrainz is often too long. 2. which metadata downloader must be enabled to load artist pictures?
  25. Hello, I'm having a problem with the display in the Metadata Manager for "Movies" media libraries. Indeed, for these media libraries, the variable " serveritemtype " is set to " Movie ", while for media libraries of the " TV " type , the display is in " Folder " mode eg: " Films " type media library : <li role = "treeitem" serveritemtype = "Movie" collectiontype = "undefined" aria-selected = "false" aria-level = "2" aria-labelledby = "8_anchor" id = "8" class = "jstree-node jstree -leaf "> " TV " type media library : <li role = "treeitem" serveritemtype = "Folder" collectiontype = "undefined" aria-selected = "false" aria-level = "2" aria-labelledby = "8_anchor" id = "8" class = "jstree-node jstree -leaf "> The fact is that when a media is not correctly detected by the scrapper, it is very practical to be able to find it thanks to the Metadata Manager (I think, moreover, that is its function). Display in " Folder " mode is therefore necessary. On an Emby server, in the latest stable version (4.3.1.0), which I upgrade from version to version since version 4, I don't have this problem, the display is in " Folder " On a freshly installed Emby server (4.3.1.0), I have this problem. For information on configuration, the 2 Emby servers are installed on an Ubuntu 18.04 server 64bits (up-to-date) with an Emby Premiere LifeTime license each. Is there the possibility to force the display in " Folder " mode in the Metadata Manager ? Thanks for your help. Mick @@neik @@Happy2Play @@arrbee99
×
×
  • Create New...