Jump to content

Search the Community

Showing results for tags 'metadata'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. DSM 7, x64 Emby 4.6.7.0 No matter what setting configuration, artist metadata from a newly created music library will never be downloaded at all despite any type of scan EXCEPT a personal, individual, one-by-one refresh. Steps to reproduce: Enable appropriate settings when creating the library (see pics). Library finishes import and no artist metadata is saved like it should be. Manually trigger a scan, meta refresh, literally try any scan possible for the library. Still, no artist metadata is saved like it should be again. Music library settings upon creation: Things tried: Checking/unchecking NFO settings (Both after the library was already created, AND after deleting the library and starting from scratch with the settings checked). Changing music folder structure to "other or unstructured" (After deleting the library and starting from scratch with the setting). The only way I am able to get an artist's meta to download is by manually going to their specific page and performing a metadata refresh on just them. Still, this method does not work if the two "NFO" options are unchecked. It doesn't make any sense. Why are all of the SAME options perfectly functional for video libraries but just flat out don't work for music libraries for years? How? Furthermore, half of the settings literally do absolutely nothing at all. This includes: Metadata readers/savers - Unlike a movies or tv library that populates nfo files next to the content on the HDD, the settings for a music library seemingly do nothing. Save artwork into media folders - Nope, just flat out doesn't work / has been broken for at least 2 years. Every time I bring it up it's somehow twisted around that I am misunderstanding the feature and it's working as intended. Again, works just great for both my movies and tv libraries. Does nothing at all for the music library. Can provide video evidence of everything if necessary, a remote session, just about anything to get this solved. No logs or anything of the sort should be necessary. I can easily install a brand new, fresh Emby server, add a music library and watch the same results happen every time
  2. Recently reset my book & comic library to get it working with the latest version of emby, and noticed that external metadata files aren't being generated for supported files. Tried manually creating/importing nfo, opf, and xml files, but they're either not supported, not being detected, or aren't properly formatted. Any tips? I'm able to edit metadata for the titles, but it clearly isn't being stored in or with the files. Thus far I've tested cbz, epub, and pdf books with manually extracted cover thumbs. On my home machine, I typically manage my epub books with Calibre (I use the current version), and my cbz books with ComicRack (I don't believe the software's maintained any more, however). While Calibre generates opf metadata files, ComicRack usually stores its metadata of the cb7/cbr/cbt/cbz archive files as an xml archived inside the file. Though I doubt there's time or resources available for emby devs to enable the server software to extract the metadata from these files, I am curious as of what the proper method is since emby's clearly storing the metadata that it does have somewhere (the cache perhaps?). Of additional minor note, the current metadata for books doesn't seem to include an author tag, so I've been keeping that data in the title. Is that intended to be placed in the Studio tag or something? Stay awesome! EDIT: Also, any genre tags on books link to the equivalent Movie genre instead (if they exist). Tags seem to work properly at least.
  3. Hi, so what I'm suggesting isn't just the whole WebUI page refreshing when any changes is detected, I'm leaning more toward the Plex approach. Meaning, when scanning your library folders (per show/movie/etc.) you'll get the percentage indicator or a spinning icon signaling that the server is in the middle of the process. The lack of indicators when making changes is resulting in an unawareness of if the action you just performed is in effect or has completed. It's a small but appreciated quality of life addition.
  4. Was wondering if, like with Plex, you're able to somehow show the animation studio's name instead of the broadcast company that aired it? Like for an instance Madhouse instead of Tokyo-MX.
  5. Hello everyone Last Friday I restarted my Docker Emby container on Unraid. I lost all my libraries. I had the "Server Configuration Backup" extension, but no restore worked. I was using this Emby package, so I thought that this one had a problem. So I installed a new package at the end of the day. Everything was working until today when I had no cover image on my libraries. I restarted my container, and I lost all my containers. I also tried a restore but nothing worked. Also, it deleted my old Emby log files... However, I found an error in the little log file : When I look in my system, all the metadatas are deleted... ! Do you know can i fix it and restore my metadas ? Thanks a lot embyserver-63765654731.txt
  6. It occurs to me that the various databases have a great array of images for actors that sometimes will include series specific pictures for them. A few series that pop out to me are Various Star Trek Series, Various TMNT Series, Knights of the Templar, the various CW DC Series; many more. I don't tend to use these so that I don't see one of the posters popup for an actor on a completely unrelated series. Could we have a feature that allows us to have several posters/art for a single actor and specific which to use as default and which to use on specific series? --- Another random feature request (possibly/probably deserving its own thread), on the same vein as actor metadata, currently, we have all the actors on a series get crammed on a single line. I would love to have an option to allow people to display two additional lines for actors, 1 for season regulars (not series regulars, regulars that are for one season only) and then an additional one for notable guest stars. Considering some might see this as clutter, especially if a super awesome way to display this doesn't come along, I would highly recommend that the server admin can opt to turn this feature off and users can also opt to turn this feature on and off; obviously if the server admin opts to turn it off, its turned off for everyone.
  7. I am having some issues with The Walking Dead and The Walking Dead: Origins, Emby keeps matching the later as part of the main show and I can't get it to split at all, if I go into season one of the walking dead and then each episode I can split them there but it still see is as one show and not 2 different ones. I am unable to use folder view as it seems to thing the same here, yet my Plex has detected them properly and there using separate folders on my NAS as per how Sonarr added them
  8. Hallo, ich habe einen neuen Emby Server aufgesetzt und mir ist aufgefallen, das die Zuordnung nicht immer funktioniert, wenn der Film in Deutschland einen anderen Namen hat. Im Beispiel geht es um den Film "Auf der Jagd" von 1998. Wenn ich den Film auf "themoviedb" suche bekomme ich auch den Film als Ergebnis (Film 01 themoviedb). Wenn ich Emby zum Identifizieren des Films benutzte (Film 01 Identifizieren), bekomme ich ein unzufriedenstellendes Ergebnis. Hat jemand eine gute Idee? Gruß Rolf
  9. embyL0VER

    Deutsche Metadaten TMDB

    Hi, nach längerer Nutzung des TMM um Metadaten zu pflegen, habe ich Mal wieder emby selber getestet. Leider funktioniert das scrapen über TMDB für Filme (Serien ist ein anderes Thema) auf Deutsch immernoch nicht ordentlich. Beispielsweise wird die Handlung für den Film "Luca" auf Englisch bezogen, obwohl auf TMDB eine deutsche Handlung verfügbar ist. (Metadaten über emby schon mehrfach versucht zu aktualisieren, bleiben Englisch) Der TMM ruft korrekt die verfügbare deutsche Handlung ab. Wäre es evtl. möglich, dass sich dieser Problematik einmal angenommen wird? Letztendlich sind die korrekte Abfrage und Verarbeitung von Metadaten ja ein essentieller Bestandteil von emby. Hier wird bei solchen Problemen leider immer bzw. meistens auf eine fehlerhafte APi von z.B. TMDB hingewiesen, dass mag auch mal so gewesen sein, mittlerweile bekommen andere Scraper es aber hin Daten fehlerfrei auf deutsch (wenn verfügbar) von TMDB zu scrapen.
  10. Hi, Apologies again for the long post. This is a follow-up to my post from the previous year: The discussions there helped me finalise the working of multiple Emby servers that read from the same library with one acting as the metadata writer for generating all the nfo/jpg etc. and the others (referred to as metadata readers) reading those with their respective internet metadata downloaders disabled or uninstalled altogether. Now that 4.6.1 has been released with quite a few changes to how Emby stores and processes the metadata (especially with Collections & Audiobooks), I am planning to wipe the existing metadata and re-generate it with a fresh Emby install so that there are no issues due to upgrades etc. Before going ahead with it, I have a few questions that I would like clarified: * Are the metadata generated by 4.5.4 & 4.6.1 servers inter-compatible (barring Collections, which is stored in a different location altogether)? To clarify, can the metadata writer be in 4.6.1 and the metadata readers be in 4.5.4 or vice-versa? Any issues with client compatibilities? * How are multiple collections stored in the media nfo file? Multiple set tags? * I see that TV shows also have the "Minimum automatic collection size" setting (like Movies) but no option for "Automatically import collections from the enabled metadata downloaders" like Movies. Is that by design? What does changing the size affect then, if it's not automatically importing the collections? * What all content has been moved to the metadata folder, apart from Collections? From a brief search, I see that the People folder was also moved there? Anything else? * Following up on the above, why wasn't the movement of the People folder mentioned in the release notes? The move of Collections is also similarly lacking mention in the release notes but for that, at least there was a mention of the storage rework which helped me to track down the various changes w.r.t the media nfo files & the metadata folder * I see that the people images are only downloaded on-demand now which becomes problematic in my scenario where the metadata folder is mounted as read-write only on the metadata writer & as read-only on the metadata readers with no streaming occurring on the writer. Is there any API call to force a download of those images?
  11. Emby is not properly reading all ARTIST tags for MP3 files. FLAC files are okay, seems to be only MP3 files. Not sure what causes this, but I tag MP3 and FLAC files the same in mp3tag and MusicBee, with an ARTIST tag for each artist on the track: Title: Believe ft. Big KRIT (DatPiff Exclusive) Album: Before The Box Album Artist: David Banner Artist: David Banner Artist: Big K.R.I.T. When FLAC files are tagged this way with multiple artists, the artist tag is treated as a list and all artist are recognized individually. However, it seems like Emby can only read the first ARTIST tag from MP3 files. This means that any featured artists do not get indexed, and any MP3s they are tagged on will NOT show up on under the "appears on" section for the artist page. Here are the tags viewed in Mp3tag:
  12. I have a couple of sports related libraries with matches I've recorded from TV, when setting them up in libraries I have the library set to use 'Thumbnail Images' (Generate video preview thumbnails = 'as a scheduled task and when media is added'), I can see this works great in the 'Chapters' part of an entry (ie a match) but the screenshots aren't used for the entry itself, instead the main image for the top level item is used (see screenshot attached). The absolute ideal scenario would be to be able to select one of the chapter images as the main image for the entry or, if not that then, to click a button in 'Images' that will show a few screenshots to select from. Thanks
  13. I'm trying to update the Cover photo of some albums because some of the automatic album covers taken from metadata are not good quality. This works fine for most albums but there are some albums that when updating the album cover, the individual song covers stay the same because each of them has its own cover still set to the previous one. Any way I can update all songs in an album to the custom Album cover that I've set without having to go through each song and change its cover individually?
  14. In my plugin I have successfully implemented Movie and Series Providers without any issues based on the examples from the Anime plugin. Now I am trying to do the same for people with no success. I have tried it first by implementing IRemoteMetadataProvider and when that didn't work I tested ILocalMetadataProvider also with no success. While debugging with breakpoints on the GetMetadata and GetSearchResults methods it seems like they are simply never called. Not while adding a person, not while manually refreshing the metadata and not while using the identify search. For reference these are my classes, stripped down to the minimum for testing: IRemoteMetadataProvider class MediaServerDBPersonProvider : IRemoteMetadataProvider<Person, PersonLookupInfo> { private readonly ILogger _log; private readonly IHttpClient _httpClient; private readonly IApplicationPaths _paths; private readonly IDirectoryService _directoryService; public static string provider_name = ProviderNames.MediaServerDB; public string Name => "MediaServerDB"; public MediaServerDBPersonProvider(IHttpClient httpClient, ILogger log, IDirectoryService directoryService, IApplicationPaths paths) { _httpClient = httpClient; _log = log; _directoryService = directoryService; _paths = paths; } public Task<MetadataResult<Person>> GetMetadata(PersonLookupInfo info, CancellationToken cancellationToken) { return Task.FromResult<MetadataResult<Person>>(new MetadataResult<Person>()); } public Task<IEnumerable<RemoteSearchResult>> GetSearchResults(PersonLookupInfo searchInfo, CancellationToken cancellationToken) { return Task.FromResult(Enumerable.Empty<RemoteSearchResult>()); } public Task<HttpResponseInfo> GetImageResponse(string url, CancellationToken cancellationToken) { return _httpClient.GetResponse(new HttpRequestOptions { CancellationToken = cancellationToken, Url = url }); } } ILocalMetadataProvider public class MediaServerDBLocalPersonProvider : ILocalMetadataProvider<Person> { private readonly ILogger _log; private readonly IApplicationPaths _paths; public static string provider_name = ProviderNames.MediaServerDB; public string Name => "MediaServerDB"; public MediaServerDBLocalPersonProvider(IApplicationPaths appPaths, ILogManager logManager) { _log = logManager.GetLogger(Name); _paths = appPaths; } public Task<MetadataResult<Person>> GetMetadata(ItemInfo info, IDirectoryService directoryService, CancellationToken cancellationToken) { return Task.FromResult<MetadataResult<Person>>(new MetadataResult<Person>()); } } One thing I noticed is that while for Movies and Series the used providers depend on the configuration of the library, the providers used for people seem to have a different configuration as even with all remote providers disabled in the library emby is still fetching remote metadata for people. So maybe I need to configure my provider to be used for people somehow? Any help would be appreciated. Thanks!
  15. So I added a new series to the server for my two young sons to watch. When logged in on their profiles, the saeries is not displayed - that's because their profiles restrict content based on the rating. great, that works. When I look at the series, I see the parental rating applied is KR-ALL. Being in the UK, anything other than GB-U or GB-PG is not allowed on their profiles. Again, good, all is working. however, when I go to amend the parental rating, I change the series rating to GB-U thinking this will cascade from the highest level down through both seasons and all episodes. Nope. I then have to go to each season and change that perental rating and then each and every single episode. Even using the metadata manager this is panful as Ican't select multiple items... Please tell me I did something wrong and should have done X instead to change all values simultaneously... Tl/DR - changing the parental rating of a TV series doesn't cascade to all items below it and using the metadata manager is painful without allowing multiple selections.
  16. queenbuzzo

    Metadata default language

    Hi, I have a quick question and couldn't find any information. Is there an option to set a default language for metadata, if no data for the language set for the library is available? In my case I have set the library language to German, but theTVDB does not have German content for all the episodes yet and currently Emby is not showing any information. In this case I'd like Emby to pull the English content, but it seems that this is not possible or am I missing something? Thanks.
  17. Yodikko

    Audiobooks not showing properly

    The structure is /Audiobooks folder/Book name/ and here the files are 1- Book name - Chapter 1 2- Book name - Chapter 2 ... 8- Book name - Chapter 8 What am I doing wrong here? As you can see the chapters are not showing up, and it looks like it is reading just the chapter 8.
  18. embyserverlogidentifyerror.txt I am unable to retrieve tv show metadata from the internet due to a TrustFailure - CERTIFICATE_VERIFY_FAILED Here an error snippet snippet from the attached log: 2021-01-05 11:09:54.348 Info HttpClient: HttpClientManager GET: https://www.thetvdb.com/api/GetSeries.php?seriesname=Downton+Abbey&language=en 2021-01-05 11:09:55.139 Error HttpClient: Error TrustFailure getting response from *** Error Report *** Version: 4.4.3.0 Command line: /var/packages/EmbyServer/target/server/EmbyServer.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -ffdetect /var/packages/EmbyServer/target/ffmpeg/bin/ffdetect -restartexitcode 121 Operating system: Unix 2.6.32.12 64-Bit OS: False 64-Bit Process: False User Interactive: False Mono: 6.8.0.105 (tarball Wed Apr 8 20:33:25 UTC 2020) Runtime: file:///volume1/@appstore/EmbyServer/3rdparty/mono/6.8.0.105/lib/mono/4.5/mscorlib.dll System.Environment.Version: 4.0.30319.42000 Processor count: 1 Program data path: /var/packages/EmbyServer/target/var Application directory: /volume1/@appstore/EmbyServer/releases/4.4.3.0 System.Net.WebException: System.Net.WebException: Error: TrustFailure (Authentication failed, see inner exception.) ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. ---> Mono.Btls.MonoBtlsException: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED at /source/mono/external/boringssl/ssl/handshake_client.c:1132 at Mono.Btls.MonoBtlsContext.ProcessHandshake () [0x00048] in <b373cc92cfb94ef6a19b4f1140645494>:0 at Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake (Mono.Net.Security.AsyncOperationStatus status, System.Boolean renegotiate) [0x000da] in <b373cc92cfb94ef6a19b4f1140645494>:0 at (wrapper remoting-invoke-with-check) Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake(Mono.Net.Security.AsyncOperationStatus,bool) at Mono.Net.Security.AsyncHandshakeRequest.Run (Mono.Net.Security.AsyncOperationStatus status) [0x00006] in <b373cc92cfb94ef6a19b4f1140645494>:0 at Mono.Net.Security.AsyncProtocolRequest.ProcessOperation (System.Threading.CancellationToken cancellationToken) [0x000fc] in <b373cc92cfb94ef6a19b4f1140645494>:0 --- End of inner exception stack trace --- at Mono.Net.Security.MobileAuthenticatedStream.ProcessAuthentication (System.Boolean runSynchronously, Mono.Net.Security.MonoSslAuthenticationOptions options, System.Threading.CancellationToken cancellationToken) [0x00262] in <b373cc92cfb94ef6a19b4f1140645494>:0 at Mono.Net.Security.MonoTlsStream.CreateStream (System.Net.WebConnectionTunnel tunnel, System.Threading.CancellationToken cancellationToken) [0x0016a] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.WebConnection.CreateStream (System.Net.WebOperation operation, System.Boolean reused, System.Threading.CancellationToken cancellationToken) [0x001ba] in <b373cc92cfb94ef6a19b4f1140645494>:0 --- End of inner exception stack trace --- at System.Net.WebConnection.CreateStream (System.Net.WebOperation operation, System.Boolean reused, System.Threading.CancellationToken cancellationToken) [0x0021a] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.WebConnection.InitConnection (System.Net.WebOperation operation, System.Threading.CancellationToken cancellationToken) [0x00141] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.WebOperation.Run () [0x0009a] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.WebCompletionSource`1[T].WaitForCompletion () [0x00094] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task`1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func`1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x000f8] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00020] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <9d3f0d4bd0fb4c1e8b6c2ac1ba1303ac>:0 Source: System TargetSite: System.Net.WebResponse EndGetResponse(System.IAsyncResult) InnerException: System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. Source: mscorlib TargetSite: Void Throw() at Mono.Net.Security.MobileAuthenticatedStream.ProcessAuthentication (System.Boolean runSynchronously, Mono.Net.Security.MonoSslAuthenticationOptions options, System.Threading.CancellationToken cancellationToken) [0x00262] in <b373cc92cfb94ef6a19b4f1140645494>:0 at Mono.Net.Security.MonoTlsStream.CreateStream (System.Net.WebConnectionTunnel tunnel, System.Threading.CancellationToken cancellationToken) [0x0016a] in <b373cc92cfb94ef6a19b4f1140645494>:0 at System.Net.WebConnection.CreateStream (System.Net.WebOperation operation, System.Boolean reused, System.Threading.CancellationToken cancellationToken) [0x001ba] in <b373cc92cfb94ef6a19b4f1140645494>:0 InnerException: Mono.Btls.MonoBtlsException: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED at /source/mono/external/boringssl/ssl/handshake_client.c:1132 Source: System TargetSite: Boolean ProcessHandshake() at Mono.Btls.MonoBtlsContext.ProcessHandshake () [0x00048] in <b373cc92cfb94ef6a19b4f1140645494>:0 at Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake (Mono.Net.Security.AsyncOperationStatus status, System.Boolean renegotiate) [0x000da] in <b373cc92cfb94ef6a19b4f1140645494>:0 at (wrapper remoting-invoke-with-check) Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake(Mono.Net.Security.AsyncOperationStatus,bool) at Mono.Net.Security.AsyncHandshakeRequest.Run (Mono.Net.Security.AsyncOperationStatus status) [0x00006] in <b373cc92cfb94ef6a19b4f1140645494>:0 at Mono.Net.Security.AsyncProtocolRequest.ProcessOperation (System.Threading.CancellationToken cancellationToken) [0x000fc] in <b373cc92cfb94ef6a19b4f1140645494>:0 Any help would be appreciated.
  19. Hello! Meta doesnt appear to be pulling. Been like this for the past couple days. Nothing has been touched on a server level. We did recently update to a new mesh wifi recently, but no issue accessing the server both onnet and offnet The screenshot below is how it pulls when new media is added. Odd Thomas is the only one that pulled a cover, but no actual meta. The rest all look just as you see it. I ran a fresh debug. Any assistance would be phenomenal. Thanks!!! embyserver (1).txt
  20. Hi, I'm an Emby user since 2 or 3 months ago. Still experimenting on some things, but I'm already on a production scenario, with hundreds of items. I've spent a lot of time customizing metadata for single items, and such. As I'm an Emby Premiere user, I'm using the Emby Backup plugin to backup everything in case of disaster. However, I've read recently on other similar posts, and later I confirmed according to the wiki here: https://support.emby.media/support/solutions/articles/44001159936-backup That the Emby Backup plugin does not backup metadata at all. According to the wiki, it's recommended to store local metadata to media folders. Until now, I just didn't use this option because I didn't want Emby to have write access to my media library. So I prefered to let Emby save metadata in its internal database, and use the Emby Backup plugin to backup the data. But given that metadata cannot be backed up this way, I can switch to store it on local media folders. In case I want to enable the option to store metadata to media folders, how would be a safe way to do the migration? Is it enough enabling the option "Nfo" on each library? Should I also enable the "Saving pictures on media folders"? (Sorry I have my Emby on Spanish and I'm translating the option, not sure if it's named that way). I guess I should enable both if I want it to store all metadata on the library, with its info/plots/customized artwork items, etc... And more importantly, I already have lots of valuable customized metadata for my libraries. What will happen when I enable this option to store metadata on library folders? Will Emby migrate all existing (emby-database) metadata to the nfo format and store it to the correct place on my library? I don't want to lose customized posters, etc... so I want to make sure it will save my existing metadata instead of downloading it again from the scrappers. And well, in case the migration is not a safe process, is there any other way to make this migration? And in case there is no other way, is there any good way of backing up the folders where emby stores this data? I guess images are stored as files and other metadata is stored in a specific table on a database? I'm guessing alot here, but shouldn't it be possible to automate some type of reliable backup copying the folder and making a dump of the table where metadata is stored? In case it matters, I'm using Emby 4.5.2.0 on a Synology x86-64 NAS. I kow I'm asking lots of things here. Thanks for any attention you give. Congratulations for this great software. I hope it gets better and better over time. Sincerely,
  21. It has been a few days since Emby for the "Majo no Tabitabi" series hasn't been able to recognize her. He finds it as "Kiki home delivery" of 1989 (studio Ghibli). I tried everything, changed the name of the folder from "Majo no Tabitabi" to "Majo no Tabitabi (2020)" to "The Journey of Elaina" to "Wandering Witch The Journey of Elaina" but nothing. Even putting the ID series from AniDB (15202) / TheTVDB (371436) and telling him to replace all meta and images, he keeps leaving this series (leaving only the right logo and backgrounds but everything else is wrong). Unfortunately I cannot change the name of the file (mkv) which is "[Erai-raws] Majo no Tabitabi - 07 [720p] .mkv" because this is automatically downloaded from qBittorent and automatically seeded in the folder that emby uses. Basically I created a folder (which we will call Seed) where there are the various series in progress and each contains the episodes as they come out (via RSS on qBit). Seed > Series 1 > Season 1 > Episode1.mkv Series 2 > Season 3 > Episode5.mkv Such a thing. To be clear: Jujutsu Kaisen; I'm stading; Tonikawa; King's raid; Danmachi 3; Sleepy Princess in the demon castle; they use the same nomenclature ([Erai-raws] Series Name - 07 [720p] .mkv) and do not have this aforementioned problem. Procedure for forcing identification (which then fails): How it comes out (here by now I have already tried to force majo no tabitabi and in fact the logo and backgrounds are right). identify (first attempt only using name) Result: find kiki instead of majo. This time I use the ID series from TheTVDB (it's better for meta than AniDB): good, found it (): So I tell him to use him and replace EVERYTHING ... Result, he hasn't changed a damn thing: To be clear, I have Italian as my preferred language and country language for the library in question. I also tried with AniDB ID and AniList ID but it doesn't update the meta. I also tried to delete the series (then re-download the episode) but it always finds that series. Thank you in advance. (I notice that compared to 6 - 8 months ago, Emby has made good progress compared to Plex which is really too reclining).
  22. lowe1739

    MetaData issue

    For some reason my Metadata is no longer pulling from any sources. example below. Wonder Woman, the screen cap 1 shows the correct info for themoviedb but even after refreshing and choosing replace image it just shows what is in the other two screen caps any help would be appreciated, just happened this week.
  23. tjmcd.314

    Music metadata issues

    I'm having issues importing my music library. I don't have a list, but there are lots of issues with incorrect meta-data. Just to start with an example, I have a ton of random artists showing up as having "3 doors down" as the artist and album artist (see image below of library). I've checked the metadata with ffprobe and mp3tags and none of the tracks I see list 3 doors down anywhere (mp3tags screenshot of one track below). I've tried deleting and re-importing the library several times, and the issue persists. I think I was able to get 1 album to correct itself by just re-writing the tags with picard, but I don't understand why that did anything since I can't figure out what metadata emby is seeing that is grouping this artists together under an unrelated artist.
  24. Hi all, I’m looking to copy all the metadata from my server to a new second server, all file/paths will remain the same. The issue is though that I want both servers to remain running. I’ve tried copying the whole /var/lib/emby folder, and while that works fine to copy the metadata, it glitches out the server if both the original and copy are running at the same time. I can’t remove emby premiere from just one for example, and emby connect starts disconnecting users. I assume there’s some unique server identifier that distinguishes between servers or something like that. Is there anyway I can modify the the copy of my emby server so that it’s recognized as a new independent server by emby connect/premiere?
  25. Hello, I'm returning to Emby after a few years with Plex and other platforms. Love the configurability of Emby vs other platforms - kudos to the team. What seems to be screwing up the experience for me is the reset of metadata and folder images. This is what initially convinced me to leave Emby for others. I spend considerable time customising the images for various video catalogues, use tags and craft a web of permissions... one day I log in and *puff* gone. Images reset to the automated images pulled from videos, tags nowhere to be found. <Enter anger management> So this happened to me again. My platform is now Linux rather than FreeBSD. Versions ++ as well. Why is this happening? No, I don't think we need logs and deep analysis. Not if it's happening across many Emby releases and different software platforms. Is this a setting? Is there a process which overrides what I configure? Suggestions and comments most welcome. Thanks in advance and take care. :) Janusz
×
×
  • Create New...