Jump to content

Search the Community

Showing results for tags 'metadata'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Sorry if this is a repost, but I haven't been able to find an answer anywhere.... All I need is a simple explanation of how to refresh my entire database in one go (if possible), and whether this can be achieved by a simple restart, an option in the menu, or by deleting a cache folder? Clean install? Or other method? Obviously I'm new to all this... My problem arises from originally having MB set up wrong, and now that it's configured the right way, I'm still left with some oddly incorrect metadata and am trying to find a way to simply refresh (rewrite) it all. For example, all of my "sort name" metadata in my television folder is missing key episode information: 'Adventure Time - S01E20 - Freak City.mp4' is labeled under sort name '001-Freak City' (missing episode info) but a quick manual refresh gets it correctly to '001-0020 - Freak City' I save it and all is good. Except, I really don't want to do this for EVERY SINGLE EPISODE, because that would be mad. Any help would be beyond awesome.
  2. heciruam

    3D MVC metadata

    Hello everyone, I have a question regarding the "3D format" tag, one can edit under "edit info" for a movie. I tag all of my media with mediaelch before I let emby scan them. So after I added them I let emby fetch the local media metadata, I go in and change the "3D format" tag to "mvc". - My question is, if that mvc format tag is an emby internal thing or if I could do that before hand so that would get saved into the .nfo file. (Where is it just a regular "tag" or does it need to be saved anywhere specifically?) - If it is an emby thing, could I let emby export the metadata just for that one movie, even though my setting are setup for emby to save metadata into movie folders. I just want to make sure that, if I ever had to reinstall emby without a back up I would not have to do it all again. Cheers
  3. hello, sadly my first post here is a problem, I am a long user of this great software and reading through the forums has solved several of my problems before, I did also find other posts with metadata issues but but giving the right ID seamed to solve most of those, but doesnt seam to work for me, but here is my problem. Edit: just found out that BBC Horizon (1964) has the same problem I am suddenly getting wrong metadata for at least 2 different shows. Eureka https://www.thetvdb.com/?tab=series&id=79334&lid=7 is suddenly being identified as Eureka seven https://www.thetvdb.com/?tab=series&id=79360&lid=7 supernatural https://www.thetvdb.com/?tab=series&id=78901&lid=7 is being mixed with supernatural the animated series https://www.thetvdb.com/?tab=series&id=197001&lid=7 from what I can see in the metadata manager it is pulling the wrong show name, description and the poster art. but all the episode info and other art i still correct, as it has been for a long time. first I suspected that the anime metadata plugin I had installed was the making some weird problem, but I uninstalled the plugin and the problem is still there. what I tried this happened at the same time to both shows so I have tried this on both with the same result: I tried using the identify function, putting in the correct name and thetvdb.com show id (I also with IMDB ID but had the same result). I then selected the correct show from the list and the data refreshes, but when the data pull is done, the metadata is not for the show I selected, but instead the other one with a similar name. debug log attached. If any more info can help, please tell and I will do my best to produce it. metadata_debug.txt
  4. I recently added Stranger Things Season 2 to my server and I'm having an issue regarding the naming conventions. I'm getting Season 20 (Episode 1), Season 200 (Episode 2), etc.. as if the sub-folders are creating their own season. Folder structure is: Z:\TV Shows\Stranger Things\Stranger.Things.S02E01\Stranger.Things.S02E01.mkv. If I change the folder structure to Z:\TV Shows\Stranger Things\Stranger.Things.S02E01.mkv, the episodes show up as expected under Season 2 with the proper episode names. In fact ALL the episodes show under Season 2 just by moving one episode, but also leaves the residual "Episode 200000" What's more interesting, folder structures of TV shows from months ago with the extra folder show perfectly. Only recently added shows seem to have this issue. Thank you Emby server Version 3.2.35.0
  5. Last month (Sept 25) I noticed that a large number (37) of previously added movies had suddenly moved to the top of my "Latest Media" movie queue. The same thing just happened again on October 18, but only to two previously added movies. This seemed to happen with no intervention from me. It appears the metadata "date added" field is being reset whenever a new metadata item is added to the folder. I have verified in metadata manager that this field has been changed and no longer reflects the date the movie was added but either Sept 25 or Oct 18 2017. In investigatory mode tonight, I have tried doing something similar manually using the Library settings menu, choosing Scan Library on my Movies library, and then selecting Search for Missing Metadata in the dropdown. So far, manually searching for metadata has not caused the same problem with the "date addded" field, though the scan is still in progress. I will update if it does cause the same problem when the scan finishes. Tonight I have also tried changing the Library > Advanced > Date added behavior for new content from "Use data scanned into library" to "Use file creation date." No change in the (now messed up) Latest Media order was observed after reloading the home page, logging in and out of emby, and restarting the server from settings. I am not sure if this last change will only apply to media added from now forward or should apply to my existing movies. When I look at the directory structure of the actual folder using the OS, I can see that file creation date for the folder is the new, same date as the new metadata while of course the file creation date of the actual movie mp4 file is still the date I added the movie. Note that my movies are organized using the standard folder-movie file convention: Movie Name (2000) > Movie Name (2000).mp4 This is frustrating. I usually add a couple of movies a week or so, and we like to pick what to watch from the most recently added list. I'd attach logs but latest problem was a few days ago and logs have cycled. Maybe if I catch it again, now that I know what to look for.
  6. ginjaninja

    Actor Browsing Responsiveness

    Is it possible to prefretch all the people info / metadata? Im prefetching images, but when i browse via person it take a few seconds for each new person... i suspect to download bio. given the server is generally on 24/7 it would be great if all the info could be prefetched to make the ui as responsive as possible. thanks
  7. joshuaavalon

    Episode has empty path?

    I am trying to develop a plugin. I encounter an NullReferenceException in my code. System.NullReferenceException: Object reference not set to an instance of an object at Emby.Server.Implementations.IO.SharpCifsFileSystem.IsEnabledForPath (System.String path) [0x0000a] in <3b153e3701214cb7bba0ce34ae8828eb>:0 at Emby.Server.Implementations.IO.ManagedFileSystem.GetDirectoryName (System.String path) [0x00000] in <3b153e3701214cb7bba0ce34ae8828eb>:0 at MediaBrowser.Controller.Entities.BaseItem.get_ContainingFolderPath () [0x0001a] in <d575e0bae0a34f14bdbdffbac62641bc>:0 at MediaBrowser.Controller.Entities.Video.get_ContainingFolderPath () [0x0003a] in <d575e0bae0a34f14bdbdffbac62641bc>:0 After I try to log some of my code, I found out that an Episode (MediaBrowser.Controller.Entities.TV.Episode) has an empty path and accessing the ContainingFolderPath caused the error. How is it possible to have an episode item with empty path?
  8. When i add say 15 new movies to my library folder, they don't appear in emby for ages! Only one new/unidentified/posterless movie shows up (old bug, all 15 new/unidentified do show up in folders view). Only after ages do they appear, with all the metadata and images. Can we have a button, perhaps just on the dashboard, that instructs emby to: * Immediately halt any other processes, scans, etc. * Scrape the library folders for new media. * Show these discovered new/unidentified/posterless movies in the 'Latest Movies' view (as it used to before the bug/change a while ago) * Systematically acquire all the metadata, images, etc. for each new item. Then emby will show up the new media as quickly as the server, internet connection will allow. Now the new can be watched, organized, edited, checked, etc.
  9. Hello everyone from Emby! This is my first post on your forums since I only started using your product since yesterday (22/09/2017). I used to work with Plex Media Server but after testing your system I'm thinking on jumping platforms for my streaming needs. So here is the issue that I'm facing: 1) After creating a library and scanning the library, I'm faced with a lot of shows with automatically downloaded metadata (which is fine and works perfectly) but also some shows with incorrect matches or no matches at all. I tried finding an option to "fix incorrect match" like I used to do it in PMS and so I found the "Identify" option to basically fix the metadata of each series. Again, until then everything is working perfectly. So after pressing the "identify" option, we get the "identify" window/form where you can actually type in a Name and then search for possible metadata match in the DBs. Now here comes the issue... after I've typed a Name and submit my request, I'm often faced with many possibles metadata choices that could match with my Name. The real problem here is that I'm not shown the complete names of all those possible matches; they are being cut after about 19 characters which is way too small in my case. Some more details to completely explain the issue: -I've only been faced with this annoying issue with Anime titles for Series and Movies since Anime titles are often very long and often have multiple seasons and special episodes starting with the same long title meaning we're seeing the same "Names" in the Metadata Matches. i.e. *Code Geass: Hangyaku no Lelouch *Code Geass: Hangyaku no Lelouch R2 *Code Geass: Hangyaku no Lelouch Special Edition Black Rebellion *Code Geass: Hangyaku no Lelouch Picture Drama *etc, etc... Most of them only show "Code Geass: Hangyak...". I haven't seen an option to change the format to see complete names. Is there some kind of hidden function I have not seen? I'm all ears! 2)Following directly from issue 1, I click on the wrong metadata match and I want to go back by clicking on the back arrow (top left corner of the previous image) or by clicking out of the window, it simply drops me back to my Library and I need to redo all the steps I mentioned to try a different metadata match. If there is no way to display the full names of all matches at this moment, is there a way to make it so that back-tracking to the metadata match window is possible? Thank you for looking into it! Best regards, Pitchblack P.S. I think Emby has a lot of great options! I enjoy it a lot.
  10. Hello there, New Emby Premiere member here. I just moved from PLEX since there is some serious trouble with their Samsung Tizen App that has persisted through more than 6 months with subtitles out of sync. So I downloaded the windows client and has added all my media. However, where PLEX seem to load metadata flawlessly for almost ALL my files, Emby doesn't. I've been sitting for a couple of hours to manually update metadata for many files, but I'm about to give up. It takes way too long and besides this should work properly and automatically insert the correct metadata. Here is an example: I have a folder called: Blade.II.2002.1080p.Bluray.x264 and within this folder is a file called hdc-blade2-1080.mkv The Emby server won't insert the correct metadata for this file. Any suggestion to why this fails?
  11. This occurs in the Linux version, but this is not Linux specific. Enter an actor manually and specify the date of birth and then view the actor. The DOB displayed will be 1 day prior. Find the row associated with the actor in TypedBaseItems. The PremiereDate (I assume this corresponds to the DOB field) will have the date entered when creating the actor.
  12. EDIT: Never mind, I figured it out I think. I put a bunch of videos of demo scene productions in a folder for testing Emby, and they were wrongly identified as movies. Can I remove all the metadata from them at once? Is it possible to only show filenames for the contents of a library for cases like this were the metadata is known to be almost certainly wrong? Thanks.
  13. boxtor

    People metadata

    Although I'm using Emby on unRAID, this is likely a general question. Where is the data associated with people stored in Emby and not just the images?
  14. boxtor

    Actors incorrectly matched

    I have automatic download of metadata and images turned off for the library. When I add an actor that consists of a single name such as "Daisy", it will automatically match it to a (wrong) full name. Sometimes it adds a IMDB or TMDB ID as well. I cannot unmatch the actor. It's automatically renamed and any item I had the actor assigned to has the link removed. I cannot add a new actor of the old unmatched name either. Most of the times I can't remove the IMDB or TMDB IDs either. I create new actors by adding the name to TV episodes or seasons. A blank actor is created as expected. However, it's not expected that it would be automatically matched to something. This is problematic since there is no way to go through the library and remove old actors. It would be nice if the metadata manager would also manage actors.
  15. boxtor

    Actor becomes unusable

    If you manually enter an actor and inadvertently have leading white space (spaces or new lines, usually when manually copy and pasting a name), it will be added, but will not be linkable to a TV season or episode. However, if you add a corrected version without the white space, is disappears as well and is not usable. I've worked around it by adding additional text such as parenthesis, but that causes usability problems for me. "The Actor" becomes "The Actor (2)". I don't know if the original actor still exists. I have tried to delete the original actor poster from the file system, but that did not help. A similar problem happens when I rename an existing actor. If I change "The Actor (2" to "The Actor (2)".
  16. This occurs during a library scan for a TV show season. If there is an existing season.nfo (it's provided to Emby, Emby did not create it from scratch), Emby will not add missing elements. For example, if the season poster is present (image file is present), but not listed in the season.nfo, it will not be added and the poster will need to be added manually through the web interface. Also, if the seasonnumber element will not be added if it is not present. The season number needs to be added via the web interface as well. I would have expected that the library scan would have added missing elements to the season.nfo since 'Save artwork and metadata into media folders' is checked for the library.
  17. The Short Overview section used to exist in the metadata manager, however, after reading https://emby.media/community/index.php?/topic/44536-short-overview-section-missing-in-metadata-manager/ it appears that it has been removed as ' Emby does not make any use of this information, therefore it's being removed from the editor. In the future if we start using it, then it can return'. However, Kodi makes use of this information, so it impacts lots of people who use Emby-for-Kodi. The Short Overview used to contain the plot outline from imdb, and the 'overview' would give the longer description of the plot. This full Overview often contains spoilers as well. Now the full Overview is what we see for each film we add, which is really annoying. Please bring back Short Overview.
  18. I have the following requests for metadata associated with people. 1) Allow per show or per library people. This would be useful for people who are not available on public metadata sources and are likely pseudonyms. 2) Add another role for the person such as character. This isn't the same as the other field. It would be for a scenario such as "Daisy" starting as "Daisy", when there isn't a mapping to "Daisy" and a real name. 3) Consider the person data to NFO or XML files stored with the library or show.
  19. New guy question. Everything seems to be working FreeNAS-11.0-U2 (e417d8aa5) and emby-3.2.26.0-amd64. But I don't understand what the Emby Dashboard info is telling me. When I selected the the folders for Emby I used a media folder I had made and the jail that the Emby plugin made. The storage folders show as /mnt/FNAS/Media/Movies which is a folder I made and /media/Movies which is in the emby_1 jail. However, when I look to see where the metadata is being stored using the Server Dashboard it shows /var/db/emby-server/root/default/Movies Now I cannot find that folder anywhere on the FreeNAS server. Everything is setup to the defaults. So is the server actually able to access the metadata with that designation? Is the data being saved? Or is this just pointing nowhere? Extra Question: I know I should do a different post. If the answer is long I will do so. Just let me know. If I need to reinstall FreeNAS can I get emby to reuse the jail that already exists or must I allow it to use a new jail.
  20. Hello I've just noticed that movies I am adding to my library are not downloading any metadata. I have the option checked to store the metadata with the media file itself but that option has actually not worked for a while (but metadata was still downloading). Recently my c: drive was completely full and I suspect that may have played a role in preventing any meta from downloading but I have cleared some space and now even if I scan for new files or manually refresh metadata nothing happens. I also chose another location for the cache but that did not seem to resolve it. I'm actually not sure where the metadata is stored on the computer. I would like to move it all to another drive to free up more space. I am not sure which files in AppData\Roaming would need to be moved though. I am running Emby server Version 3.2.26.0 on Windows 7 Pro x64. C:drive is a 240GB SSD that has less than a GB of free space currently. I am assuming that the caches and metadata are taking up all the space because no media is stored on this drive. Any thoughts on a fix for this? Thanks
  21. bling26

    Metadata Savers Option

    Emby no longer reads metadata from a xml file? Only nfo files can be used now? This has changed sometime in the last month I think. If you go to Server Manager > Library > Metadata and locate Metadata Savers option, only nfo is available now? This is no good, where did the xml option go? The main reason I choose to go with xml is Media Center Master creates the metadata in xml. I like that because I can manipulate the synopsis for example: "Former cop Brian O'Conner is called upon to bust a dangerous criminal and he recruits the help of a former Miami street racer who has a chance to redeem himself. Parental Rating Summary: MPAA Rating: PG-13 Sex & Nudity: 12 Violence & Gore: 25 Profanity: 1 mouthed and 1 muffled F-word, 2 obscene hand gestures, 3 sexual terms, 38 scatological terms, 24 anatomical terms, 30 mild obscenities, 1 religious profanity, 1 religious exclamation Alcohol/Drugs/Smoking: 1 Frightening/Intense Scenes: 2" as opposed to the overlong: "Florida street racer Tej (Ludacris) is looking for a driver and calls Brian O'Conner (Paul Walker) to a race. Brian is an ex-cop who has the hottest car now. He races against Suki (Devon Aoki), Orange Julius (Amaury Nolasco) and Slap Jack (Michael Ealy) and wins. The police arrive and give chase, capturing Brian. Agent Markham (James Remar) and... ON AND ON AND ON FILLING UP MY SCREEN" Can this be fixed or put back the way it used to be please? Please allow xml metadata files to be read or allow us to choose the type of synopsis is displayed.
  22. Sorry i know this has been answered before. I searched the forums and found users with the same problem, but i dont know if i should bring back an old post or make a new one. Same problem: https://emby.media/community/index.php?/topic/43502-emby-generating-artistnfo-on-emby-servermetadataartists-instead-of-artist-folder-and-not-fetching-artist-bio/ Artists/albuns added some time ago are good, every .nfo is in the correct folder and everything is ok for these in the metadata manager and music catalog. For recent added artists emby generates an artist.nfo under \Emby-Server\metadata\artists and the genre tag is missing when i check in the metadata manager. This is anoying specially when browsing a genre, these newly added artist wont show up. The option 'Save artwork and metadata into media folders' is ticked. When i move the .nfo manually to the artist folder seems to work, the artists pop under the genre in the music catalog. Im using version 3.2.17.0 Thanks in advance
  23. I'd really like to see an option to use the modification time stamp over the creation time stamp, when evaluating the date added. At lease for music files. See also this discussions: https://emby.media/community/index.php?/topic/39666-latest-media-sort/page-1 https://emby.media/community/index.php?/topic/26485-file-created-date-vs-file-modified-date/
  24. i setup Emby with defaults, and according to the Wiki, to store metadata on the (fast SSD) applications drive, not the RAID media drive. (This is also general consensus I've seen at AVS.) “Installation · MediaBrowser/Wiki Wiki · GitHub” https://github.com/MediaBrowser/Wiki/wiki/Installation But I've seen recommendations here to store metadata and artwork in the media folders. What's the current thinking? If it's better to store with the media folders, can this be made the installation default? And the Wiki updated accordingly? And a handy new feature would be to migrate metadata and art to media folders if the server setting is changed. This would accommodate those of us wanting to move to the newly recommended setup (assuming it is).
  25. When I add new content to my music library and scan, it seems album fanart (cdart.png and sometimes folder.jpg) gets downloaded instantly, as it shows up in the corresponding album library folder with no additional action on my part. Artist fanart does not seem to work the same way, as nothing is downloaded to the user-set metadata folder after the library scan. However, once I go into the web player and select an artist, all relevant artwork is downloaded to the metadata folder. Usually I see the banner, folder, and logo pop up right away, and then the extrafanart folder gradually fills up with images (I set the limit pretty high, so this part often takes a while). Is my best bet to just select each artist in the web player one by one, and wait for all images to download, after my full library completes scanning? Or is there some setting to initiate the artist fanart downloads automatically?
×
×
  • Create New...