Jump to content

Search the Community

Showing results for tags 'kodi'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi, I'd love some help please with a frustrating playback issue that suddenly emerged on my Nvidia Shield running Emby for Kodi (native/direct paths). Native/direct sync works. Kodi very briefly shows "Working..." when I press play, then goes back to the menu, all within half a second. My quick and highly uneducated look at the log file showed some errors around demuxing, but I don't know if that's significant. Recent changes to server I imagine it's relevant to point out I've recently upgraded my OS X version on my server machine, and also tinkered with its static IP address (but I ended up returning the address to what it was before the issue) - see below for more details. I'm sorry, I realsie it would be very helpful to be clear when the behaviour started in relation to both of those changes, but I cannot be sure which of those was responsible. Native vs Dynamic The playback error only seems to happen in my preferred native/direct path configuration, so that's a pretty good hint that it's a path/network issue I guess (I'm no IT expert). If I go through the emby for kodi app and select folders with (dynamic) written next to them they work ok, but I'd love to get the snappier native playback working again. Issue on: The playback issue is only encountered on my Nvidia Shield P2897 box, which I use Emby for Kodi (4.0.5) add-on on Kodi 18.4 (native/direct paths setup). Unaffected - these stream fine When I run Emby on my Android phone (galaxy s10e) I can access and stream videos on the server fine via Emby and VLC on the phone, but I guess they use the dynamic playback mode as well. Server My Emby Server (4.2.1.0) is running on a late 2014 iMac, which I recently updated to OS X Catalina (10.15.1). I'm sorry I cannot be specific with times, but the Kodi issues started around this time, and I saw a post about clicking on and off the sharing on the mac to get things running again, and I've done that. As mentioned above, I also changed the IP address of the server for a brief period, as my phone was taking the same IP address, but I then moved my mac back to it's original IP when I worked out how to set a static IP for my phone to stop them clashing. The server's IP is now back to the same value it was when it worked, which is the same as that in the "Shared Network Folder" in the library, and I've done Emby for Kodi database resets and resyncs to be sure the Shield has the right IP paths, but to no avail. The log is available here - I'd value the interpretations of a skilled user (scroll to 2019-11-18 at 19:16 to 19:17).
  2. Hi guys, I just have noticed, that if I play anything from Firefox or Chrome (latest on both) and I "Play on another Device" and select EmbyCon (I have Kodi on a separate HTPC) then in the browser, the volume remains at Zero, actual volume is non-0 though, and I can adjust it with the slider and the volume changes on the HTPC system, but it jumps back to Zero in the browser every time. Is this a bug or expected? Kodi from Debian (17.6 Debian package version: 2:17.6+dfsg1-1ubuntu1) EmbyCon 1.9.32 Emby 4.3.0.26 Thanks...
  3. jeffshead

    Emby for Kodi settings do nothing

    On my Nvidia Shield... Since updating Kodi to 18.5 and Emby for Kodi to 4.1.16, none of the EFK add-on settings do anything. For example, nothing happens when I click on the "Repair Library" option. Also, when starting Kodi, I no longer get the little pop-up that says, "Welcome user". Everything worked just before the updates. Another ongoing problem (the reason why I wanted to repair the libraries) is that artwork goes missing for a lot of the TV episodes so I periodically have to repair the databases. Its been doing this since the last couple of releases. How do I troubleshoot/fix this? UPDATE: I solved the issue. I use a scheduled task to run the Emby Server updater script and I run Emby Server as a service. Apparently, Emby Server automatically updated just hours before I manually updated Kodi and Emby for Kodi on the Shield box. The Emby Server update did not get fully installed because it needed to install an updated version of the Microsoft Visual C++ redistributable package. This cannot be done until you logon to the Windows server. Simply stopping the Windows Emby Server Service and starting the Emby Server EXE auto started the update of the Microsoft Visual C++ redistributable package. Once it finished updating, Emby Server could once again fully start.
  4. misterkoat

    A lot of problems.

    So I'm a new user for emby and I loved it right from the start. It's easier to use than all other media servers. However, I noticed a couple problems 1.With reading music tags I have a vast collection of music files, and I arrange them in folders. I have complete albums in a single folder, and singles in another folder. However, when i added the files to Emby, it was a mess. (See screenshot to understand). It was super frustrating. Note that Kodi and Plex read the tags just as they are. 2. Emby on Kodi I love Kodi. As a result, I always connect Kodi with my Media servers (and if they fail I use Kodi as is.) However, it's drag to get emby to work well. For instance, I have episodes which have VTT subtitles. Since no player apart from VLC can be able to show VTT subtitles, I have added it as an external player. The problem is that after I'm done playing the episode, the watched status changes back to unwatched and if I visit Emby on a browser, the episode is unwatched (mark you i already watched it). Those two are the most pressing.
  5. Hi, I’m having an issue of emby plugin for kodi skipping to the next song in the middle of playback. Usually around 1 – 2 minutes mark. Not much to say – just skips to next song in playlist. Access Is non direct (http). Fresh Kodi install with no other plugins. Manual login to remote server. Originally, I noticed this issue on my Raspberry Pi 2, when I updated from Krypton to Leia. That’s why I decided to test it out on my desktop PC. Web interface and roku app work perfectly fine. Attaching logs. I just noticed – emby has a lot of ffmpeg-transcode logs, attaching couple of those as well. Kodi: 18.4 Git:20190831-3ade758ceb (2019-09-01) for Windows 10. My emby server is on dedicated machine running Ubuntu. If you need any other info, or logs - please ask. Thanks kodi.log embyserver.txt ffmpeg-transcode-84b17364-4fa1-4242-9ed9-f9b2c17723b5_1.txt ffmpeg-transcode-342e7e8b-1866-445c-bb37-65992f41c6b0_1.txt
  6. Hello: Emby Setup: >> I am using Emby Server with Kodi Leia 18.3. Issue/experience: >> When I add TV Shows to Emby Server (and tag them as TV Shows) all of my files are renamed with a "SxxExx" prefix convention. Emby Server also attempts to regroup my files by adding season folders/containers on the server. The naming convention and grouping structure then passes on to Kodi as is expected. >>What I would like is for my TV Show folder structure and file naming convention to remain the same as it is on my hard drive (unmodified), is there a way to do this? If not is there a work around that can be used with "Mixed Content" tag? If a work around exists how do I enable it as, or under, a Kodi main menu item selection? Background: >> I am converting from a HTServer that ran MediaBrowser2. All of the files are DVD type VIDEO_TS files with movie.xml files and .nfo files that store all of the metadata correctly and every episode was set to display an image similar to a movie poster. These TV Shows are stored with the following naming and structure <G:\Television Series\SeriesName\Episode xxx - EpisodeTitle\VIDEO_TS>. Thank you.
  7. hokr

    Kodi chapters for custom videos

    Hi, I did not find answer to this question, when I've searched through the forum. I have custom videos without embedded chapters and relay on Emby to generate scene list and thumbnail images for those. Are such scenes created by Emby imported to Kodi as chapters, when using Emby for Kodi add-on? Or do the chapters need to be embedded to Mp4 or Mkv in order to show in Kodi chapters list? Thank you.
  8. adam.niescierowicz

    MusicVideo Sync Error value: year is out of range

    Hi, I come across emby plugin error when sync music videos 2019-05-29 19:00:21.624 T:3795833712 NOTICE: EMBY.full_sync -> starting sync with [u'd114c77facafc090d524086d64bb83ee', u'542982fef76b941ec285a96e910407b3', u'Boxsets:'] 2019-05-29 19:00:21.775 T:3795833712 NOTICE: EMBY.helper.wrapper -> Processing Teledyski: d114c77facafc090d524086d64bb83ee 2019-05-29 19:00:22.316 T:3795833712 NOTICE: EMBY.objects.musicvideos -> UPDATE mvideo [183/9339/1] 563852: #ShotoverG1giveaway - 2019-05-29 19:00:22.387 T:3795833712 NOTICE: EMBY.objects.musicvideos -> UPDATE mvideo [183/9340/2] 563853: #ShotoverG1giveaway - 2160p 2019-05-29 19:00:22.414 T:3795833712 NOTICE: EMBY.database -> ERROR:: type: <type 'exceptions.ValueError'> value: year is out of range 2019-05-29 19:00:22.415 T:3795833712 NOTICE: EMBY.database -> [emby] 2 rows updated. 2019-05-29 19:00:22.419 T:3795833712 NOTICE: EMBY.database -> ERROR:: type: <type 'exceptions.ValueError'> value: year is out of range 2019-05-29 19:00:22.421 T:3795833712 NOTICE: EMBY.database -> [video] 22 rows updated. Any suggestions on how to fix it?
  9. jasonborn

    Selected subtitle not always showing

    Hi all, I am a satisfied user of Kodi and Emby. I run 2 Kodi's both on a seperate Pi 3b+ and have an Emby Server running also on a Pi 3b+ All the Pi's are 24/7 on so I quick fire up a movie when I want to, and alway's have the latest up-to-date movie information in Kodi. The thing is, that frequently when I start a movie, and select a subtitle with Kodi Kore app on my smartphone, the sub is not showing. A reboot is needed to fix this. Anyone has anyone experienced this before? Kind regards, - Libreelec 9.0.2 - Emby 4.1.12 - Emby server 4.2.0.40
  10. Somewhat related to this prior request ( https://emby.media/community/index.php?/topic/44010-emby-theater-external-player-custom-messages-particularly-for-media-stubs-and-tags/ ) it would be nifty and useful to add support for the Kodi Media Stub embedded data, which would then be displayed when a user tries to Play a Media Stub item. From http://kodi.wiki/view/media_stubs <discstub> <title>Alternative Title</title> <message>Message to be displayed</message> </discstub> Thanks! PS - If this is something you might like to see implemented, be sure to "Like" this top/first post (as well as any subsequent posts in this thread that highlight particular aspects of what you are interested in) -- "Liking" the top/first post helps the Devs to know how much interest there is in a given Feature Request.
  11. Hi, in Emby i can play the Trailers from TheMovieDB, but in Kodi is now (1-3 Updates) no trailer available anymore. I've synced with addon mode and native mode, no trailer. Emby Server is version 4.2.0.26 and Emby for Kodi is 4.1.3 on Odroid C2 with Coreelec 9.0.x nightly (Kodi 18.3), i don't know on what side the problem is, Emby or Kodi. In the movie.nfo file is the trailer located like <trailer>plugin://plugin.video.youtube/?action=play_video&videoid=xC4hiSAprpM</trailer> So, in Emby works all correct like this thread https://emby.media/community/index.php?/topic/71039-kodis-built-in-trailer-feature-not-working-with-emby-without-emby-trailer-addon/?hl=trailer Thanks in advance
  12. Hello, after a good hour of research and tests, I fail to operate the automatic playback of the next audio track. Everything worked without worries before, but since yesterday, no way. I have not made any updates or changes to the configuration to cause this. Seeing that I could not unblock the problem, I uninstalled and reinstalled in new, without success. I am now under Kodi 18.3, Embycon 1.9.18 and Embuary 18.7.13. I did the manipulations as described in this post:https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=2ahUKEwjjjaLIxK3jAhVEG80KHSi1AGQQFjAAegQIBBAB&url=https%3A%2F%2Femby.media%2Fcommunity%2Findex.php%3F%2Ftopic%2F55271-embycon-kodi-addon-play-the-next-video-automatically%2F&usg=AOvVaw3Kz3UNpmXSMkpWm_kQzfRt and in this one: https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&cad=rja&uact=8&ved=2ahUKEwjcpLPAyK3jAhVVYs0KHV2GA5UQFjADegQIAxAB&url=https%3A%2F%2Fdiscourse.coreelec.org%2Ft%2Fplay-next-track-broken%2F2304&usg=AOvVaw3XEtZWNP1Z5mV5fLIFLP4P I do not know if it's actually due to embycon or it's a bug from kodi, but I would appreciate some help. Which's pretty wierd is that work perfectly for the tv shows section, or "Videos" in settings... Thank you
  13. Hi, I‘ve one point which I really don’t understand. Why is neither EMBY nor Plex using the most advanced Player out there, I mean Kodi, in their Apps? I think Kodi is open source, so the player itself isn’t closed while it‘s really the most advanced Player out there. If it would be used in the apps a lot of transcode could be avoided and it would be very easy to enjoy the media. So, why is this so? Are there regulatory restrictions or any other technical issues? I just want to know. P.S. I am aware that EMBY has a good implementation in Kodi but I like some other features of the app. So I‘m switching between Kodi and the nativ android app on my shield depending ont the thing I want to see.
  14. twistedvincent

    Local Host Not Showing In Dashboard

    I'm trying get Emby successfully installed in Kodi 18.2 but I can't manually connect a server because no local host is showing in my server dashboard so I'm stuck. Here's my dashboard info: Also I tried to have Kodi scan for a server and it found mine but wouldn't connect. I'm a total noob to Kodi and the error/log file stuff baffles me. Any help would be appreciated
  15. Hi Guys Long time user but new to the AndroidTV App, have always used Emby for Kodi but since becoming a supporter have switched to the native app and am enjoying the experience apart from one gripe. If I try to play a movie with Atmos/TrueHD it will transcode the audio to AC3, however, if I switch to using an External Player via App options and play the movie via Kodi it plays as expected with full Atmos/TrueHD sound. Kodi doesn't switch back to Emby cleanly after stopping playback though so it's not a solution I can continue to use... Any ideas why the Mibox will not pass the Atmos track through native app playback? Xiaomi Mi Box 3 MDZ-16-AB > Onkyo TX-NR545 > Crappy 1080p TV Have attached Server log and transcode log. Played movie first using the internal player, then stopped and switched -inside Emby app- to External Player (Kodi) and started playback again. Hoping I can get this working, let me know if you need any more info embyserver.txt ffmpeg-remux-7ac4bbd3-693c-4a20-b990-e917a6ac56d5_1.txt
  16. nealhamilton

    Access kodi from Emby UI.

    I've been using kodi and nextpvr for awhile now but I'm liking emby UI and how it's manages the libraries and it's streaming engine. The fact now it has dvr capabilities would allow me to replace nextpvr. The only issue is I use a lot of addons in kodi and there's not the same in emby, instead of porting a bunch of plugins for emby would it be possible to port in the kodi addon framework into emby natively; this way we could just put in the kodi repo/s and install the plugin via the emby server dashboard. Can the emby core be expanded by a plugin that would allow this or would it have to be ported into the core? This would be awesome so we'd not have to install kodi just to use the addon framework. If this isn't possible can a plugin be made that would allow us to access the kodi plugins from an installed kodi server from the emby UI. I know there's a plugin that allows us to access emby from kodi but I'd much rather use the emby UI for everything instead of switching UI/s all the time. Emby theater is really nice and I'd like to control my media center in whole from one single UI.
  17. mondowondo

    Move Kodi "played" status to Emby server

    I searched and found several frustrated people who tried to move from Kodi database to Emby Server. Frustrated, because they wanted to move the Played / Unplayed status from Kodi to Emby. I figured out a way to do it! I'm not a programmer and have no idea if this will work for you but here is how I did it. I have Unraid running kodiheadless docker and mariadb as a central db. This allowed us to have multiple instances of Kodi running off the same central database. FireTV in the living room, Win10 in the office, Android cell phone, all running Kodi but accessing the central database on the unraid server. The only reason this may be important is that I have a mariaDB. From win10 MySQL Workbench I connected to the MariaDB instance to run a query to return anything with a playcount greater than zero, then exported this to a .csv file. SELECT path.strPath, files.strFilename FROM files, path WHERE files.idPath = path.idPath AND files.playcount > 0 I cleaned up the spreadsheet, removing unnecessary lines and characters using find/replace. Added a column of "<PlaylistItem><Path>" in front of each entry and "</Path></PlaylistItem>" at the end of each line. Using the Emby UI, I created a new playlist by adding one random movie to it. Then edited the new \EmbyServer\data\playlists\All Played [playlist]\playlist.xml file to remove that random movie and replaced it (copy/paste) with all the movies/TV episodes I want to mark as watched. So now the playlist file looks like this. <?xml version="1.0" encoding="utf-8" standalone="yes"?> <Item> <ContentRating>Rated PG</ContentRating> <Added>3/17/19 9:10:38 PM</Added> <LockData>false</LockData> <LocalTitle>All Played</LocalTitle> <RunningTime>1092</RunningTime> <Genres> <Genre>Action</Genre> <Genre>Adventure</Genre> <Genre>Comedy</Genre> <Genre>Drama</Genre> <Genre>Family</Genre> <Genre>Crime</Genre> <Genre>Romance</Genre> <Genre>Fantasy</Genre> </Genres> <Studios> <Studio>Columbia Pictures Corporation</Studio> <Studio>New Line Cinema</Studio> <Studio>Kentucky Fried Theatre</Studio> <Studio>Plan B Entertainment</Studio> <Studio>Marv Films</Studio> <Studio>20th Century Fox</Studio> <Studio>O Entertainment</Studio> <Studio>Grand Army Entertainment</Studio> <Studio>TriStar Pictures</Studio> </Studios> <PlaylistItems> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Karate Kid, The (1984).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Keanu (2016).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Kentucky Fried Movie, The (1977).avi</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Kick-Ass (2010).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Kick-Ass 2 (2013).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Kingsman The Secret Service (2015).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Knight And Day (2010).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Knight's Tale, A (2001).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Kung Pow (2002).avi</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/Labor Pains (2009).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Kids/Movies/Labyrinth (1986).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Kids/Movies/Labyrinth (1986).mkv</Path></PlaylistItem> <PlaylistItem><Path>/mnt/user/TowerVideo/Movies/A-Team, The (2010).mkv</Path></PlaylistItem> </PlaylistItems> <Shares> <Share> <UserId>1</UserId> <CanEdit>true</CanEdit> </Share> </Shares> <PlaylistMediaType>Video</PlaylistMediaType> </Item> After editing and saving the new playlist.xml file I restarted the emby server and Scan All Libraries (each a few times). After a while the updated library was visible. I don't know what triggers the UI to pull the info from the playlist.xml file but eventually it did. Then it was EASY to click the check mark on the playlist to mark everything in the playlist as played. PS. So far this only worked one time... I tried creating another playlist so I could mark more items as watched, so far it hasn't been able to read the new playlist.xml file EDIT: SUCCESS!!! With help from those below and Luke on the server forum I figured out my problem was not every <...Item> was valid. The & in a few items acted as an XML comment so I replaced it with $amp;. I also had two items that were messed up because it was a 'part1' and 'part2' but the SQL returned them on the same line. I also finished this using a collection.xml instead of playlist because in the GUI there is an option to rescan the collections without rescanning the whole library (faster).
  18. Saviq

    Playback looping on its own

    Hey, Since the intermediate "emby-loading.mp4" switch all my video playback seems to be looping without me asking for it. The same item will play over and over again. "Play next" is disabled, if I go to the play queue it shows repeat being disabled, it seems the plugin is just looping the playback around. Please find attached a plugin debug log. Software versions: 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Starting Kodi (18.1 Git:18.1-Leia). Platform: Linux ARM 32-bit 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Using Release Kodi x32 build 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Kodi compiled 2019-02-27 by GCC 8.2.0 for Linux ARM 32-bit version 3.14.29 (200221) 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Running on CoreELEC (official): 9.0.1, kernel: Linux ARM 64-bit version 3.14.29 aarch64 2019-03-04 18:37:34.994 T:4090716960 NOTICE: FFmpeg version/source: 4.0.3-Kodi … 2019-03-04 19:54:19.907 T:3810521968 NOTICE: EMBY.entrypoint.service -> Version: 4.0.11b Thank you! emby-loop.log
  19. I'm looking for some under the hood info - from advanced users that have built a multi-client environment. My existing system is pretty basic, as I like to keep things simple, and in the event of a problem I don't have to muck through a maze of "how did I do this again?" I have a Synology NAS - that provides all the storage for my media files. Using all the built-in 'add video' sources within Kodi - linked to my NAS. I've also enabled a MariaDB10 app, on the NAS to support the MySql feature within Kodi - so all my clients (multiple FireTV & PCs (Windows,MAC)) sync to the same dB. This all works quite well, however a bit complex configuration on each client to maintain if I make the same change or add a source, etc. So here's where my questions begin... I've installed Emby Server on one of my Synology NAS boxes, actually, this particular one is an Xpenology device. I chose that one because it has much more HP than my official Synology boxes. I've also purchased a lifetime Emby account. I've built a Kodi (18.1) client on one of my Fire TV televisions - from scratch. Installed the basic Addons that I require for my use ... OpenSubtitles, Trakt, Lyrics & Backup. I've also just installed Emby/con - addons. After running and testing - to the Kodi local dB all seems to be working well. I'm not sure how the updates to the local client dB updates, and if there is by directional flow when it comes to Trakt data, and partially watched positions, etc... Would it be better to switch to using the Mysql as a common dB source for my clients as I did before? or just stick to the Kodi local dB file dB? I'm thinking using the Mysql dB would be a bit redundant and just complicate things. That I should just let Emby do all the dB work, and keep the local client dBs updated. any HELP, feedback and or comments would be welcome. So far I'm pretty impressed with Emby server.
  20. I have Kodi Leia 18 and have installed addons and not a single one shows any content on both my MacBook and my Fire stick. I enabled unknown sources and have an VPN service, I've tried eeeverything..how do I fix this? Thanks(:
  21. Saviq

    Subtitles not shown on resume

    Hey, with the switch to the intermediate "emby-loading.mp4" video, I started seeing subtitle issues when resuming playback - I can switch between them, but they're not shown. I've seen a handful of similar topics, but none treated about playback resume, which is the only breaking case for me. Please find attached the plugin debug log. Software versions: 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Starting Kodi (18.1 Git:18.1-Leia). Platform: Linux ARM 32-bit 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Using Release Kodi x32 build 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Kodi compiled 2019-02-27 by GCC 8.2.0 for Linux ARM 32-bit version 3.14.29 (200221) 2019-03-04 18:37:34.994 T:4090716960 NOTICE: Running on CoreELEC (official): 9.0.1, kernel: Linux ARM 64-bit version 3.14.29 aarch64 2019-03-04 18:37:34.994 T:4090716960 NOTICE: FFmpeg version/source: 4.0.3-Kodi … 2019-03-04 19:54:19.907 T:3810521968 NOTICE: EMBY.entrypoint.service -> Version: 4.0.11b Thanks! subtitles-resume.log
  22. I really like using Emby to manage my movie and TV libraries, and to provide remote access to them. When I'm home, for various reasons, I use Kodi as my player, rather than one of the Emby apps. I use the Emby for Kodi add-on, the Embuary skin, and configure them for native/direct play over nfs to my nas. I have both Emby and Kodi configured to store subtitles alongside the video files. Emby is configured to download external srt subtitles from opensubtitles.org for movies and episodes that have neither external subtitles already, nor subtitles encoded into the video file itself. I only need/use English subtitles. All of that works beautifully most of the time. When doing direct-play in Kodi, it will use the embedded subtitle found in the video container file, or the external *.eng.srt file downloaded and saved by Emby. When I notice that subtitles are out-of-sync with the video, one of the nice ways I can solve that within Kodi is to use their mechanism for picking and downloading a new srt subtitle file from opensubtitles.org. I pick a file that I think will more closely match the video file I have, download it, and continue to play the video to test the new subtitles. It usually only takes one or two tries to find a subtitle file that is perfectly synchronized. However, Emby saves subtitle files as *.eng.srt and Kodi saves them as *.en.srt. So, after choosing and downloading an in-sync subtitle file in Kodi, I now have two subtitle files on disk--one that is in sync with the video (named *.en.srt) and one that is out-of-sync with the video (named *.eng.srt). Although Kodi saves the file using the 'en' tag, it seems to also recognize files that use the 'eng' language tag in their names. It seems to prefer the *.en.srt file if available, either because that's the naming standard it uses when it saves, or because that file is newer, I'm not sure which. I'm not sure how Emby decides which file to use as the English subtitle file when streaming, but if it picks the same one it saved, it will be the out-of-sync one. All of this would be solved though, if Emby and Kodi both used the same language tag standard. Kodi seems to be using either ISO 639-1, or the IANA Language Subtag Registry. I'm not sure which because both of those use 'en' as the code for English. Emby, on the other hand, seems to be using ISO 639-2. There are quite a few different standards for language tags. See the tags I've given this topic for some of them. The only guidance I could find when searching for preferred standards for this type of use came from W3C in this document: https://www.w3.org/International/questions/qa-lang-2or3 Their recommendation is to use the IANA Language Subtag Registry instead of ISO 639-1 or ISO 639-2. If that's the case, then I think Kodi is correct to us 'en' instead of 'eng'. Thanks so much for any help with this. I hope that Emby and Kodi can get on the same page for which language tags to use when naming srt files.
  23. Howdy people! Using Kodi on an Android TV, Emby serving stuff from a docker container runing on an Unraid server. Kodi ver. 18.0, Emby server 4.0.1.0, Emby for Kodi 4.0.5.; manual login on server (no passwords, only usernames), no EmbyCon. Ever since Kodi got updated to 18.0, I'm unable to add user(s) to session in Emby for Kodi menu. When I select the option, most of the time nothing happens, rarely a "spining circle" appears for a second or two but nothing after. If I restart Emby for Kodi (from the same menu) after selecting the "add user..." option - the window for selecting the user to add appears just as the "restart option" is selected, but no users appear listed there. The user selection from Kodi login appears to work fine (the watched/started etc shows/movies are set correctly for each user) but the addition doesn't work. Haven't seen anyone complaining about that, so it's either a rarely used function or I'm the only one who uses it and has problems with it. Does anyone have any ideas? Thanks in advance.
  24. wickedlemon

    Kodi Companion and shared libraries

    I've now got Emby set up and working with Kodi, but now I need to introduce extra Kodi profiles. In the past I've used shared libraries for some Kodi accounts and I'm wondering how I should deal with this? Will Kodi Companion sync properly with two profiles sharing a library and syncing with Emby? Or would I bet better off putting up with the extra overhead and add one Emby user for each Kodi profile even though this will just mean duplicating data?
  25. jpichie

    Kodi Companion does not stay enabled

    Good afternoon, I have been having issues with emby since Version 4 by the looks of it. I have had the same issue on Kodi 17.6 - 18 RC - 18 Stable with Emby for Kodi. When I first install Emby for Kodi, it goes through the prompts, I connect to my server, enable artwork caching, whole tomatoes, etc. I sync my TV and Movies. When I check my Emby settings, they look correct, Companion is enabled, artwork caching is enabled, I hit OK and close out. When I open up Kodi again, I get prompted to enable artwork caching and to turn on Companion. This happens EVERYTIME, and these settings get disabled again after I restart Kodi (or they never get enabled). Any help would be appreciated. This has happened exactly the same way on 4 separate systems, 3 of which were fresh installs. kodi.log
×
×
  • Create New...