Jump to content

Search the Community

Showing results for tags 'https'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hello I am using Emby in a docker container that I am trying to set up with https connection. I was able to set it up but it took me some time since I was trying to use certificates generated by letsencrypt. Once I generated the cert and private key with it i ran openSSL to create the pfx file. The "issue" that I am having is that Chrome is not giving the connection a green light. I would really like to get the green verified https since my family will be using it and I dont want to explain to everyone what this means.
  2. Let's Encrypt offers free automated SSL certificates that are valid for 3 months. They can then be automatically renewed without any user interaction. https://letsencrypt.org/ I would like to see this implemented as either a plug in or natively in emby server to solve the issues with using https specifically with the android and Chromecasts but also the media browser. This would allow easy to use signed and valid https connections and would take the hassle out of renewal every 3 months.
  3. Hello all, I'm having an issue with the android app. When I try to connect to my server over HTTPS I get a connection failure error. If i switch to HTTP it works. HTTPS was working fine three-four days ago, when I installed the certificate on the phone. I've tried with the domain and the IP, both don't work. How should I proceed? App version: 2.5.55 Server version: 3.0.5781.5 Server OS: Ubuntu
  4. Hello guys! I'm new to Emby but I like the program very much! I have one little problem, can't get the HTTPS function to work: the server doesn't generate a SSL certificate. But that is not my question today. Because my HTTPS is not working, I no stream via HTTP to locations outside my home network. Normally I don't stream a lot, but now, because of the holidays I do stream a lot. My question, is it safe to stream over HTTP. Because everyone can watch what I'm streaming would I not be marked for piracy or something? Because I'm up-and-downloading files that are protected by copyright. thanks in advance, kind regards, Ronnie van der Woude
  5. I have an SSL Certificate (letsencrypt.org) that is signed by - issuer=/C=US/O=Let's Encrypt/CN=Let's Encrypt Authority X1 This cert is in turn signed by - issuer=/O=Digital Signature Trust Co./CN=DST Root CA X3 I create a pkcs12 from the pem files using the following command openssl pkcs12 -export -out cert.pfx -in cert.pem -inkey privkey.pem -certfile x3chain.pem -nodes Where cert.pem is the certificate, privkey.pem is the private key and x3chain.pem is the issuing certificate (Let's Encrypt) and the rootCA (DST Root CA X3). I then provide this certificate to Emby and start it. When I connect from Chrome on desktop, everything is OK ("Let's Encrypt Authority X1" is trusted by Desktop Chrome). When I try to access using Android, "Let's Encrypt Authority X1" is not a trusted CA, however "DST Root CA X3" is. If the chain were being sent properly, the chain of trust is in tact and it should work. Unfortunately, Emby is not sending the full chain, just the top certificate (mine) and the "Let's Encrypt Authority X1" certificate. I have seen references to a Mono bug, however that bug was fixed in April of 2014. To try and answer some questions ahead of time, here is the output from the top of my log file - 2015-12-21 22:06:02.5739 Info Main: Emby Command line: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/pbi/emby-amd64/bin/ffmpeg -ffprobe /usr/pbi/emby-amd64/bin/ffprobe -programdata /var/db/emby-server Operating system: Unix 9.1.0.0 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/db/emby-server Mono: 4.2.1 (Stable 4.2.1.124/39edf24 Sun Dec 20 05:03:56 UTC 2015) Application Path: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe 2015-12-21 22:06:02.8854 Info App: Application version: 3.0.5781.8 2015-12-21 22:06:02.9482 Info App: Application configuration: {"EnableUPnP":true,"PublicPort":8097,"PublicHttpsPort":8096,"HttpServerPortNumber":8097,"HttpsPortNumber":8096,"EnableHttps":true,"CertificatePath":"/etc/ssl/cert.pfx","EnableInternetProviders":true,"IsPortAuthorized":true,"SeasonZeroDisplayName":"Specials","SaveLocalMeta":true,"EnableLocalizedGuids":true,"DisableStartupScan":true,"EnableUserViews":false,"EnableLibraryMetadataSubFolder":true,"PreferredMetadataLanguage":"en","MetadataCountryCode":"US","SortReplaceCharacters":[".","+","%"],"SortRemoveCharacters":[",","&","-","{","}","'"],"SortRemoveWords":["the","a","an"],"MinResumePct":5,"MaxResumePct":90,"MinResumeDurationSeconds":300,"RealtimeLibraryMonitorDelay":40,"EnableDashboardResponseCaching":true,"EnableDashboardResourceMinification":true,"DashboardSourcePath":"","MergeMetadataAndImagesByName":true,"EnableStandaloneMetadata":true,"ImageSavingConvention":"Compatible","MetadataOptions":[{"ItemType":"Book","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Movie","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Disc","Limit":0,"MinWidth":0},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"MusicVideo","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Disc","Limit":0,"MinWidth":0},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Series","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":1,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"MusicAlbum","ImageOptions":[{"Type":"Backdrop","Limit":0,"MinWidth":1280},{"Type":"Disc","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"MusicArtist","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Logo","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"BoxSet","ImageOptions":[{"Type":"Backdrop","Limit":1,"MinWidth":1280},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Thumb","Limit":1,"MinWidth":0},{"Type":"Logo","Limit":1,"MinWidth":0},{"Type":"Art","Limit":0,"MinWidth":0},{"Type":"Disc","Limit":0,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":[],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Season","ImageOptions":[{"Type":"Backdrop","Limit":0,"MinWidth":1280},{"Type":"Primary","Limit":1,"MinWidth":0},{"Type":"Banner","Limit":0,"MinWidth":0},{"Type":"Thumb","Limit":0,"MinWidth":0}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Episode","ImageOptions":[{"Type":"Backdrop","Limit":3,"MinWidth":1280}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]},{"ItemType":"Video","ImageOptions":[{"Type":"Backdrop","Limit":3,"MinWidth":1280}],"DisabledMetadataSavers":["Emby Xml"],"LocalMetadataReaderOrder":[],"DisabledMetadataFetchers":[],"MetadataFetcherOrder":[],"DisabledImageFetchers":[],"ImageFetcherOrder":[]}],"EnableAutomaticRestart":true,"PathSubstitutions":[{"From":"/mnt/Data","To":"\\\\**redacted**"}],"WanDdns":"home.**redacted**.com","UICulture":"en-us","PeopleMetadataOptions":{"DownloadActorMetadata":true,"DownloadDirectorMetadata":true,"DownloadProducerMetadata":false,"DownloadWriterMetadata":false,"DownloadComposerMetadata":false,"DownloadOtherPeopleMetadata":false,"DownloadGuestStarMetadata":false},"FindInternetTrailers":true,"InsecureApps9":["Chromecast","iOS","Unknown app","iPad","iPhone","Windows Phone"],"SaveMetadataHidden":false,"ContentTypes":[],"EnableAudioArchiveFiles":false,"EnableVideoArchiveFiles":false,"RemoteClientBitrateLimit":0,"DenyIFrameEmbedding":true,"EnableLibraryMonitor":"Auto","SharingExpirationDays":30,"DisableXmlSavers":true,"EnableWindowsShortcuts":false,"EnableVideoFrameByFrameAnalysis":false,"EnableDateLastRefresh":false,"Migrations":["5767.1"],"EnableDebugLevelLogging":true,"EnableAutoUpdate":true,"SystemUpdateLevel":"Release","LogFileRetentionDays":3,"RunAtStartup":false,"IsStartupWizardCompleted":true,"EnableCustomPathSubFolders":true} 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Plugins.PushBulletNotifications, Version=3.0.5810.33455, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Api, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.WebDashboard, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Model, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Common, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Controller, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Providers, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Common.Implementations, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Server.Implementations, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.MediaEncoding, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Dlna, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.LocalMetadata, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.XbmcMetadata, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.IsoMounting.Linux, Version=1.0.5131.24779, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Server.Mono, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:02.9590 Info App: Loading MediaBrowser.Server.Startup.Common, Version=3.0.5781.8, Culture=neutral, PublicKeyToken=null 2015-12-21 22:06:03.0498 Info SqliteUserRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/users.db 2015-12-21 22:06:03.1207 Info SqliteFileOrganizationRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/fileorganization.db 2015-12-21 22:06:03.1282 Info AuthenticationRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/authentication.db 2015-12-21 22:06:03.1399 Info SyncRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/sync14.db 2015-12-21 22:06:03.2005 Info ImageMagick: ImageMagick version: ImageMagick 6.9.0-10 Q8 amd64 2015-12-11 http://www.imagemagick.org 2015-12-21 22:06:03.2314 Info ImageProcessor: ImageProcessor started with 4 max concurrent image processes 2015-12-21 22:06:03.2845 Info App: FFMpeg: /usr/pbi/emby-amd64/bin/ffmpeg 2015-12-21 22:06:03.2845 Info App: FFProbe: /usr/pbi/emby-amd64/bin/ffprobe 2015-12-21 22:06:03.2857 Info SharingRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/shares.db 2015-12-21 22:06:03.3144 Info ActivityRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/activitylog.db 2015-12-21 22:06:03.3293 Info SqliteDisplayPreferencesRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/displaypreferences.db 2015-12-21 22:06:03.3419 Info SqliteItemRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/library.db 2015-12-21 22:06:03.3546 Info SqliteProviderInfoRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/refreshinfo.db 2015-12-21 22:06:03.3665 Info SqliteUserDataRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/userdata_v2.db 2015-12-21 22:06:03.3755 Warn App: ffmpeg is missing decoder h264_qsv 2015-12-21 22:06:03.3766 Info SqliteNotificationsRepository: Sqlite 3.8.8.3 opening /var/db/emby-server/data/notifications.db 2015-12-21 22:06:03.3834 Warn App: ffmpeg is missing decoder mpeg2_qsv 2015-12-21 22:06:03.3909 Warn App: ffmpeg is missing decoder vc1_qsv 2015-12-21 22:06:03.7160 Info HttpServer: Calling ServiceStack AppHost.Init 2015-12-21 22:06:06.1848 Info ServiceStackHost: Initializing Application took 3025.623ms 2015-12-21 22:06:06.2013 Info ServerManager: Loading Http Server 2015-12-21 22:06:06.2041 Info HttpServer: attempting to load pfx: /etc/ssl/cert.pfx 2015-12-21 22:06:06.2506 Info HttpServer: Adding HttpListener prefix http://+:8097/ 2015-12-21 22:06:06.2511 Info HttpServer: Adding HttpListener prefix https://+:8096/ 2015-12-21 22:06:06.6102 Info App: Core startup complete If I am misreading the Mono commit and that bug is still unfixed in 4.2.1 I'll try and hack master together on FreeBSD and see what I get
  6. tobby

    Can't play Blu Ray

    Hi I can't play BluRays. Their file structures are just the same as on the original discs, just copied to hdd. BluRay ISOs aren't working either, but the logs are for blu-ray-copies, not blu-ray-isos. When doing it over HTTPS: Log: http://xbmclogs.com/p4kc0mjus Error 1: http://xbmclogs.com/p4kc0mjus#line-287 Error 2: http://xbmclogs.com/p4kc0mjus#line-291 Followed by: http://xbmclogs.com/p4kc0mjus#line-312 And when doing it over HTTP: Log: http://xbmclogs.com/pmctpcyfo Error: http://xbmclogs.com/pmctpcyfo#line-256 Anything I can do?
  7. tobby

    No connection via https

    Hi Yesterday I set up my Emby server. It is working great and I can use the WebApp though my Browser via http on port 8096 and via https on port 8920. Both is working. At first I used the self-signed certificate, but then I generated a valid certificate from "let's encrypt" for it, which is also working. But when using the Android-app or the Amazon-FireTV-Stick-App both can't connect to the https port. However, both are working great when using the http-port. I also tried both, using the self signed certificate and the let's encrypt one. Doesn't change anything... So: Http and Https are both working with the web app, but on Android and on the FireTV-Stick there is only http working. Any ideas what I may do wrong or what may be wrong with the apps?
  8. https://letsencrypt.org/ the free certificate authority it in public beta now and allows everybody to get valid free SSL certificates. It would be nice to have support for getting SSL certificates via their ACME protocol directly from emby. This would make it really easy for people to setup secure access to the server from the internet.
  9. TheRealGrale

    Connecting Roku Emby externally over HTTPS

    Ok so I'm not a network novice, but clearly I am missing something here. I've searched the forums and have only found mention of using http port 8096 for external connections. None of the documentation/posts I have seen specifically speak of using https, which I would like to use if possible. The firewall on my 2008r2 server has the proper ports all opened, the exe is also allowed access, and the port forwarding rules are in effect on my modem. On the web console of EMBY it even reports "Remote Access: https://xxx.xxx.xxx.xxx:8920. Now when I go to my EMBY Roku app, it doesn't matter if I enter https://:xxx.xxx.xxx.xxx or just the IP and then use 8920, the Roku will not connect, it gives the following error: We were unable to connect to this server. Please make sure it is running and try again. HTTPS works from a web browser, but it will not work from the EMBY Roku, nor the EMBY client for android. Now I know all is working on the server/firewall side because if I go back and connect using the IP and use 8096, boom, connects and works both Roku and droid clients. I am using the latest release of EMBY server, as of this writing, and I have removed and reinstalled the EMBY Roku client just to be sure. Can the roku connect over HTTPS and if so what am I missing? Thanks guys! P.S. EMBY ROCKS!
  10. hello, I have a concern with Emby on Ubuntu server, when accessing http Emby, videos read this without problems, but when I accessed via https, I misread Video window, yet all my videos are in MP4 format. I do not understand what's going on! thank you in advance for your support
  11. strixd

    ssl certificates help please

    Having a bit of an issue with ssl. I enabled https, point my web browser to my server, everything works fine. When I try to use my android clients, there are no images, and playback does not work. My server gives this error: 2015-09-25 19:00:01.3045 Error - HttpServer: Error in ProcessAccept *** Error Report *** Version: 3.0.5724.5 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /mnt/config Operating system: Unix 3.19.3.200 Processor count: 12 64-Bit OS: True 64-Bit Process: True Program data path: /mnt/config Mono: 4.0.3 (Stable 4.0.3.20/d6946b4 Thu Aug 13 12:39:47 UTC 2015) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe The authentication or decryption has failed. System.IO.IOException at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: Mono.Security.Protocol.Tls.TlsException The authentication or decryption has failed. at Mono.Security.Protocol.Tls.RecordProtocol.ProcessAlert (AlertLevel alertLevel, AlertDescription alertDesc) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.ReceiveRecord (System.IO.Stream record) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.SslServerStream.EndNegotiateHandshake (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 I am trying to migrate from plex to emby, love emby so far. Can't wait to use it outside my network! Thanks! ( It seems other people have had this issue as well: https://github.com/MediaBrowser/Emby/issues/1097 )
  12. Hey everybody, I want to use my emby server when not at home and wanted to use it with ssl encryption. I use the standard 8096 port for non-secured access, and port 8920 for https. When I am in my local network, http://ip-of-emby-sever:8096 in the browser sends me to emby, however, https://ip-of-emby-sever:8920 doesn't, Chrome prints out that the connection is not private and does not connect to emby. In the settings of the emby server, the external WAN port is set both local and public to 8920, "Report https as external address" is checked. Am I missing something?
  13. Hi, I am running Kodi 15.1 with Emby 1.1.13. I am trying to play a 3D movie in 2D/monoscopic mode but it's not working. In Kodi, the 3D icon is shown next to the movie and looking in the metadata manager, I can see Emby has correctly marked this movie as 3D. When I am on the same network and "Play from http instead of SMB" option is unchecked in plugin settings, Kodi gives me a choice between 2D/3D and everything is fine. But when I am connecting to my server over the Internet and I have checked the "Play from http instead of SMB" option or I have this option checked and I am on the same network, the movie is not being detected as 3D in Kodi and it just plays as is. My two cents is that the 3D status of the movie is being detected by Kodi from the filename (which works over smb but not http) instead of an entry in MyVideo93.db (I assume this is where the 3D icon is coming from). I should also note I am using https. Please chime in...
  14. studio-jurdan

    https, wan and....

    hello, i'm sory but i realy can't acces to emby server outside my home, the wiki and help are not up to date so they are talking about option i can't find in this distro (the last) why HTTS first? it make ssl alert to all the browsers that is no cool for my guest ??? why another port for internet that the one for intranet? if i try to connect with emby account, sometime i can see my server inb the "list" BUT it ca'nt connect. i had open the wan port in windows seven firewall AND in my router firewall i also made a DMZ zone for the server internal IP on my router i also tryed with a "NOIP dns server. but ALL are working when i"m in the same wifi connection but if i change the isp the wifi conecting to the webrowser, it' all stoped can't connect to the server. here..https://github.com/MediaBrowser/Wiki/wiki/Hosting%20Settings i see a wan place to put my noip dns server but it is not on my server thios stuff ?????
  15. icthusman1

    8.0.67.1 won't connect to HTTPS

    The new client will not connect to my server via HTTPS. I am able to use a web browser (on an external network) and connect via HTTPS. The only way I was able to get the WP client to connect was to turn off the server setting "Report HTTPS as external address" so that it went back to using the HTTP port. The connection info that the WP client showed me was correct, it was the right hostname and port. Please help Scott!
  16. fc7

    Hardening Emby login

    After using Emby for a while I'm so happy with it that I decided to publish it to the Internet so I can listen to my music when I'm away, without needing to VPN home. I'm publishing Emby behind a Squid reverse proxy, using SSL termination. Meaning: Internet Client -----HTTPS SSL connection-----> | Squid reverse-proxy -----PLAIN HTTP-----> Emby | INTERNET | LAN Now I have a couple of questions/features requests regarding publishing Emby to the "evil" Internet: Is there any known issue/concern that I should be aware off that is not too relevant while Emby is only visible in the LAN but that can be dangerous if Emby is visible from the Internet? I'm worried about brute force attacks. Is it possible to enable a captcha on the login screen so for example after 3 failed logins the user will need to validate the captcha to try to login again? About the login screen: would it be posible to have a configuration parameter in Emby to "harden" the login form like for example disabling autocomplete on the username field? Is it possible to enable a configuration parameter to hide all users from the login screen, server wide, instead of doing it on user basis only? How does the "in-network sign-in" with the easy pin code works? How does Emby know that the user is logging in from the LAN or from the Internet? What happen if the user is in the Internet but Emby is behind a reverse-proxy in the LAN (all requests comes from the LAN IP of the proxy)? Would Emby check the X-Forwarded-For HTTP header if the reverse-proxy provides it? I know these are a lot of questions and some things may not be even implemented right now, but if they are not, maybe they can be a good idea to implement in the near future since they can help us to protect our server for the "evil" Internet. Cheers
  17. Hi, Have tried to find a description on how to control when SSL can be forced. Is it possible to force SSL for all remote connections, but allow normal http for all connection from the local network? Under Dashboard->Advanced->Hosting it has a "Force https as external address", and I guess it's this checkbox I wonder if works as described above? Not much need for SSL locally, but would be great to be able to force it for everything coming and going to the outside network. -Florux
  18. Glaive

    Ubuntu & HTTPS

    Hi all, I've been trying to figure out why HTTPS doesn't work on my ubuntu server for the last few days and no luck unfortunately. Does anyone know (devs would be super useful) if this is supported on Linux (Ubuntu) at all? On my windows PC it works fine however on my Ubuntu server (14.04 LTS) and VM (Ubuntu 14.04.2 LTS) the connection is dropped almost instantly (I don't even see the page). EDIT: I have firewall turned off Telnet doesn't even seem to work either, everything you see in the terminal. Please see the below screenshots. Thank you! Chrome Firefox Telnet Any help would be greatly appreciated! Otherwise I'm really enjoying MediaBrowser and will likely use it over Plex if this feature works for me! Cheers, Glaive
  19. Hi, I've read a lot about SSL / https support in Media Browser, but cannot find the settings for it anywhere - there's also no mention of it in the wiki. Could someone please point me in the right direction? -Florux
  20. I am running MB3 server through omv (debian). I updated and got the latest Beta with https support. I have a StartSSL cert I use for external access in omv. I created a pfx and have loaded it into MB3, but I get an exception when MB3 tries to load the certificate. 2015-02-12 22:07:51.0890 Info - HttpServer: Adding HttpListener prefix http://+:8096/ 2015-02-12 22:07:51.0890 Info - HttpServer: Adding HttpListener prefix https://+:8920/ 2015-02-12 22:07:51.0954 Info - HttpServer: attempting to load pfx: /media/1a89ed0c-663f-4cc7-84fe-f841d48fb61e/MediaBrowser/dean1120.net.pfx 2015-02-12 22:07:51.1126 Error - HttpServer: Exception loading certificate: /media/1a89ed0c-663f-4cc7-84fe-f841d48fb61e/MediaBrowser/mine.pfx *** Error Report *** Version: 3.0.5518.3 Command line: /opt/mediabrowser/MediaBrowser.Server.Mono.exe -programdata /var/lib/mediabrowser Operating system: Unix 3.2.0.4 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/mediabrowser Mono: 3.12.0 (tarball Sat Feb 7 19:12:57 UTC 2015) Application Path: /opt/mediabrowser/MediaBrowser.Server.Mono.exe Input data cannot be coded as a valid certificate. System.Security.Cryptography.CryptographicException at Mono.Security.X509.X509Certificate.Parse (System.Byte[] data) [0x00000] in <filename unknown>:0 at Mono.Security.X509.X509Certificate..ctor (System.Byte[] data) [0x00000] in <filename unknown>:0 at System.Security.Cryptography.X509Certificates.X509Certificate2.Import (System.Byte[] rawData, System.String password, X509KeyStorageFlags keyStorageFlags) [0x00000] in <filename unknown>:0 at System.Security.Cryptography.X509Certificates.X509Certificate2.Import (System.String fileName, System.String password, X509KeyStorageFlags keyStorageFlags) [0x00000] in <filename unknown>:0 at System.Security.Cryptography.X509Certificates.X509Certificate2..ctor (System.String fileName) [0x00000] in <filename unknown>:0 at SocketHttpListener.Net.EndPointListener.LoadCertificateAndKey (System.Net.IPAddress addr, Int32 port, System.String certificateLocation) [0x00000] in <filename unknown>:0 InnerException: System.Security.Cryptography.CryptographicException Input data cannot be coded as a valid certificate. at Mono.Security.X509.X509Certificate.Parse (System.Byte[] data) [0x00000] in <filename unknown>:0 2015-02-12 22:07:51.5959 Info - ServerWMC: Config IP: mediacenter (192.168.15.11), Config Port: 9080 2015-02-12 22:07:51.5978 Info - ServerWMC: Running in Linux, Linux path to mounted RecTV directory: /media/1a89ed0c-663f-4cc7-84fe-f841d48fb61e/RecordedTV 2015-02-12 22:07:51.8799 Info - App: Core startup complete 2015-02-12 22:07:51.9846 Debug - PortMapper: Starting NAT discovery 2015-02-12 22:07:52.0385 Info - Dlna: SSDP service started 2015-02-12 22:07:52.0581 Debug - Dlna: Starting alive notifier Does anyone have any idea on what might be wrong? Thanks,
×
×
  • Create New...