Jump to content

Search the Community

Showing results for tags 'completed'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Valodia De Seynes

    2.3.0 - External subtitles issue

    Hello, ​ ​It seems there is an issue with the Emby for Kodi app concerning external subtitles. Whenever I play a video in Kodi, it doesn't detect any subtitles for it even though the server-side has detected the subtitles. ​ ​This doesn't happen when the subtitles are part of the video file (like .mkv). Also, I'm pretty sure the issue arose with version 2.3.0 because I remember being able to play external subtitles with version 2.2.19. ​ ​I'm not certain any log is necessary but I can provide them if you need them.
  2. You guys are developing the live tv section beautifully, however one key function is missing. That's the "Wake for recordings". So much effort has been put into the recording functionality but it doesn't work if the server is sleep. I've read that this functionality is low priority, but how can it be if, once again, the recordings won't work if the server is sleep? Here's to trying to bring that functionality to light within the emby server without plugins.
  3. Valodia De Seynes

    2.3.0 - 'ascii' codec can't encode character

    Hi, today I updated Emby for Kodi from 2.2.19 to 2.3.0 and it now seems that I cannot use KODI to play my files stored on the Emby server. Here's my log: ​ 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> ConnectionManager response status: 200 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> connectToAddress https://multimedia.serveur.lan:443 succeeded 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> begin connectToServer 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> beginning connection tests 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> testing connection mode 2 with server Centre Multimédia 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> tryConnect url: https://multimedia.serveur.lan:443/emby/system/info/public 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> ConnectionManager response status: 200 19:10:32 T:140263802783488 NOTICE: EMBY.connectionmanager -> calling onSuccessfulConnection with connection mode 2 with server Centre Multimédia 19:10:32 T:140263802783488 NOTICE: EMBY.ga_client -> ERROR:: ('/usr/lib/python2.7/json/__init__.py', 190, 'dump', 'fp.write(chunk)') 19:10:32 T:140263802783488 NOTICE: EMBY.ga_client -> ERROR:: UnicodeEncodeError - __init__.py:190()(fp.write(chunk)) 19:10:32 T:140263802783488 NOTICE: EMBY.ga_client -> GA: {'el': '__init__.py:190()(fp.write(chunk))', 'cid': 'fe13fa8ef0efca215354148f5d5b3ba1', 'sr': '1920x1080', 'v': '1', 'ea': 'UnicodeEncodeError', 'ec': 'Exception', 'an': 'Kodi4Emby', 'ul': 'French', 't': 'event', 'av': '2.3.0', 'tid': 'UA-85356267-1', 'aid': '1', 'ua': 'Kodi/16.1 (Linux)', 'ds': 'plugin'} 19:10:32 T:140263802783488 NOTICE: EMBY.ga_client -> ERROR:: initializer for ctype 'int(*)(int, X509_STORE_CTX *)' must be a pointer to same type, not cdata 'int(*)(int, X509_STORE_CTX *)' 19:10:32 T:140263802783488 NOTICE: EMBY.service -> ERROR:: 'ascii' codec can't encode character u'\xe9' in position 14: ordinal not in range(128) Traceback (most recent call last): File "/home/marc/.kodi/addons/plugin.video.emby/service.py", line 43, in <module> service.service_entry_point() File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/service_entry.py", line 94, in service_entry_point initialsetup.InitialSetup().setup() File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/initialsetup.py", line 40, in setup if self._server_verification() and settings('userId'): File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/initialsetup.py", line 90, in _server_verification {'ssl': self.user_client.get_ssl()}) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connectmanager.py", line 74, in get_server self.state = self._connect.connectToAddress(server, options) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 321, in connectToAddress server = self.connectToServer(server, options) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 503, in connectToServer return self._testNextConnectionMode(tests, 0, server, options) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 562, in _testNextConnectionMode return self._onSuccessfulConnection(server, result, mode, options) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 576, in _onSuccessfulConnection return self._afterConnectValidated(server, credentials, systemInfo, connectionMode, True, options) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 599, in _afterConnectValidated self.credentialProvider.getCredentials(credentials) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/credentials.py", line 72, in getCredentials self._set(data) File "/home/marc/.kodi/addons/plugin.video.emby/resources/lib/connect/credentials.py", line 57, in _set json.dump(data, outfile, indent=4, ensure_ascii=False) File "/usr/lib/python2.7/json/__init__.py", line 190, in dump fp.write(chunk) UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 14: ordinal not in range(128) 19:10:32 T:140263802783488 NOTICE: EMBY.service -> Forcing shutdown 19:10:32 T:140263802783488 NOTICE: EMBY.service_entry -> ======== STOP EMBY ======== ​I've got the full log here and I've also taken the liberty to put online a full debug log. I've also got issues on other computers about the ssl certificate of my server even though Emby for Kodi is not set to verify the certificate it seems that it does it anyway and fails (same result even if I set it to verify and give it the root certificate). ​ ​All of these issues only started appearing after I updated Emby for Kodi to version 2.3.0 ​Hope you can help, thanks!
  4. yotamN

    Hebrew subtitles not showing

    ​When I use the Kodi extension I can't use my Hebrew subtitles, I only see (external) in the name of the subtitles and I couldn't use the Hebrew subtitles. I know that Hebrew works in Kodi because Hebrew subtitles from OpenSubtitles works but sometimes I download subtitles separately and I can't use them from Kodi, the Emby Android TV app worked with the Hebrew subtitles, how can I fix that?
  5. lja

    Emby for Kodi Freezes

    @@Angelblue05 During syncing process Kodi freezes at "Gathering Albums". Have reinstalled Kodi and Kodi for Emby. No change. Kodi 16.1 Emby Server 3.0.7200 https://www.dropbox.com/s/n3v9rrixq2l6ogz/kodi.log?dl=0 Hope this is the right log. Any help? Thanks.
  6. Hey I'm getting this error on current Emby for Kodi beta. Already tried to manual sync and to repair database. The repair task went through fine, but on every Kodi start I'm getting the error. 01:37:13 25.198072 T:1696388000 NOTICE: EMBY.librarysync -> ERROR:: need more than 1 value to unpack Traceback (most recent call last): File "/storage/.kodi/addons/plugin.video.emby/resources/lib/librarysync.py", line 860, in run self.run_internal() File "/storage/.kodi/addons/plugin.video.emby/resources/lib/librarysync.py", line 914, in run_internal uptoDate = self.compareDBVersion(currentVersion, minVersion) File "/storage/.kodi/addons/plugin.video.emby/resources/lib/librarysync.py", line 845, in compareDBVersion currMajor, currMinor, currPatch = current.split(".") ValueError: need more than 1 value to unpack This happens on LibreELEC 7.0.2 on a Raspberry Pi 3, Emby server (3.0.8200) is being accessed externally. Best regards
  7. The deleted episodes are gone from the PC grom where I have watch them but when I open Kodi on my PC in the bedroom thos deleted episodes are still there but playable because they are no longer on the server because I have deleted them already. THis goes vice versa. Watched episodes are 1,2 and 3. Can this be fixed? Here is an example of the same serie with episodes on two different PC's with Kodi. Kodi log pc image 1 Kodi log pc image 2 Server log
  8. Emby for Kodi 2.2.45 Kodi 16.1 After deleting the addon and deleting all emby addon folders in Kodi I attempted a reinstall of the Beta addon. I kept getting dependency missing errors. They were: plugin.video.emby.movies/ 2016-08-02 19:52 - plugin.video.emby.musicvideos/ 2016-08-02 19:52 - plugin.video.emby.tvshows/ 2016-08-02 19:52 After manually installing them from zip from http://embydata.com/downloads/addons/xbmb3c/kodi-beta-repo/ I was able to install 2.2.45 beta. Just thought I should let you know.
  9. Hi there, There is a nice "send message" function build into Emby's Server 'Now Playing' screen, which allows to send a text message to any online client. I will be really glad if you can help me to change the default display time (3~4s) used by Kodi to make it a little bit longer since the message disappears way too quickly for my use. Seems that the GUI.ShowNotification function of Kodi allows to define the display time as an optional parameter. Thank you for your help Best regards
  10. Hi I was just resetting my local database and it came up with a sync error and said to report it on the forum: :06:54 T:10752 NOTICE: EMBY.default -> plugin.video.emby started 17:06:54 T:10752 NOTICE: EMBY.default -> Parameter string: ?content_type=video 17:06:54 T:10752 NOTICE: EMBY.default -> plugin.video.emby stopped 17:06:54 T:5332 NOTICE: Thread BackgroundLoader start, auto delete: false 17:06:54 T:10752 WARNING: CPythonInvoker(18, C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\default.py): the python script "C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\default.py" has left several classes in memory that we couldn't clean up. The classes include: class XBMCAddon::xbmcaddon::Addon 17:07:04 T:5092 NOTICE: EMBY.utils -> Resetting the Emby database. 17:07:22 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"LibraryChanged","Data":{"FoldersAddedTo":[],"FoldersRemovedFrom":[],"ItemsAdded":[],"ItemsRemoved":[],"ItemsUpdated":["7f45658987a1247b0734dff1fcc15ab3"]}} 17:07:22 T:4972 NOTICE: EMBY.librarysync -> Queue update: [u'7f45658987a1247b0734dff1fcc15ab3'] 17:07:23 T:10096 NOTICE: EMBY.ga_client -> ERROR:: ('C:\\Users\\Stuart\\AppData\\Roaming\\Kodi\\addons\\plugin.video.emby\\resources\\lib\\embydb_functions.py', 251, 'getMediaType_byId', 'self.embycursor.execute(query, (embyid,))') 17:07:23 T:10096 NOTICE: EMBY.ga_client -> ERROR:: OperationalError - embydb_functions.py:251(no such table: emby)(self.embycursor.execute(query, (embyid,))) 17:07:23 T:10096 NOTICE: EMBY.ga_client -> GA: {'el': 'embydb_functions.py:251(no such table: emby)(self.embycursor.execute(query, (embyid,)))', 'cid': '5ed473ca4b05facfb5071324fe04d438', 'v': '1', 'ea': 'OperationalError', 'ec': 'Exception', 'an': 'Kodi4Emby', 'ul': 'English', 't': 'event', 'av': '2.2.51', 'tid': 'UA-85356267-1', 'aid': '1', 'ua': 'Kodi/15.2 (Windows NT)', 'ds': 'plugin'} 17:07:23 T:10096 NOTICE: EMBY.librarysync -> ERROR:: no such table: emby Traceback (most recent call last): File "C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\librarysync.py", line 860, in run self.run_internal() File "C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\librarysync.py", line 967, in run_internal self.incrementalSync() File "C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\librarysync.py", line 799, in incrementalSync items = emby_db.sortby_mediaType(listItems) File "C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\embydb_functions.py", line 266, in sortby_mediaType mediatype = self.getMediaType_byId(itemid) File "C:\Users\Stuart\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\embydb_functions.py", line 251, in getMediaType_byId self.embycursor.execute(query, (embyid,)) OperationalError: no such table: emby 17:12:42 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"ScheduledTaskEnded","Data":{"StartTimeUtc":"2016-10-19T15:00:22.0963493Z","EndTimeUtc":"2016-10-19T16:12:40.6645488Z","Status":"Completed","Name":"Refresh Guide","Key":"RefreshGuide","Id":"3c6a16ed7db828baeb3bb3c1cff74810"}} 17:13:19 T:2420 NOTICE: Thread JobWorker start, auto delete: true 17:13:46 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"LibraryChanged","Data":{"FoldersAddedTo":[],"FoldersRemovedFrom":[],"ItemsAdded":[],"ItemsRemoved":[],"ItemsUpdated":["d76204ad069e50e6b6312a674626c820"]}} 17:13:46 T:4972 NOTICE: EMBY.librarysync -> Queue update: [u'd76204ad069e50e6b6312a674626c820'] 17:14:10 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"ScheduledTaskEnded","Data":{"StartTimeUtc":"2016-10-19T16:14:01.6103543Z","EndTimeUtc":"2016-10-19T16:14:08.4117363Z","Status":"Completed","Name":"Cloud & Folder Sync","Key":"ServerSync","Id":"d2abaeece4b6c98c888bb52f637151a8"}} 17:14:54 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"LibraryChanged","Data":{"FoldersAddedTo":[],"FoldersRemovedFrom":[],"ItemsAdded":[],"ItemsRemoved":[],"ItemsUpdated":["a51db5d08a2f0e98eef29b22aa17d594","5411624a02ba46b54eadfb17a67eea65"]}} 17:14:54 T:4972 NOTICE: EMBY.librarysync -> Queue update: [u'a51db5d08a2f0e98eef29b22aa17d594', u'5411624a02ba46b54eadfb17a67eea65'] 17:17:39 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"ScheduledTaskEnded","Data":{"StartTimeUtc":"2016-10-19T15:10:41.0533103Z","EndTimeUtc":"2016-10-19T16:17:37.7258273Z","Status":"Completed","Name":"Scan media library","Key":"RefreshLibrary","Id":"2d67d886717cdade18d9640d4ebbb9cb"}} 17:21:44 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"ScheduledTaskEnded","Data":{"StartTimeUtc":"2016-10-19T16:21:42.6529457Z","EndTimeUtc":"2016-10-19T16:21:42.7621415Z","Status":"Completed","Name":"Convert media","Key":"SyncPrepare","Id":"12e0945fba4d49b1f482115adb46c341"}} 17:22:17 T:4972 NOTICE: EMBY.downloadutils -> SessionId: 8dd02693756c7deacd5b5fa4e7f81243 17:22:37 T:4972 NOTICE: EMBY.websocket_client -> Message: {"MessageType":"ScheduledTaskEnded","Data":{"StartTimeUtc":"2016-10-19T16:22:24.8493227Z","EndTimeUtc":"2016-10-19T16:22:35.9716949Z","Status":"Completed","Name":"Download missing subtitles","Id":"2c66a88bca43e565d7f8099f825478f1"}} 17:23:23 T:4160 NOTICE: Thread JobWorker start, auto delete: true 17:23:43 T:5092 NOTICE: EMBY.default -> plugin.video.emby stopped After clicking OK on the error dialogue box it then proceeded to ask the normal questions about clearing the artwork cache and if you wanted to delete the add-on settings etc. Upon re-opening Kodi it has started its initial sync process. Thanks.
  11. thunbrakuble1

    Having Playback Failure

    Emby v.2.2.46 Kodi v. 2.4.9 Recently I have been having difficulty when going to play a video file. It is giving me a Playback failure and I can't figure out how to fix the problem. The message I am receiving is the following "Playback Failed.....One or more items failed to play. Check the log for more information about this message." There is a second error message that pops up on the upper right hand part of my screen that says "Emby error....Check the log for more information" Please refer to the Kodi Logfile Uploader. https://paste.ubuntu.com/23320937/ Thank you in advance for your help! UPDATE!!!!: I've tried to do this both on Wifi and with an Ethernet cable connected to my Chrome box and it does not work. I've also noticed that this only occurs on my Chrome Box. I have a Fire TV box on another TV and it is not giving me this error message or issue. The Fire TV box is using wifi no Ethernet cable if that helps.
  12. I have Emby Server Version 3.0.7300.0 on my Synology with Trakt pluggin 3.0.6021.26344. I noticed some time ago, that although Trakt is tracking and showing an item being watched, if that item is deleted with the Emby option of "Offer delete after playback" then that item is not logged as watched on Trakt. If I select the No option to delete, and then manually delete the item straight away, it will show as watched on Trakt. Is there a solution to still have both working as they should?
  13. Looking at the source: https://github.com/MediaBrowser/plugin.video.emby/blob/04d4865074994e6f71243b7d62847897371264e5/resources/lib/websocket_client.py Line 221 player.setSubtitleStream(index - audio_tracks - 1) I think "index" should be "emby_index" because index hasn't be initialized yet. This raises an exception. I haven't yet tried replacing it. There may be other changes to make it work. I also think there may be an issue in websocket.py, due to the error that is logged: (Note, ignore the lne 228, it should be 221. I modified the file to log some other information while I was troubleshooting). 20:50:25 T:55460 ERROR: No handlers could be found for logger "root" 20:50:25 T:55460 ERROR: File "C:\Users\XXX\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\websocket.py", line 894, in _callback 20:50:25 T:55460 ERROR: callback(self, *args) 20:50:25 T:55460 ERROR: File "C:\Users\XXX\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\websocket_client.py", line 91, in on_message 20:50:25 T:55460 ERROR: self._general_commands(data) 20:50:25 T:55460 ERROR: File "C:\Users\XXX\AppData\Roaming\Kodi\addons\plugin.video.emby\resources\lib\websocket_client.py", line 228, in _general_commands 20:50:25 T:55460 ERROR: player.setSubtitleStream(index - audio_tracks - 1)
  14. totalhavoc

    Emby - Please sign in screen????

    All of the sudden today everyone's profile in kodi, other than mine, is getting authentication errors. Sometimes it pops up with an emby box asking the user to log in. If I type the user's password it does not work. None of our profiles/users are setup for emby connect. They just have local passwords for external direct access. My understanding was clients on the local network would not need to login. We never have before. I'm really not sure why it is doing this except that the addon updated again recently.
  15. I would like to know the status of this problem? The infamous multi-pathing. Im also in this situation, and its simply impossible to pool anything else together. As im using a synology 1813+ with volumes comprised of raid0 made upon 2 HDD's at a time. Kodi team solved this 2 years ago +-, how come emby replicates de problem all over again? Furthermore, my situation is curious, via the emby webbrowser, all is ok, for example, I have Arrow tv show on 2 HDDs, and via the webbrowser it only shows 1 record (this is because it was already addressed server side). Problem is when i go to my kodi machines, 2 or more entries, depending on how many hdd's i have the tv show stored in. server side (addressed) As you can see, ARROW is ok via the web browser: Client side (not addressed), KODI addon messes up: This would be really useful if addressed, as its keeping me and many others from switching to emby...unfortunately When this is addressed, not only will I adopt emby as I will become lifetime member gladly. EDIT: I think this has to do with folder structure ID pulls at the time database is built. I can dig a little more if needed. It only poins one way. EDIT2: Metadata being stored either centrally as well as locally (e.g. on media folders) makes no effect or noticeable change. Because the problem must really be ID pulls from database...
  16. Hi guys. Something sudden broke with my Emby Syncing. Movies, Music and Music Videos all sync ok but as soon as it starts syncing TV it crashes. The versions are as follows. Python Version: 2.7.9 (default, Aug 13 2016, 18:15:29) GCC 4.9.2 Platform: Linux/RPi KODI Version: 16.1 EMBY Version: 2.2.37 Emby server Version 3.0.7200.0 I've attached a debug log. Odd that is just for TV shows but hmmm only started a few days ago. Any help is appreciated. Thanks. kodi.emby-crash-tv.log
  17. Hi! When i start my NUC with libreelec jarvis build it starts my NAS with OMV which needs about 60 seconds before its up and running. Now i did try to login via emby connect .... i´ve set the emby addon to a 75 seconds timeout before trying to connect btw since i´ve tried connecting to my server via emby connect i get the emby connect login screen where i have to ender my username und password. i can skip this choosing cancel but i what to tun it off completely. I´ve already set the connection method in the kodi addon from emby connect to manual, so does some1 have any advice for me? thanks in advance! b0mb
  18. lanos

    never ending sync

    I added a new show to emby this weekend but Kodi refused to show it listed. I did manual syncs, library repair and in a last ditch effort I did a library reset. Now Emby for kodi is broke for me, it does a sync whenever I start up kodi makes it to 99% on added box sets and just stays there. If I try to do anything with Kodi once emby hits that 99% for boxsets all of Kodi crashes and I have to use task manager to close out. I let it sit for 12 hours and it still was just stuck 99% boxset. I already had the art cache at 25 so i dropped it all the way down to 5 still nothing I've attached my most recent log hopefully someone can help me with this I have people here freaking out, without their Kodi/Emby we may have to be forced to actually talk to one another. oh and I'm on emby for kodi ver 2.2.19 and kodi Jarvis, I think I'm not exactly sure how to tell which version I have but I know my last manual update was jarvis kodi.log
  19. hey there are still two crucial mistranslations to German in Emby settings -> Extras: The setting in the first row: Deaktiviere erweiterte Bilder (z.B. CoverArt) means "disable enhanced images" So the setting should be: Aktiviere erweiterte Bilder (z.B. CoverArt) And the first row setting at Emby -> settings -> Extras -> Server messages: Unterdrücke Server-Verbindungsmeldungen beim Starten means "suppress server connection message on startup" so it should be: Aktiviere Server-Verbindungsmeldungen beim Starten Regards
  20. denethor

    Sync fails with specific album

    Hi there My music library sync fails every time during the sync of specific album. Since the sync fails to complete it starts all over again with the 2200 movies 100 shows. (I have cleaned up my database lately) This is with the SMPC 16.4-2 and problem started with the add-on version 2.2.36. Or may be this related with the server since I am on dev branch. (Version 3.1.6111.23367) Relevant part of the log: (It keeps trying to sync album named "Dealing with it") 18:32:15 T:1434593584 NOTICE: EMBY.itemtypes -> ADD album itemid: 934f9efd634c2150f7f44fda96036507 - Name: The Best Of Me 18:32:15 T:1434593584 NOTICE: EMBY.itemtypes -> ADD album itemid: 5dc52e0915efc9eec31d68aa884a79ce - Name: Full Speed Ahead 18:32:15 T:1434593584 NOTICE: EMBY.itemtypes -> ADD album itemid: e812f8223cfd768a4e677877504192d9 - Name: Dealing With It 18:32:15 T:1434593584 NOTICE: EMBY.downloadutils -> ERROR:: === Bad status response: 400 === 18:32:16 T:1434593584 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<-- - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS! Error Type: <type 'exceptions.KeyError'> Error Contents: ('Type',) Traceback (most recent call last): File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/default.py", line 159, in <module> Main() File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/default.py", line 69, in __init__ self._library_sync(mode) File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/default.py", line 147, in _library_sync librarysync.ManualSync().sync() File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/resources/lib/librarysync.py", line 1092, in sync return self.fullSync(manualrun=True) File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/resources/lib/librarysync.py", line 326, in fullSync completed = self.music(embycursor, musiccursor, pDialog) File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/resources/lib/librarysync.py", line 1522, in music process[data_type][1](embyitem) File "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/resources/lib/itemtypes.py", line 1927, in add_updateAlbum if artist['Type'] == "MusicArtist": KeyError: ('Type',) -->End of Python script error report<-- 18:32:16 T:1434593584 WARNING: CPythonInvoker(35, /storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/default.py): the python script "/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.emby/default.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE,N9XBMCAddon9xbmcaddon5AddonE,N9XBMCAddon4xbmc7MonitorE 18:32:16 T:1394280752 ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting plugin://plugin.video.emby/?mode=manualsync 18:32:16 T:1394280752 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.emby/?mode=manualsync) failed 18:32:16 T:1434593584 NOTICE: EMBY.default -> plugin.video.emby started 18:32:16 T:1434593584 NOTICE: EMBY.default -> Parameter string: 18:32:16 T:1434593584 NOTICE: EMBY.default -> plugin.video.emby stopped 18:33:08 T:1433528624 NOTICE: EMBY.default -> plugin.video.emby started Album artist contains dots (D.R.I.) if this is rings any bell. If you also require server logs let me know.
  21. bartolomesoriano

    Movie Year Not Syncing to Kodi

    I am using the latest plugin version from the GitHub develop branch (version 2.2.36), and Kodi Krypton Beta 2. Did a new installation of the plugin with an empty Kodi db. None of the movies have the year populated, even though it is correctly populated in Emby server. TV Shows are not affected. My Emby server is running on Windows 10, and it is version 3.1.6113.25198.
  22. negativzeroe

    Continuous failure on HTPC.

    I've been trying for two weeks to get this app to work. I have a mini slim desktop with a basic GPU in it and have tried Kodibuntu, LibreELEC and OpenELEC. I set it up. Everything through Kodi works perfectly except Emby. What happens is, I will go through the whole setup and everything will be glorious for a few episodes or movies. Then the next time I try to play something I get an error. The only way I have found to fix this is to completely remove Kodi, including all the app files, and completely re-install and re-setup the entire thing. Even if I just reset the database. I cannot get the startup wizard to prompt for my server and if I enter the IP and user manually I cannot get it to prompt for the password. It's like the app just up and dies after a few plays. It's not anything having to do with Internet or anything else because I can stream Exodus with no problem (as shown in log). Also, I can get to my server with my phone both by local IP address and outside the network using my router's DDNS. Just to point out, I'm using beta but have tried with the app from the stable repo and get the same results. Also the IP address in the log is NOT my server and is not the IP that is in the app settings so I have no idea where it is getting that from.... Attached is the latest log right after resetting the database. I'm hoping this is enough to diagnose the issue. I'll begin completely removing and reinstalling and wait for this to happen again and grab that log as well. Edit. This is actually on the Fire TV which also has the issue, my bad got them mixed up. kodi.log
  23. Emby (server or the plugin) insists on transcoding all music files when trying to direct stream. In plugin Beta 2.2.30 on Jarvis 16.1 I have the following settings: * Playback Mode: Addon * Enable Music library: On * Direct stream music library: On * Play from HTTP instead of SMB: On Server is beta branch 3.1.156.0 The bitrate limits on both Kodi-plugin and the server are way up (100 Mbps). Most of my library are 160Kbps .mp3 files that I have ripped my self. Kodi plays them fine as such, but when using Emby with the above settings, they get transcoded to 128Kbps .mp3 files. How can I avoid transcoding the music if the bitrate is way below the limits and Kodi is able to direct stream it unmodified? BR, Andy777 Edit: Attached transcoding log. Server log doesn't show any messages about need to transcode. ipmasked_ffmpeg-transcode-4d215c0c-cc56-4c89-ae65-d03df0461b4d - Copy.txt
  24. So these Leelboxes work great with Emby for Android TV but there's a problem: the controller/app doesn't really allow for basic DVR capability while playing back. The remote is pictured well here: https://www.amazon.com/Leelbox-android-installed-Amlogic-Android/dp/B013DONLX2 What I'd recommend during playback is: D-Pad Up/Down = change channel (disabled when playing back a recording) D-Pad Left = jump back 10 seconds D-Pad Right = jump forward 30 seconds OK = pause See the guide button to the lower left of the D-Pad? Make that button open up the on-screen display and the D-Pad behave as it does now. Better yet, and for maximum compatibility, allow users to press a key, and Emby record it, for defining the button to open the on-screen display switching the behavior of the D-Pad. This is useful for remotes that don't have that specific info button.
  25. So have installed the latest beta emby and titan skin, and I get the thred has exited. But think I have found the problem, if I have a library with say "lucifier" season 1 in it saved as a box set and in my recorded tv library I have recorded an episode of the new season of lucifier I get thread has exited. If I remove one of the lucifier folders from either boxsets or recorded tv it will continue to scan until it hits the next box set that I am currently recording a new season of. Any help would be great Oh and using kodi 17 krypton
×
×
  • Create New...