Jump to content

Search the Community

Showing results for tags 'Roku'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. The Roku Emby app needs to be able to remember the password once logged into. Its very annoying to have to put login info in all the time. So annoying in fact that I use a separate DLNA app that a password is not required. I like the app but its just annoying to constantly entering password especially when the Roku does not have a keyboard. Please allow the Roku app to remember password and logins, Thanks!
  2. Greetings, I have NextPVR set up with my HDHR Connect to schedule and record live TV. The initial recording is a .ts file and for an hour show it was huge like 7-8 GB. Using ffmpeg I re-encoded the .ts file to an mp4 using these options: -c:v libx264 -preset slow -crf 26 -c:a aac. I've used these options before with mkv files and the resulting mp4 is able to be direct played on my xbox one, which is what I thought would happen here. Anyway, heres the problem: I try and play the new mp4 on my xbox one and it says I'm transcoding. (bitrate setting on app is set to auto) Weird. So I do my best to troubleshoot and try to play the same file on emby theater on my win 10 pc where my server lives. Still transcoding. So then I hook up my Dad's roku just to see what would happen and it direct streamed it with no buffering or stopping at all. For some reason the transcoding would not allow it to just play all the way through. So I guess I have two questions: 1) Why does my xbox have to transcode something i know it can direct play since all of my movies are mp4 and direct plays them with no problems. 2) If it can't direct play the file why can't the xbox direct stream it like the roku did which was great quality and no buffering/stopping? Attached are the server, remux, transcode log files, plus the media info for the file at hand. Thanks, server-63621468333.txt ffmpeg-remux-f42d1527-bb15-40a4-b4c3-e638d82bd902.txt ffmpeg-transcode-ab54a10c-5673-4f4d-8c50-e0e3b49e60c8.txt
  3. What this solves: 1. On demand creating Roku Bif files recursively through sub folders, using Emby Servers naming scheme. (Simple Dialog Interface, Command Line and SendTo {must be compiled}). 2. Scheduled Bif file creation, 3. Allow networked computers to work on shared folders to speed things along. Only limiting factors are the speed of your network & the number of systems connected. Notes: The Folders this script is to run against must be on ether a local or network mapped drive, as the script isn't setup to handle UNC paths. Also checkout the concurrent version further down in the thread. Requirements: AutoIt FFMpeg Roku SDK Instructions: Install AutoIt and set it to execute scripts when double clicked. Create a folder somewhere...lets call it "Creat BIF" just to be unimaginative. Now inside "Create BIF" create a sub folder called "Bin". Now extract the contents of FFMpeg's "Bin" folder into your new "Bin" sub folder. Now extract "biftool.exe" from the Roku SDK into your new "Bin" sub folder. Now going back into "Create BIF" folder Right Click on it's background and select "New\AutoIt v3 Script" from the context menu, and Rename it "Create BIF.au3" Now Right Click "Create BIF.au3" & select "Edit Script" from the context menu. Now paste the following code into: Now save the script & execute it by double clicking it and then select the folder holding your videos that you wish to process. Now go do something else, this will take a while...maybe a great while depending on the number of videos you have. The script will notify you when it's done...and if you're currious as to if it's still running there should be a icon in your system tray that looks like a blue "A". Past that you can start your Task Manager and you should more than likely see FFMpeg running in the background. By default this will create 320px aspect correct BIF files, if you wish to create 240px or any other size you'll need to edit line 7. Example: from $iVideoWidthSize = 320 to $iVideoWidthSize = 240 Update 1: I decided to let FFMpeg do all the calculations for resize...which result in a massive code reduction. Update 2: Added passing folders via command line. This is mostly aimed at adding SendTo context menu support. 1. Right Click on "Create BIF.au3" and select "Compile Script (x86)" from the context menu 2. ALT + Left Click on "Create BIF.exe" and Drag to create a shortcut...rename to remove ".exe" from the file name 3. Cut & Paste shortcut to your SendTo folder: %APPDATA%\Microsoft\Windows\SendTo\ Now you don't even need to hunt down the script when you need it. Update 3: Added very simplistic scheduling based on a 24 hour clock. Currently you can not start on one day and end on the following. Only one time block allowed per day. The script now produces an INI that can be edited "Create Bif.ini" If you choose to use the scheduling the script needs to be compiled. Once compiled & the INI edited to your liking, open up a console in the script folder. Then enter: "Create Bif.exe" ScheduleNew Now new tasks have been created in the Windows Task Scheduler. To remove tasks enter: "Create Bif.exe" ScheduleDelete To not have a task scheduled for a day, set the start time and end time to be the same. Update 4: Command Line now supports both Folders & Files...thus making a SendTo shortcut more useful. Update 5: Added auto SendTo shortcut creation...only happens if script is compiled. To trigger this...simply use the executable once...you don't even have to actually process a file. If you don't want this feature simply delete the code on and between lines 17 & 25 (currently) Update 6: Now allows only one instance to run at a time, to prevent bogging down your system. This applies to Command Line and GUI, but not Task Scheduler...as the Task Scheduler should only have one instance anyways. This allows you to cue up several folders\files to be processed, even though they are in very different locations. Update 7: Made it easier for the script to clean up after it's self.
  4. kuebs

    Roku Media Center Menu not working

    Hello all, This is a weird problem. I have two Roku 3s, one on LAN and one in WiFi. Suddenly I can no longer get the opening ROKU channel view where I see my Emby server, folders, folder artwork, content, last added all the other nice cool features of Roku for Emby. This Roku channel was why I chose Roku over Amazon Fire or other alternatives. I have reset my Router, Server, WiFi router. I have tried an older version of the Roku Emby plugin. I have tried the beta version of the Roku Channel. I still connect just fine to the server and can use the search function to find specific titles. But I no longer see the really nice browsing menu. This has just started a few days ago. I am running a stable version of Emby for WMC and my Windows 8 is patched and up to date. This is affecting my family life as my daughter and wife can no longer find their favorites and browse through our videos and movies. Is anyone else experiencing this? Does anyone know what happened?
  5. funwithmedia

    Questions about Media Stubs

    Greetings, I'm thinking of trying out Emby, and I have a few questions. I was wondering if it is possible to create custom Media Stub Flags? For example, I have online content spread across providers like Vudu and Disney Movies Anywhere, and it'd be nice to be able to aggregate those titles within Emby along with my local videos (even though I'd have to open up Vudu to actually view a given video). Is there an "advanced settings" method of adding to the list of recognized Flags (eg, movie1.vudu.disc)? This would of course only be useful if I can also define what would be displayed in accordance with the custom flag (eg, so instead of DVD for a .dvd. flag, display Vudu.com, or whatever corresponds to the custom flag I've set). How does Emby for Roku handle Media Stubs, and does the interface display anything in response to the Flag (eg, DVD, Blu-ray, TV, etc.)? In my current setup I have the IMDB id (eg, tt2975590) in the database for any of my titles that exist in IMDB, so it would be possible for me to extract that into filenames. Would including that in the filename (whether for an actual video file), or for a Media Stub, help Emby with accurately identifying titles? And if so, what would be the recommended syntax for where in the filename to put that? Thanks much!
  6. bikermiker

    Roku 3 Loading Please Wait

    Hi, I'm having a problem when playing back video on my Roku 3. For the 1st 10-15 seconds the video will stop at least once (sometimes several times) and display the message "Loading, Please Wait" along with a loading status bar. I'm new to Emby. I tried messing with some settings but nothing seemed to change this. It almost seems like it is not buffering enough somewhere. My network is 300Mbps N. I haven't had this problem using other services but I don't think those services were transcoding to H.264.... I'm not sure though. I am using a new Synology DS916. Emby Version 3.0.8500.0-1. Log
  7. JohnsLibrary

    Emby for Roku Live TV

    It was working fine for months and in the last 2 weeks, live tv retrieve progress bar moves a little then just brings back the play screen. All my other media on the emby server plays fine including recorded tv shows. Only live tv is broken. I'm using an HDHomeRun Prime with cable card. Emby server is running on Win 7 with ServerWMC. Box is an Intel I7 CPU.
  8. Dear emby-friends, I use for a very long time Plex on Linux etc. Now discovered emby, but I can't get roku to delete any file doesn't matter what user or group and even giving thme all 777 rights. If I followed the guide for plex, it just worked, trying anything possible for emby, it just doesn't want to work. Need help to get emby to be able to delete files with Roku. In a test I had it before and it was working, now, I can't get it done doesn't matter what. Need help and a fresh mind
  9. tallguy.hackett

    Server frequently crashes on Raspberry Pi 2

    I am running Emby on a Raspberry Pi 2 by following the instructions here and it had been working well until a couple months ago. For the last couple months when I go into the Roku Emby app and select an episode of a TV show to watch and after I select "Play" the loading screen appears and then the Roku Emby app would quit and take me to my Roku home screen. Further attempts to open the Roku Emby App didn't connect to my Emby Server. I used PuTTY to ssh onto my raspberry pi and ran the top command to see if the emby server process was still running. It had stopped running and I then restarted the service with sudo service emby-server start this would start the service and I was able to get the Roku Emby app to open and connect to my server again. Going to the same TV episode and selecting play would either play the episode or give the same behavior where Roku goes to the Roku home screen and the server crashes. It has happened with almost every episode of all the TV series I have tried watching in the last couple months and various movies. Bottom line is I can get a movie or TV episode to play if I go through the restart process enough times. It is very annoying though having to boot up my laptop every time I want to watch a show so that I can restart the server until it works. I have received the same behavior inside Firefox with the only message being "An error occurred" displayed before the server crashes. Also sometimes the server has just crashed during the middle of the night not while any media is being played. I just try to access Emby either through the Roku or Firefox and the server is not up and running. I SSH into the server run top and sure enough the server process is not running. I'm able to start the server again without incident but then I'll still run into the issue described above. Log files attached for the most recent occurrence. ffmpeg-sub-extract-81c3aa92-fa21-48fc-8903-a5df2d9ec365.txt server-63611126557.txt unhandled_4a24fc76-7e73-4145-b6f4-ded92629b557.txt
  10. So I installed the Roku Server Plugin a while back, it's been running long enough to create BIF files for my entire library. However, whenever the scheduled task runs, after it terminates it leaves behind zombie ffmpeg processes that as far as I can tell will run forever consuming cpu time. This has been a consistent and repeatable issue. As I said, the entire library already has BIF files generated (or at least the scheduled task progress bar disappears after a few minutes).
  11. Every morning when I get up my server's fans are going full speed (which only usually happens during transcoding). A quick look into task manager's performance tab shows that my I5-4670K is CONSTANTLY running at 99% (which NEVER happens). I then take a peek at the processes tab and the culprit is media browser server. If I kill the application the CPU performance returns to normal and the fans return to their normal morning silence. I LOVE media browser, but I'm afraid it's going to blow up my computer. This happens every morning since I've updated to server version 3.0.5518.7. Also new with 3.0.5518.7.... My Roku gets stuck on the loading screen until you reboot it and all of my live TV channels have the same channel logo. If i re-install the previous sever version, everything works perfectly until it automatically updates its self back to 3.0.5518.7 and then the problems start all over again. Please Help!!!! server-63561110400.txt
  12. I am running 4 rokus and they all have the same issue. After a recent server update (there have been a few lately) my rokus have not been suggesting movie titles as it did before. 1. It is only suggesting unplayed content rather than titles from the full library as it did before. 2. It is only suggesting based on the last movie played rather than cycling through the last 5-7 when I clicked ok on the suggest movie based on tile. Is there a setting I don't know about? Can't find anything. Roku Emby version 2.2 build 4 Server: 3.0.6020.0 Danke. -M
  13. I currently have a HTPC WMC with xbox 360 extender set up. I am looking to move to the following setup: Surface Pro 2 as a dedicated HTPC, Ethernet into my router. Roku ethernet client. I will need a NAS or other storage to store all my media, obviously the Surface Pro will not cut it. It will not be the server, just the storage. What do you recommend? I would like to use Live TV a lot (currently have an hdhomerun setup). Any recommendations while I try to set this up?
  14. i have internal and external family members that use Roku's. If any of them leave the options at default in the app that means theme music will play but set to not repeat. The server web client reports them playing the theme song even when they are currently playing a movie or tv episode. The activity display flashes between the real item they are playing and theme song which has reached the end but never disappears. Server Version 3.0.5464.40000 and Roku 1.72 or 1.75. Please fix this when you have time as I don't mind them wanting to use that feature but I have noticed some consistency to the server going unresponsive when one of these theme songs is stuck in activity. For now I made sure all my Roku users turn off theme music. Nothing in the logs that I could find.
  15. Hi Team, It seems each time I have set up EMBY on my Linux Mint MATE 17 AMD64, i can stream from any browser on a computer but then it fails when trying to play from an App (Rolu, android phone, Android tablet.) Server: Linux Mint 17 (Ubuntu 14.04) EMBY Version 3.0.5621.4 Roku 2: <- does not work EMBY verision 2.07 - sided loaded from this link Android phone: <- does not work Note 2 OS: CyanogenMod 12-20141220-UNOFFIXIAL-t0ltatt App: Emby for Android Works: Windows 8.1 IE 11 Chrome: version 43.0.2357.81 m Things i have tried: Fresh install of my OS each time I reinstalled EMBY Tried installed per Debian direction Tried installing per Ubuntu 14.4 direction Tried installing per docker Tried installed with my user verse using the emby user Stood up WIN7 VM, installed EMBY and confirmed both ROKU and Android phone can stream from it tried to figure out how to dongrade MONO and was unsuccessfuly tried disabling DLNA RokuTelnetLogs.txt server-63568686904.txt transcode-734416ed-7cd1-453c-8e38-1bcd0f9c8f47.txt
  16. FreedomRydr

    Roku Media Selection

    Hi. New to Emby. I installed this server controller so I could view my media, Photos, Videos and Music. In setting up media locations, I only find ability to load single files not folders and subfolders. I have thousands, no, tens of thousands of photos, videos and music albums. How do I set it up so it will read entire parent folders, rather than having to add one file at a time? It would take literally months of adding one file at a time for every photo, song, or video file. Other apps allow folders, and reads all content in sub folders below it but I do not find this option in the dashboard. Anyone know if this can be done? Otherwise this setup was all in vain! Thanks ~FR
  17. eglorioso

    No Playback on Any Device

    I can not get Emby Server to playback on any device, here's my config - log file attached: Windows 7 Professional Emby Server 3.0.5786 ServerWMC 1.0.0.67 Clients; Roku, Android Mobile, Local Chrome Browser, Remote Chrome Browser, Remote Microsoft Edge Browser, Theater Roku Client Crashes, All Browsers and Android app continually spins as if it's trying to load the channel, Theater No Guide and Spins Clicking "Now Playing". Server was reinstalled, and initially played on "Now Playing" from local server but quit after ServerWMC was installed and configured. server-63588664929.txt
  18. chazgee

    Roku Playback Issue

    Hi, I installed this a few hours ago on my MacBook Pro and Roku 1. The Roku 1 connects to and sees all the media in my folder, even creating thumbnails from the media. But once I press Play, the blue "retrieving" bar gets just under half way across and freezes. It stays like that for a minute or two, then returns to the previous screen. A transcode log is created, but no transcodes are created in the "transcoding-temp" folder. I've tried AVIs, MOVs & MP4s using an h264 or MP4 codec. Please note that if there's a preferred codec / wrapper combo that would make streaming easier or more efficient, please let me know as I would have no problem transcoding my files as needed to accommodate the process. As instructed, I'm attaching the server log and transcode log. Any help would be appreciated. Thanks, Chaz server-63588030976.txt transcode-d0856d29-1297-4f13-8946-1b69116bbd0e.txt
  19. I created a music playlist on the Emby Server and it plays all the songs correctly on my Roku 3. However, after the first song finishes playing and the next song begins to play, the information (metadata) for the first song continues to be displayed. The first song information is displayed through the entire playlist (until the Roku screensaver comes on). Is there an easy fix to make the Roku display info for the song that is currently playing?
  20. AsianEd

    Subtitles not transcoding

    I'm not really sure how to troubleshoot this behavior. I noticed today that some files with embedded subtitles (.mkv container) are not transcoding with the subtitles and playing properly on my Roku3. Oddly, these same files played with the subtitles transcoded and burned in just a few weeks ago. Did something change in the server to cause this to happen? My server is running 3.0.5800.3
  21. For those that have a Roku player in Australia you can now set an Australian Time zone as of build 9021 (version 7.0) The benefits of which are; - On the Roku you can display the correct time. - Inside the Emby client for Roku you can display the correct time. - Live TV in the Emby client now displays correct programme running times (this was a huge annoyance for me)
  22. I recently installed the Enby app for roku. I can connect to the server, see all of my folders, series, episodes etc. but when I click on an episode or movie to play, it shows a progress bar to indicate that it is loading/buffering and stops halfway through and then reverts to the previous page. Any help would be appreciated.
  23. TheRealGrale

    Connecting Roku Emby externally over HTTPS

    Ok so I'm not a network novice, but clearly I am missing something here. I've searched the forums and have only found mention of using http port 8096 for external connections. None of the documentation/posts I have seen specifically speak of using https, which I would like to use if possible. The firewall on my 2008r2 server has the proper ports all opened, the exe is also allowed access, and the port forwarding rules are in effect on my modem. On the web console of EMBY it even reports "Remote Access: https://xxx.xxx.xxx.xxx:8920. Now when I go to my EMBY Roku app, it doesn't matter if I enter https://:xxx.xxx.xxx.xxx or just the IP and then use 8920, the Roku will not connect, it gives the following error: We were unable to connect to this server. Please make sure it is running and try again. HTTPS works from a web browser, but it will not work from the EMBY Roku, nor the EMBY client for android. Now I know all is working on the server/firewall side because if I go back and connect using the IP and use 8096, boom, connects and works both Roku and droid clients. I am using the latest release of EMBY server, as of this writing, and I have removed and reinstalled the EMBY Roku client just to be sure. Can the roku connect over HTTPS and if so what am I missing? Thanks guys! P.S. EMBY ROCKS!
  24. dguilmore

    Unable to connect to server

    I have both Media Browser channels in the Roku Channel Store and another older one I got 2 years ago from private channels. My server always connected to all of them before the server updates last week. Channels are version 1.78, 1.84 & the official ch. I cant get Media Browser to connect to my server since last update. I became a supporter and it links my account, but says unable to connect to server on my Roku. Wont play in Netgear anymore either. That one says Media Browser (Offline). Still plays in my browser. Please help. Would it still play in browser if I pasted the activation key wrong? Also my Roku doesn't show up in the selected play to devise area.
  25. ginjaninja

    Emby for Roku

    Emby For Roku Setup Guide Assumptions The Author only had access to a Roku 3 (Model 4200X Software v5.4 2240) . It is assumed that all Rokus behave in the same way in respect of this guide.Prerequisites Install EMBY Server. Create an EMBY User. Optionally (and recommended) make user an EMBY Connect User (by registering on community forums and adding the valid MB community username to the user account under server configuration and authorising via email) http://emby.media/connect/ Follow the Roku product installation instructions to register your email address/Roku account. Ensure the Roku has a valid IP route to your EMBY server and ensure the necessary rules are applied on any intermediary firewalls. See Client<>Server Connection Troubleshooting. Guide Chapters Adding EMBY Channel to Your Roku. Connect EMBY Roku Client to EMBY Server Client<>Server Connection Troubleshooting. Note many of the pictures in this guide need updating for the latest version and new product name. Media Browser is now EMBY
×
×
  • Create New...