Jump to content

Search the Community

Showing results for tags 'Debian'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 68 results

  1. dual-o

    https on Debian VPS ist not working

    Hello Guys, facts: installed emby on a debian vps. allow 8096 and 8920 in ufw buy a Domain at namecheap. create A Record for the VPS IP. create a letsencrypt cert (https://emby.media/community/index.php?/topic/42315-creating-a-letsencrypt-ssl-certificate-for-emby/ Emby config: add certfolder to /opt/emby-server/ssl/ssl.pfx Emby config: add external Domain "https://xxx.xxx" Problem: I got emby over "http://xxx.xxx:8096"but on "https://xxx.xxx:8920" I got "ERR_TUNNEL_CONNECTION_FAILED" can you help me with this issue? thanks
  2. cghouly

    Debian 9 x86 missing dependencies

    I have been working on a solution to get emby-server installed on my small living room computer. It is an x86 machine root@debian:/home/user# uname -a Linux debian 4.9.0-4-686-pae #1 SMP Debian 4.9.65-3+deb9u1 (2017-12-23) i686 GNU/Linux I have added the repo from here, and tried installing from the install instruction from the main downloads page for linux. Both ways complain about unmet dependencies. root@debian:/home/user# apt-get install emby-server Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libembysqlite3-0 but it is not installable Depends: embymagick but it is not installable Depends: mono-devel (>= 4.6) but it is not going to be installed E: Unable to correct problems, you have held broken packages. I confirmed the mono packages are installable. My main concern is the two packages that are not installable (libembysqlite3-0 and embymagick). Looking at the repo I notice that they are both missing. I searched both packages in https://build.opensuse.org and found libembysqlite3-0 and embymagick. Unfortunately embymagic build failed for x86_64 for debian 9. I am at a loss on how to proceed. Any way x86_64 builds for Debian 9 can be fixed in the repo?
  3. ThermoDust

    Metadata Manager Blank

    Problem is the metadata manager is showing blank. https://1drv.ms/i/s!AtItXRNac1nKhopn5VBM5idumQ4K1g I tried removing the libraries and readding them. The scan shows complete. I rebooted a few times and still nothing. When you go into the meta data manager it shows blank. Log: https://1drv.ms/t/s!AtItXRNac1nKhopmXTJpmqpBV87EbQ
  4. tcm

    Consistent CTD on Deb Squeeze

    greets. emby fresh debian 9 install (and reinstall) libraries for epub, video and audio via NAS SMB consistent crash withiin moments requiring service emby-server restart. two most recent log files attached. assistance greatly appreciated, tnx! ~tcm server-63652982530.txt server-63652982708.txt
  5. doonze

    Best setup for transcoding on Linux

    So, I'm running an older low end gateway duel core system as my server. I'm running Debian 9, and don't plan on switching to anything else. While this works for my day to day needs, it can only really transcode one stream at a time. And makes a lot of noise from fans to do so. What I'm trying to get my head around is what hardware Emby can take the best advantage of running under Linux for transcoding multiple streams. I would like to have a system that could transcode 3-4 streams and keep up. My starting point would be a 8 Core processor with 32 GB ram transcoding on a SSD. What processor extensions do I need to look for that Emby can take advantage of? What's the best hardware acceleration to use? AMD better or Intel? Any motherboard hardware that can help? Can Emby take advantage of any GPU processing? If so, what cards are best? Mainly I want to make a big bad Emby streaming monster. But not sure what Emby can best take advantage of. Anyone who knows transcoding better then I do got any opinions? Thanks!
  6. Big user of Emby here, but about 2 months ago I've came across a problem that really screwed me over. I installed Emby via the third party repository (now you get Emby with a .deb file), and after a failed Emby upgrade, Emby's repository messed with my dependencies, deleting core system packages in the process. My system was a Debian server on version 9.1. Luckily I had backups, so I reinstalled, but I did not install Emby because I was scared of losing my dependencies again. Now I'm Emby-less. So devs, can you please consider getting Emby into the official repositories for major distributions? This will make installing Emby a lot less of a hassle and ensure a more stable system. Thank you.
  7. adam.niescierowicz

    Multiversion crash emby 3.2.33.13~beta+298.3

    Hi, I have added couple of video version to test multiversion with diffrent bitrate. Emby recognize video files and added them in one position with diffrent bitrate - so far good. After I change connection speed to lower value in the kodi, video stop working. In the server logs I found the following error: https://pastebin.com/y4Y83wwN
  8. hello so I have both a web server and emby running on the same network with one public IP so I have emby running through a reverse proxy to put it on a subdomain of my url in the share links emby generates a url as if it were the only thing on my network to be used for sharing if I try to tell it what url its on through the public url box it breaks the reverse proxy because then emby tries to bind to that. could you add a feature where you can tell emby what url its running at so that share urls work without it trying to bind to it incase you have something else managing that? also in the near future I will be building a server good enough to have both emby and my apache web server on the same machine (this machine also has zoneminer on it) so emby will have to be runnning on a different port from 80 because apache will be already be using it so the share urls will really be messed up then unless there is someway for me to tell emby that it is running on media.98seaturtles.net but just tell it to use that for self identification but actually run on localhost:8080 so I can use apache to deal with the subdomain if you have any advice it would be greatly appreciated
  9. ThermoDust

    Interpreting log - Transcoding w/ Quicksync

    /usr/bin/ffmpeg -ss 01:34:18.000 -i file:"/srv/b2e24e20-856e-4b9e-9fa5-c504efb2b7cc/Media/Movies/Ratatouille (2007)/Ratatouille (2007).mp4" -map_metadata -1 -map_chapters -1 -threads 0 -map 0:0 -map 0:1 -map -0:s -codec:v:0 libx264 -pix_fmt yuv420p -preset veryfast -crf 23 -maxrate 2871711 -bufsize 5743422 -profile:v high -level 4.1 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -force_key_frames "expr:gte(t,n_forced*3)" -vf "scale=trunc(min(max(iw\,ih*dar)\,1920)/2)*2:trunc(ow/dar/2)*2" -copyts -vsync -1 -codec:a:0 copy -f segment -max_delay 5000000 -avoid_negative_ts disabled -start_at_zero -segment_time 3 -segment_time_delta -5658 -individual_header_trailer 0 -segment_format mpegts -segment_list_type m3u8 -segment_start_number 1886 -segment_list "/var/lib/emby-server/transcoding-temp/3b94f4fbda40e23c54cb9833a1b959d6.m3u8" -y "/var/lib/emby-server/transcoding-temp/3b94f4fbda40e23c54cb9833a1b959d6%d.ts" I am trying to figure out if my system is using quicksync. If I am reading that line correct, it isn't telling FFMPEG to use hwaccel. Is that normal for the transcoding with hardware acceleration? Emby Version 3.2.26.0 Logs: https://1drv.ms/f/s!AtItXRNac1nKhfBw9ih_VuIY2XJFJA Emby Version 3.2.26.0
  10. ThermoDust

    ANSWERED Can't Switch FFMpeg Version

    I am trying to switch to the system install version of FFMpeg and it won't let me. Every time I refresh the page after saving changes it goes back to custom.
  11. Hi, I had to rebuild the server that I've been running Emby on, and I'm trying to use the server configuration backup plugin to migrate everything. However, when I try to run the restore on the backup, nothing happens. In the attached log file, it looks like there is an error associated with the restore request on line 2320 and again on line 2535. Hopefully that helps identify what is wrong with my setup. Thanks, Jonathan EmbyLog.txt
  12. tymanthius

    API key changes every time I update

    I'm on the beta, and every time I apt-get upgrade the api changes. This is a huge annoyance as I use the Ombi requests system that relys on the api. any idea why this is?
  13. nickola2

    Gestion des fichiers

    Bonjour tout le monde ! J'ai une question : Nouvel exploitant d'Emby serveur, je me suis amusé sur un debian v8 à configurer et installer mon propre serveur torrent (pour les vidéos de vacances que je partage avec ma grand-mère évidement), auquel j'ai installé le serveur média Emby. Alors tous est niquel, Emby fonctionne parfaitement et tout est bien dans le meilleur des mondes. Mais j'ai quand même un truc qui me dérange à la longue. Chaque fois que je télécharge un fichier qui n'est pas une vidéo, j'ai celui-ci qui se retrouve dans ma liste de média (vu que j'ai indiqué à Emby, comme vous l'avez également fait, de regarder la ou se trouve mes torrents) apparaît comme étant un film (alors que ça n'a rien a voir avec un film...). Et mon père a qui j'ai configuré un accès à mon serveur Emby, comment dire... ne fera pas la différence dans la liste entre le super film de vacances en famille et l'iso de debian que je viens de télécharger, par exemple et de ce fait va essayer d’ouvrir ce dernier pour le regarder (oui je sais, pas facile de coupler la famille et l'informatique). Donc ma question : Quelqu'un sait comment dire à Emby d'afficher et traiter uniquement les formats vidéo qu'il trouve sur le serveur et laisser de côté tout autre format ? Vous seriez au top si vous m'apportez cette réponse Et je dispose d'un abonnement premium Emby si jamais c'est lié. Merci chère communauté et je reste très actif sur vos éventuelles réponses !
  14. tymanthius

    Debian Beta is no longer updating from repo

    I recall this happened a few months ago, and I'm running into again now. Emby Dashboard shows I'm running 3.2.15.1 and that 3.2.15.5 is currently available. Yet when I run apt-get update & apt-get dist-upgrade, nothing is found. It's done this on all the incremental updates from *.1 to now. If anyone else is having this issue, I'd love to know it's not just on my end.
  15. Hello, using the latest versions (if I mistake not from 3.2 onwards) of Emby on Debian Jessie, if I use the command "systemctl stop emby-server" Emby does not stop gracefully and "Main" process remains alive. The only way to stop Emby is killing the process with the "kill" command. This problem is related to how systemd stops the processes and probably in the last updates you have been changed the start script "/usr/bin/emby-server" or systemd unit configuration file "/lib/systemd/system/emby-server.service". Sorry for my bad English. Thank you for your wonderful work. Carlo
  16. Hello there, I've been using multiple Emby server instances for quite a while now and I tried my luck with Amazon Cloud Drive (later referred as ACD). Basically I've tried everything I could, but it seems like that Emby is (currently?) not in a state, that it can be used with ACD without issues. First, let me show you my current setup. I try to provide as many details as possible. Hardware: CPU: Intel® Xeon® CPU E31275 @ 3.40GHz RAM: 32GB ECC Disk: 2x Seagate Cheetah 15K.7 300GB, SAS 6Gb/s (ST3300657SS) - running as RAID 1 on a LSI MegaRAID SAS 9260-4i with 512MB RAM. OS and application versions: OS: Debian Jessie Stable - Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux Emby: emby-server - 3.1.2-12.1 embymagick:amd64 - 6.9.6+6-7.1 libembysqlite3-0:amd64 - 3.15.0+1-7.1 libsqlite3-0:amd64 - 3.15.2-1 (acd_cli is using it, that's why I'm providing information to it) nginx (used as reverse proxy to provide a SSL encrypted connection to the Emby server without the need to create a pfx file): nginx - 1.6.2-5+deb8u4 nginx-common - 1.6.2-5+deb8u4 nginx-full - 1.6.2-5+deb8u4 That was the basic information - now let me show you, how I actually mount my ACD: Using acd_cli (https://github.com/bgemmill/acd_cli): acd_cli -nl mount --modules="subdir,subdir=/Storage" /mnt/acd/ --allow-other --umask 000 --interval 0 After running this command I have everything located in the storage folder on ACD in /mnt/acd This looks like (output of ls -l /mnt/acd): drwxrwxrwx 1 root root 0 Dec 29 07:38 animatic drwxrwxrwx 1 root root 0 Dec 10 20:31 anime drwxrwxrwx 1 root root 0 Dec 10 20:31 audiobooks drwxrwxrwx 1 root root 0 Jan 1 16:11 documentary-series drwxrwxrwx 1 root root 0 Dec 31 23:02 documentary-single drwxrwxrwx 1 root root 0 Dec 10 20:31 podcasts drwxrwxrwx 1 root root 0 Dec 29 16:12 series drwxrwxrwx 1 root root 0 Dec 10 20:31 series-en While having it mounted, I'm using rar2fs (https://github.com/hasse69/rar2fs) to make the media files in the RAR folders readable for emby: rar2fs --flat-only --no-expand-cbr --seek-length=1 --hist-size=40 --iob-size=32 -o max_readahead=4096M -o allow_other -o umask=000 /mnt/acd/animatic /mnt/rar2fs/animatic rar2fs --flat-only --no-expand-cbr --seek-length=1 --hist-size=40 --iob-size=32 -o max_readahead=4096M -o allow_other -o umask=000 /mnt/acd/anime /mnt/rar2fs/anime rar2fs --flat-only --no-expand-cbr --seek-length=1 --hist-size=40 --iob-size=32 -o max_readahead=4096M -o allow_other -o umask=000 /mnt/acd/documentary-single /mnt/rar2fs/documentary-single rar2fs --flat-only --no-expand-cbr --seek-length=1 --hist-size=40 --iob-size=32 -o max_readahead=4096M -o allow_other -o umask=000 /mnt/acd/documentary-series /mnt/rar2fs/documentary-series rar2fs --flat-only --no-expand-cbr --seek-length=1 --hist-size=40 --iob-size=32 -o max_readahead=4096M -o allow_other -o umask=000 /mnt/acd/series /mnt/rar2fs/series rar2fs --flat-only --no-expand-cbr --seek-length=1 --hist-size=40 --iob-size=32 -o max_readahead=4096M -o allow_other -o umask=000 /mnt/acd/series-en /mnt/rar2fs/series-en This results in the following structure (output of ls -l /mnt/rar2fs): drwxrwxrwx 1 root root 0 Dec 29 07:38 animatic drwxrwxrwx 1 root root 0 Dec 10 20:31 anime drwxrwxrwx 1 root root 0 Jan 1 16:11 documentary-series drwxrwxrwx 1 root root 0 Dec 31 23:02 documentary-single drwxrwxrwx 1 root root 0 Dec 29 16:12 series drwxrwxrwx 1 root root 0 Dec 10 20:31 series-en So far for the media files. Also I made some RAM partitions to maximize the performance of Emby and ACD. ACD stores it's cache (the node info and so on) in a folder called .cache, located in /root. For Emby itself I have changed some paths to fit my needs: Cache: /opt/emby/cache Logs: /var/lib/emby-server/logs Metadata: /opt/emby/metadata Transcoding temporary files: /opt/emby/transcoding-temp So, I created three RAM "drives" with tmpfs, which are used as following: acd_cli db: tmpfs 1.5G 198M 1.4G 13% /root/.cache emby folders: tmpfs 12G 2.3G 9.8G 19% /opt/emby tmpfs 3.0G 301M 2.8G 10% /var/lib/emby-server As you can see, there is still plenty of free space available. Just for the sense of completeness: I sync these folder every three minutes to disk. Also I adjusted the mounts to increase I/O performance (output of /etc/fstab) - I removed the UUIDs: UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx / ext4 noatime,errors=remount-ro 0 1 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /boot ext4 noatime,errors=remount-ro 0 1 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /tmp ext4 relatime,rw,nosuid,nodev 0 2 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /var ext4 relatime,rw 0 2 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /home ext4 noatime,rw,nosuid,nodev 0 2 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /opt ext4 noatime,defaults 0 0 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx none swap sw 0 0 tmpfs /var/lib/emby-server tmpfs noatime,defaults,size=3072M 0 0 tmpfs /opt/emby/ tmpfs noatime,defaults,size=12288M 0 0 tmpfs /root/.cache/ tmpfs noatime,defaults,size=1536M 0 0 For ACD I have no possibility to specify additional parameters such as noatime or relatime to increase the performance. Next is my nginx config for Emby (output of /etc/nginx/sites-available/emby) - I removed the real URL as I want to keep them private: server { server_name mydomain; listen 80; rewrite ^ https://mydomain$request_uri? permanent; } server { server_name mydomain; listen 443 ssl spdy; ssl_certificate /etc/letsencrypt/live/mydomain/cert.pem; ssl_certificate_key /etc/letsencrypt/live/mydomain/privkey.pem; ssl_prefer_server_ciphers On; ssl_protocols TLSv1 TLSv1.1 TLSv1.2; ssl_ciphers 'AES256+EECDH:AES256+EDH:!aNULL'; ssl_stapling on; resolver 8.8.8.8 8.8.4.4 valid=300s; resolver_timeout 5s; ssl_stapling_verify on; keepalive_timeout 180; # This is for strict transport security HSTS # add_header Strict-Transport-Security max-age=31536000; client_max_body_size 1024M; location / { # Send traffic to the backend proxy_pass http://127.0.0.1:8096; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-for $proxy_add_x_forwarded_for; proxy_set_header Host $host; proxy_set_header X-Forwarded-Proto $remote_addr; proxy_set_header X-Forwarded-Protocol $scheme; proxy_redirect off; # Send websocket data to the backend aswell proxy_http_version 1.1; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; } } Additional I made some kernel improvements to increase the TCP performance (output of /etc/sysctl.conf): net.core.rmem_max = 33554432 net.core.wmem_max = 33554432 net.ipv4.tcp_rmem = 4096 87380 33554432 net.ipv4.tcp_wmem = 4096 65536 33554432 net.ipv4.tcp_no_metrics_save = 1 net.core.netdev_max_backlog = 5000 net.ipv4.tcp_congestion_control = cubic Last but not least I modified the mono environment variables: MONO_THREADS_PER_CPU=2048 MONO_GC_PARAMS=nursery-size=2048m Currently I don't use any 3rd party plugins for Emby. My media collection is currently 6.8TB, which are mostly SD files and only series, no movies (I run another Emby server for that, which runs perfectly fine, as everything is stored locally ). I disabled realtime monitoring and extraction of chapter images on all folders in Emby. The only options I enabled in the library scan options are: - Download artwork and metadata from the internet - Download images in advance I disabled everything completly for documentary-single as there is no metadata to find on almost all episodes anyway. --------- I think that is all I can do to increase the perfomance from my side, however I experience a lot of issues using Emby in combination with ACD. I expected the first media scan to take quite a while, which is quite usual I asume. But upon the second scan it should be way faster - I think - which wasn't the case at all. Everytime I add new content - and if it's only one single episode - it takes several hours to a few days to complete the scan. The scheduled task Clean Database stucks at 45% for quite a few hours now. My questions are now as follows: - How does Emby actually determine new content? Is it going through each folder, even if it is already known, and checks if there is new content available? - Does it rely in anyway of a modification, access or create date to determine new content? - Is there anyway on my side, how I can increase the performance? - Would it might be possible to experiment with Amazon Cloud Drive at all, to get it working for everybody? I would be happy to help testing and collect ideas. Thanks for reading that far, if anything is needed, please let me know. I did not write this as an actual "please help me community" post, more like "hey @@Luke can you help me?" post All others: If you are not experienced with Linux, please don't try this setup, as it takes advanced Linux knowledge to run and maintain such a system. Oh and @@Luke: I can provide logfiles for you via PM, if you need them or anything - just let me know. Also I'd be more than happy to have a realtime chat or similar with you to exchange information! Thanks for all the good work on that project from everybody, who contributed! Regards, Steffen
  17. bhelm

    OGG and webplayer transcoding

    I would like to listen to 320Kbit OGG Audio and have two problems with that: 1. in Firefox 51 (linux, fresh profile, no addons, without nginx ssl proxy), there is no audio at all. song is stuck at 0:00. I can see the emby server transcoding in the logs. Playing mp3 works. 2. in Chromium (linux too) there is audio playing, but the OGG is transcoded to aac. is there a known problem with firefox and playing aac? can direct streaming of the ogg be enabled? i think chromium is able to play OGG. using latets emby on up-to-date debian jessie and with https. also using it behind nginx reverse ssl proxy because mono still seems to be unable to provide the certificate chain correctly?
  18. Hello, I'm running beta version 3.1.2 and emby server notify me of 3.1.5 available but apt is not updating the package. When I crawl the repository at " http://download.opensuse.org/repositories/home:/emby/Debian_8.0/"I can see that stable number version (3.1.5) is higher than beta (3.1.2) . Beta is not available any more ? Can I switch to stable on the fly or I will have to do a clean new installation ? thanks EDIT: really strange, I am not with emby-server-beta but with emby-server btw apt is not updating the package. dpkg -l | grep emby-server ii emby-server 3.1.283~beta-13.1
  19. vlehemonet

    Error ImageProcessor: Error encoding image

    Hi Community, Since I've migrated to the version 3.0, I have some issues with the Fanart/Logo/ect. Sometime, with no reason, I loose images for a couple of movies/TV show. "Save artwork and metadata into media folders" is check "Download images in advance" is check too If I check in my folder I can see all artwork. I tried to download images manually and I get the same behavior. Someone have an idea how I can fix this ? OS : Debian 3.16.0-4-amd64 (Promox VM) Emby Version : 3.1.1.0 (Upgrade to 3.1.2 in progress) All my media are stored in a Synology NAS shared by SMB Thanks, Here is the log for one movie : 2016-12-28 17:59:47.8502 Error ImageProcessor: Error encoding image *** Error Report *** Version: 3.1.1.0 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.16.0.4 64-Bit OS: True 64-Bit Process: True Mono: 4.6.2 (Stable 4.6.2.7/08fd525 Mon Nov 28 20:21:32 UTC 2016) Processor count: 4 Program data path: /var/lib/emby-server Application directory: /usr/lib/emby-server/bin ImageMagickSharp.WandException: Empty input file `/films/Scarface-fanart.jpg' @ error/jpeg.c/JPEGErrorHandler/322 at ImageMagickSharp.WandCore`1[T].CheckErrorBool (System.Int32 status) [0x00009] in <256b1c1ea9f54fe39d5f58f7aa82a335>:0 at ImageMagickSharp.MagickWand.OpenImage (System.String path) [0x0000d] in <256b1c1ea9f54fe39d5f58f7aa82a335>:0 at ImageMagickSharp.MagickWand..ctor (System.String path) [0x0003e] in <256b1c1ea9f54fe39d5f58f7aa82a335>:0 at Emby.Drawing.ImageMagick.ImageMagickEncoder.EncodeImage (System.String inputPath, System.String outputPath, System.Boolean autoOrient, System.Int32 width, System.Int32 height, System.Int32 quality, MediaBrowser.Controller.Drawing.ImageProcessingOptions options, MediaBrowser.Model.Drawing.ImageFormat selectedOutputFormat) [0x00028] in <f25a1d2d1bea480290baedeb7321f941>:0 at Emby.Drawing.ImageProcessor+<ProcessImage>c__async1.MoveNext () [0x005de] in <48827399e75c4c4c9a1168c775b931ee>:0 ImageMagickSharp.WandException at ImageMagickSharp.WandCore`1[T].CheckErrorBool (System.Int32 status) [0x00009] in <256b1c1ea9f54fe39d5f58f7aa82a335>:0 at ImageMagickSharp.MagickWand.OpenImage (System.String path) [0x0000d] in <256b1c1ea9f54fe39d5f58f7aa82a335>:0 at ImageMagickSharp.MagickWand..ctor (System.String path) [0x0003e] in <256b1c1ea9f54fe39d5f58f7aa82a335>:0 at Emby.Drawing.ImageMagick.ImageMagickEncoder.EncodeImage (System.String inputPath, System.String outputPath, System.Boolean autoOrient, System.Int32 width, System.Int32 height, System.Int32 quality, MediaBrowser.Controller.Drawing.ImageProcessingOptions options, MediaBrowser.Model.Drawing.ImageFormat selectedOutputFormat) [0x00028] in <f25a1d2d1bea480290baedeb7321f941>:0 at Emby.Drawing.ImageProcessor+<ProcessImage>c__async1.MoveNext () [0x005de] in <48827399e75c4c4c9a1168c775b931ee>:0
  20. silver12

    unmet dependencies - raspberry pi

    Hello, I'm trying to install emby on Raspberry Pi 3. Both Ubuntu-mate and Rasbian give me the exact unmet dependencies error: root@raspberrypi:# apt-get update && apt-get install emby-server The following packages have unmet dependencies: emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed Depends: libmono-system-transactions4.0-cil (>= 1.0) but it is not going to be installed Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed Depends: mono-devel (>= 1.0) but it is not going to be installed Recommends: libembymagickwand-6.q8-2 but it is not installable E: Unable to correct problems, you have held broken packages. root@raspberrypi:# apt-cache policy libembymagickwand* libembymagickwand-6.q8-2: Installed: (none) Candidate: (none) Version table: Also tried the following solutions: https://emby.media/community/index.php?/topic/29622-unmet-dependencies-imagemagick-6q8/ https://emby.media/community/index.php?/topic/28188-massive-update-for-debian-and-ubuntu/ root@raspberrypi:# apt-get remove --purge libmagickwand-6.q8-2 libmagickcore-6.q8-2 Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package libmagickwand-6.q8-2 E: Couldn't find any package by regex 'libmagickwand-6.q8-2' E: Unable to locate package libmagickcore-6.q8-2 E: Couldn't find any package by regex 'libmagickcore-6.q8-2' Is it currently possible to install emby-server on Debian/Rpi? Cheers,
  21. DzonDou

    Missing music artists

    Dear Emby Community. I can not see artists and album artists in any of emby client (chrome, android, kodi) while I can see it in Metadata Manager tree. Songs and albums are showing property in all clients. It is fresh installation of Emby Server, version 3.0.64000.0 on Debian Jessie. I have proper ID3 tags (I suppose). Music is kept in mp3, wma and flac files. It is stored on xfs partition. I run emby as non-default user - changed EMBY_DATA variable. I have also changed location of EMBY_DATA folder. All file permissions are OK.
  22. ytzelf

    Mono 4.4.2.11 - known issues

    Hello everyone, So mono 4.4.2.11 is available on Devian Jessie. Considering last mono update was kind of a mess I'd like to know if any of you have been experiencing issues with this new update before updating? Is everything working fine? Thanks everyone
  23. Emby has gotten progressively worse for me over the last few updates. It seems whenever I connect via the Emby android app over 4G the server quits responding for everyone, and the logs show nothing. Now, however, the Emby server will not start and throws some nasty errors! InnerException: System.Net.Sockets.SocketException Address already in use at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) <0x41b9ba20 + 0x000ef> in <filename unknown>:0 at SocketHttpListener.Net.EndPointListener.CreateSocket () <0x41b996a0 + 0x000bf> in <filename unknown>:0 at SocketHttpListener.Net.EndPointListener..ctor (SocketHttpListener.Net.HttpListener listener, System.Net.IPAddress addr, Int32 port, Boolean se cure, System.Security.Cryptography.X509Certificates.X509Certificate cert, ILogger logger) <0x41b992f0 + 0x00227> in <filename unknown>:0 at SocketHttpListener.Net.EndPointManager.GetEPListener (ILogger logger, System.String host, Int32 port, SocketHttpListener.Net.HttpListener list ener, Boolean secure) <0x41b98db0 + 0x0035b> in <filename unknown>:0 at SocketHttpListener.Net.EndPointManager.AddPrefixInternal (ILogger logger, System.String p, SocketHttpListener.Net.HttpListener listener) <0x41 b98810 + 0x000bb> in <filename unknown>:0 at SocketHttpListener.Net.EndPointManager.AddListener (ILogger logger, SocketHttpListener.Net.HttpListener listener) <0x41b98310 + 0x00153> in <f ilename unknown>:0 This happens regardless of the fact that I've rebooted the system. Any assistance would be appreciated. Just became a lifetime supporter and love the product so I would like to see this working Also I would like a good way to roll back updates in the event that you guys break things again Any suggestions on where/how to get .debs for the previous versions?
  24. kentish

    ANSWERED Playback issue since upgrade

    Hi Been using Emby for a while now with out any problems or issues - which is nice! So this is my first post. Want to say that it's a cracking bit of software which really works for our family - a few kids, a few device and less arguments!! Running Emby on OpenMediaVault NAS and upgraded through the web ui after shutdown the service first. Current version server is 3.0.5985.0 OpenMediaVault version: 2.2.5 Stone Burner Also run a system upgrade at the same time and I believe this updated Mono to 4.4.1.0. After the playback issues presented I backup the installation using the Backup plugin then uninstalled, rebooted and reinstalled. Attached both Server and Transcode Log as ZIP files. Tested video playback on Web UI, Samsung TV (2015 model) via DLNA, Samsung Tablet via App and playback is smooth for 15 seconds and then jumps or the image gets corrupted then freeze. I have SAMBA providing path substitution on the single library that been added, I can access and play media from it with no issues - used VLC Music file seems unaffected Hope that's enough information and sorry if I posted in the wrong bit of the forum. Thanks Kentish Log - Transcode.zip Log.zip
  25. ytzelf

    ANSWERED Double emby process

    Hello everyone, I seem to have 2 emby processes running, one is running as root (dont want) with the correct MONO_THREADS_PER_CPU and MONO_GC_PARAMS arguments, and one running as emby user (all good) without these arguments. ps auxZ | grep emby root 784 0.0 0.0 46360 3224 ? Ss 12:59 0:00 su -s /bin/sh -c exec "$0" "$@" emby -- env MONO_THREADS_PER_CPU=250 MONO_GC_PARAMS=nursery-size=128m /usr/bin/mono-sgen --optimize=all /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh emby 894 2.5 4.5 1452236 370664 ? Ssl 12:59 1:43 /usr/bin/mono-sgen --optimize=all /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh Is having 2 processes normal? why is one running as root? And lastly, how do I fix this if it is indeed abnormal? How do I get 1 process with the cirrect arguments running as emby user? nano /etc/systemd/system/multi-user.target.wants/emby-server.service [Unit]Description=Emby Media Server After=network.target [Service] EnvironmentFile=/etc/emby-server.conf ExecStart=/usr/bin/emby-server start Restart=on-abort TimeoutSec=20 ExecStopPost=/usr/bin/emby-server clear [Install] WantedBy=multi-user.target nano /etc/init.d/emby-server !/bin/sh### BEGIN INIT INFO # Provides: emby-server # Required-Start: $remote_fs $local_fs $network # Required-Stop: $remote_fs $local_fs $network # Default-Start: 2 3 4 5 # Default-Stop: 0 1 6 # Short-Description: starts instance of Emby # Description: starts instance of Emby ### END INIT INFO # chkconfig: 2345 20 80 #The above indicates that the script should be started in levels 2, 3, 4, and 5, #that its start priority should be $ # Load the VERBOSE setting and other rcS variables . /lib/init/vars.sh # Define LSB log_* functions. # Depend on lsb-base (>= 3.0-6) to ensure that this file is present. . /lib/lsb/init-functions NAME=emby-server CONF_FILE=/etc/${NAME}.conf DEFAULT_FILE=/etc/default/${NAME} # Source Emby server default configuration . $DEFAULT_FILE # Source Emby server user configuration overrides if [ -f $CONF_FILE ]; then . $CONF_FILE else echo "${CONF_FILE} not found using default settings."; fi # Path of emby binary EMBYSERVER=/usr/bin/emby-server PIDFILE=${EMBY_PIDFILE-/var/run/emby-server.pid} case "$1" in start) log_daemon_msg "Starting $NAME daemon" if [ -s $PIDFILE ] && kill -0 $(cat $PIDFILE) >/dev/null 2>&1; then log_daemon_msg "apparently already running" log_end_msg 0 exit 0 fi exec $EMBYSERVER start & sleep 2 if [ -s $PIDFILE ] && kill -0 $(cat $PIDFILE) >/dev/null 2>&1; then log_end_msg 0 else log_end_msg 1 fi stop) log_daemon_msg "Stopping $NAME daemon" if [ ! -s $PIDFILE ] || ! kill -0 $(cat $PIDFILE) >/dev/null 2>&1; then [ -e $PIDFILE ] && rm -rf $PIDFILE log_success_msg "apparently already stopped" log_end_msg 0 exit 0 fi PID=`cat $PIDFILE` CPIDS=$(pgrep -P $PID) sleep 2 && kill -KILL $CPIDS kill -TERM $CPIDS > /dev/null 2>&1 sleep 2 if ! kill -0 $PID > /dev/null 2>&1; then rm -rf $PIDFILE log_end_msg 0 else log_end_msg 1 fi ;; status) status_of_proc -p $PIDFILE "$EMBYSERVER" "$NAME" exit $? # notreached due to set -e ;; restart|force-reload) $0 stop || exit $? $0 start || exit $? ;; *) echo "Usage: /etc/init.d/emby-server {start|stop|status|restart|force-reload}" >&2 exit 3 ;; esac Thanks
×
×
  • Create New...