Jump to content






Photo

Emby Server 3.1: Faster and Lighter than Ever Before

Posted by Luke , 29 December 2016 · 14244 views

A new release of Emby Server is currently rolling out. This new release has a lot of important bug fixes, as well as new features. It's also much faster than ever before and we think you're going to enjoy that. Let's go over the highlights.

 

New Levels of Performance

 

This release of Emby Server is faster than you've ever seen it. All areas will be improved including the following:

  • Faster browsing performance in all apps
  • Faster library scans
  • Faster scheduled tasks
  • For those running the Kodi sync plugin, the sync process will be faster as well
  • Faster playback start time
IPv6 now Supported on All Operating Systems

 

On Linux, this will require the mono 4.6 run time, which our Linux packages now ship with. This also requires that IPv6 be supported by the host operating system (Unraid for example does not support IPv6).

 

Subtitle Encoding Improvements

 

Several issues have been resolved related to subtitle encoding and display of special characters.

 

Separate Latest Media By Library

 

On the web app home screen, you'll now see separate rows of latest media for each library. On touch devices these rows can be swiped horizontally. This puts more content right at your fingertips.

 

Posted Image

 

Refreshed Detail Screen

 

It's now more consistent with our other apps, and makes better use of screen real estate.

 

Posted Image

 

More Live TV Seeking Support

 

Seeking Live TV is now supported in the web app in mobile Edge and Safari for Mac. This now brings the roster of supported browsers to:

  • Chrome
  • Firefox
  • Opera
  • Edge on all Windows 10 devices
  • All other Chromium based browsers (like Vivaldi).
  • Safari on Mac
Better Recording Schedule Images

 

The recording schedule screens will now make better use of images, making your DVR more fun than ever before.

 

Posted Image

 

New Recording Options

 

You now have the option to preserve original video when recording.

 

Posted Image

 

Recording Post-Processing

 

You now have the ability to run a post-processing application after completing a recording.

 

Posted Image

 

Redesigned Series Recording Management

 

The same great features, but now they look better than ever before.

 

Posted Image

 

Xml TV Movie Prefix Support

 

If your xml tv data applies prefixes to your movies, you can now specify this on the xml tv setup screen. This will allow Emby to better handle the prefix in relation to displaying the content and searching for internet metadata.

 

Other Improvements

  • New web app design for movies and tv by genre
  • Update tv guide presentation
  • Automatically adjust scheduled recordings to program changes
  • Reduce resource consumption used by device discovery
  • Remove audio channel count from web app transcoding conditions
  • Improve image & subtitle extraction
  • Update to 3.15.2
  • Update dlna music views
  • Improve m3u channel name parsing
  • Add guide auto-refresh
  • Display series images on episode detail screen when episodes have no images
  • Improve consistency of web app detail screen with Emby Theater
  • Improve automatic network switching from mobile web app
  • Move book support into Emby core
  • Support resuming audio books
  • Add per-library series pooling setting
  • Shorten episode display numbers
  • Improve Dlna Play To device detection
Bug Fixes
  • Resolve vaapi mpeg4 transcoding failure
  • Remove condition preventing video stream copy with Apple TV
  • Resolve display issue on dlna profile screen
  • Resolve music brainz provider issue causing the library scan to get stuck in certain situations



  • jasonmcroy, Crestj, porkbone and 13 others like this



Check each library in library setup to make sure the realtime monitor is enabled for the libraries you want it to be.

 

All individual libraries are enabled. Any other suggestions?

All individual libraries are enabled. Any other suggestions?

 

Hi, the best thing to do is follow the guidelines in how to report a problem, and we'll do our very best to help you. Thanks !

Wow!!! What a fantastic christmas gift!!! Thank you guys, you rule!!!

Hi, the best thing to do is follow the guidelines in how to report a problem, and we'll do our very best to help you. Thanks !

 

It appears that after multiple restarts of the server, the real-time monitoring functionality is now working properly. Pardon the false flag.

Hello

Still not available for synology
Is this normal?

Thank you

    • Bjorr likes this
Photo
Koleckai Silvestri
Dec 20 2016 08:44 AM

Hi, is sure does, if configured to do so. If this is not happening for a specific title, then let's go over a specific example and then we can tell you why it didn't happen.


Happens to me on every new title, television and movies, that i add to my library. I get banner, poster, art, and backdrops. Never get thumbnails. Have to manually add them after the fact.
Photo
monkeyslapper
Dec 20 2016 11:22 AM

Good job on the enhancements. What i am not sure on or why you would add it? Adding all the episodes of the series in side an episode. Seems very disorganized. Maybe a better idea to move the episode list below scene/chapter list.

 

Thanks for the update.

Looks like the swagger API documentation site isn't working. I get "one or more errors occurred" when I try to launch.  Server reboot had no effect.

 

relevant log data:

    InnerException: System.IO.DirectoryNotFoundException
    System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\EmbyServer\AppData\Roaming\Emby-Server\System\swagger-ui\index.html'.

topic posted in windows support...

Yeah, I didn't have the library image updates turned on in Movies (and TV). It hadn't been an issue before because the new media used to be displayed by thumbnail instead of by poster. But Luke was correct. Once I turned that on, the images came down. Now, that said, I do have an added step when I add a movie in that I have to go to Edit Images for it to check to see what it downloaded (sometimes it can't find one so I have to manually search or make one) instead of it slapping me in the face when I start up the Emby web client, but it's totally fine.

Seriously, this fast like a rocket! I am blown out, very smooth on my android phone, well-done guys I get to like the server every day!

When will the "Separate Latest Media By Library" feature have a disable function? There's been a thread about this for ages now.

Yes, smoother and faster on all my devices now, even on an old Vista box I use for a few of my tv shows (.net 4.6.1 workaround still working for Vista too, amazingly enough).

 

Great job guys.

Yes, smoother and faster on all my devices now, even on an old Vista box I use for a few of my tv shows (.net 4.6.1 workaround still working for Vista too, amazingly enough).

 

Great job guys.

 

Thanks for the feedback !

Hi, Im not seeing this update on my Synology (415+) yet.

 

i´m on Emby Version 3.0.8500.0 and in my Emby GUI it says I have a new version available and that I should go to my Synology DSM Package manager and update but when I do there is no update. 

 

Thanks

 

EDIT:

Read in this thread that it can take some time before it will be available because there is some testing involved before a new package goes out.

https://emby.media/c...missing-update/

My Upgrade wont work its seems there's a release file missing
this is what i get when I run apt-get update and the upgrade wont work either
 
I ran the following:
 
apt-key add - < Release.key
apt-get update
 
My Version is:
 
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:        16.04
Codename:       xenial
 
 
the error is: 
 
  404  Not Found [IP: 195.135.221.134 80]
Hit:7 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:8 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:9 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:10 http://security.ubuntu.com/ubuntu xenial-security InRelease
Reading package lists... Done
W: The repository 'http://download.open...y/xUbuntu_15.10  Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.open..._15.10/Packages  404  Not Found [IP: 195.135.221.134 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

 

  • Update dlna music views

I still have the problem that artists and albumartists are shown as a jpg file in my dlna app (BubbleUPnp) and therefore these links do not show albums.

I'm very disappointed that this bug isn't resolved, because I reported it a couple of times over the last year.

 

Secondly, the folder view is also still missing in dlna apps.

 

Joost

Hi!

 

Great update - when I read the release notes I guessed that the "New Levels of Performance" promise would mean 5% faster pageloads, or something barely noticeable without using a stopwatch/monitoring tool. Boy was I wrong... how the hell did you manage such a massive perforance increase? :)

 

I'm not regretting buying the lifetime Emby Premium license at all - keep up the great work!

 

My Upgrade wont work its seems there's a release file missing
this is what i get when I run apt-get update and the upgrade wont work either
 
I ran the following:
 
apt-key add - < Release.key
apt-get update
 
My Version is:
 
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:        16.04
Codename:       xenial
 
 
the error is: 
 
  404  Not Found [IP: 195.135.221.134 80]
Hit:7 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:8 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:9 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:10 http://security.ubuntu.com/ubuntu xenial-security InRelease
Reading package lists... Done
W: The repository 'http://download.open...y/xUbuntu_15.10  Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.open..._15.10/Packages  404  Not Found [IP: 195.135.221.134 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

 

 

Your error says that apt-get tries to get repositories for ubuntu 15.10. Maybe you added the wrong repository? Look in /etc/apt/sources.list.d/emby-server.list if you have 15.10 in there. If so, delete the emby-server.list, and add it correctly with the commands from the install instructions, then update and install.

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt-get install emby-server

Cant wait to see a monit in my Synology to be able to update :D

Hi Luke,

 

Great job for this update !

 

I would like to know if I update my server, my old path substitution will be still up or not?

 

I use the old system of path substitution (with a ftp server).

 

Thank you.

May 2020

S M T W T F S
     12
3456789
10111213141516
17181920212223
2425262728 29 30
31